+ Responder ao Tópico



  1. #1
    wagner.brasileiro
    Visitante

    Padrão Problemas com APT-GET

    Bom dia pessoal,



    Venho tendo sérios problemas com meu Debian Sarge r2 com o APT! (sei que a lista é de RH mas o APT é comum aos dois embora seja nativo do RH, mas a maioria dos usuários Linux são ecumênicos. rs...)

    Na realidade sou novo no Debian, gostei dele, mas tem muita coisa diferente do RH e Fedora, o APT me parece uma boa promessa, mas no meu caso venho experimentando problemas sérios. Não consigo encontrar uma penca de pacotes como QT QTparted e suas bibliotecas, o repositório do site de distribuidor não funciona, não consigo tb instalar o Partmage... Creio que não seja problema de repositório, pois tenho uma lista vasta, copiei vários, inclusive a lista de repositórios do Kurumim para ter acesso aos mesmos programas que vêm na sua distribuição. Outro problema é a questão dos conflitos, por exemplo: Para instalar o Locales (que cuida da parte de idiomas) ele me desistala arbitrariamente o Base-config e aí fico sem APT-SETUP..!? Outro exemplo são as bibliotecas "K" e gerenciadores gráficos, ao instalar um automaticamente eles saem desinstalando o Gnome ou qq outro... Não achei nada intuitivo o Synaptic nem o Aptitude, além de fazerem o mesmo, desmarcar uma penca de pacotes ao se selecionar outros, fora, o problema de simplesmente me dizer que precisa de bibliotecas X, Y e Z e simplesmente dizer que não vão ser instaladas, sem mais nem menos...

    Agora mesmo, deixei ontem ele fazendo um APT-GET DIST-UPGRADE e hoje pela manhã me retornou uma mensagem de erro num dos pacotes e simplesmente me retorna o erro "E" em determinado pacote e não funciona mais nenhuma opção: apt-get check, apt-get clean, apt-get -f install, apt-get check... Nenhuma corrige o problema, sem falar que por vezes ele me retorna o erro "E" dizendo que é impossível encontrar o pacote, e no entanto o pacote existe, é indicado em tutoriais e minha conexão está 100% ok... isso acontece com os pacotes de compilação, fontes e headers do Kernel.



    os tutoriais que eu já andei lendo por aí só explicam o básico, nenhum fala desses problemas, comprei até o livro do Rubens Ferreira sobre empacotamento, mas nos exemplos do livro tudo funciona. Agradeço imensamente se algum usuário mais habilidoso que eu souber me esclarecer algum desses problemas ou indicar algum tutorial que os sanem ou pelo menos me coloquem na direção certa.



    Desde já meu muito obrigado!



    Wagner Brasileiro



  2. #2
    nhawkbr
    Visitante

    Padrão Re: Problemas com APT-GET

    Um dos meus motivos para migrar minha maquina de casa pra slackware (que amo) foi esse problema com o aptitude. Fui instalar um pacote de 100k, e ele desinstalou meu kde todo. (baixar o kdebase em uma conexão de 70k, demora pra kralho).
    mas o debian como estação desktop não existe melhor. ele é agil pro usuário.
    pra procurar os pacotes tipo qt(e compania ltda), use o comando aptitude search qt. se por acaso tiver um arquivo, use dpkg -S arquivo pra saber de qual pacote este arquivo faz parte, é uma mão na roda.
    Dist-upgrade é uma merda de fazer. se for fazer mesmo tem q fazer todo dia. eu tenho um mirror do debian, putz, o treco atualiza todo dia muitos pacotes, então upgrade, de tempos em tempos.
    O resto entendi naum. t+



  3. #3
    leandroapbatista
    Visitante

    Padrão Re: Problemas com APT-GET

    Tenho alguns problemas com APT-GET, comecei a usar o APTITUDE.

    Abraço.
    :mrgreen:

  4. #4
    wagner.brasileiro
    Visitante

    Padrão Re: Problemas com APT-GET

    Muito obrigado Samuel!

    Tive uma outra dica que me confirmou o que eu estava pensando. O problema foi a salada de repositório que saí catando na Internet, de várias distribuições, então ele pirava!
    O Debian como vc disse, é muito seletivo e minucioso na questão de versões, infelizmente isso me causa problemas, pois nem tudo já se tem em repositório como stable para a distro que eu uso que é o sarge r2.



  5. #5

    Padrão Re: Problemas com APT-GET

    O apt-get é um sistema nativo da Debian. Pode ser portado para outras distribuições sem problemas.

    A justificativa para o qual não existam todos os pacotes do mundo nos repositórios da Debian é que a Debian zela mais pela estabilidade à atualidade. Os pacotes são largamente testados e o tempo entre uma versão e outra é grande, justamente para criar um sistema operacional mais estável possível, e não ir enxertando na distribuição um monte de pacote que mal foi testado e já está entrando como estável.

    Como uma medida pró-desenvolvimento e para os usuários que gostam de versões mais novas para seus micros pessoais e computadores não de produção, a Debian mantém três versões da distribuição: Stable, Unstable e Testing. Para mais informações sobre cada uma delas, visite este site.

    Como uma outra opção, você pode utilizar alguns softwares da Testing que foram portados para a Stable, disponíveis no site www.backports.org. Tais pacotes não são oficiais e de vez em quando podem gerar uma certa dor de cabeça. Claro que você pode também fazer um "misto" de versões da Debian, mas não é lá muito recomendável.

    Compreendam que para manter a árvore de pacotes e dependências, a Debian PRECISA ser minuciosa à respeito disso, por motivos de organização.

    Na verdade, o aptitude é apenas um front-end para o apt-get. Uma telinha bonitinha, onde você pode procurar, remover, colocar pacotes, mas o aptitude não faz absolutamente nada que o apt-get não faça. Na verdade, o apt-get só foi criado para provar que o sistema apt funciona =).

    Como você bem notou, fazer aquela salada firmeza no seu sources.list não é lá uma boa idéia. Vai ver por isso que ninguém nunca conseguiu atualizar o Kurumin =).

    Agora, se você quiser utilizar na sua casa uma versão Debian ou mesmo em um servidor mais de boa, eu recomendo muito utilizar Ubuntu. Recebi a última versão em casa e eu estou delirando. =)

    Falow galera!

  6. #6

    Padrão Re: Problemas com APT-GET

    author
    Agora, se você quiser utilizar na sua casa uma versão Debian ou mesmo em um servidor mais de boa, eu recomendo muito utilizar Ubuntu. Recebi a última versão em casa e eu estou delirando. =)
    E eu tb...instalei o hoary,troquei os sources e foi pra breedzy,e ontem de a noite,atualizei pelo synaptic para o dapper...naun tive nenhum problema de dependencias apt

    caso vc queira usar o ubuntu,de uma olhada neste guia,jah existem mais atualizados,mas eu naun lembro os endereços:
    gp347.sites.uol.com.br/linux/ubuntuguide.htm

    os lnks não funcionam,mas todo o conteudo esta na página,e no final dela,da pra vc ver como atualizar a distro na "mão"...