+ Responder ao Tópico



  1. #1

    Padrão Compatibilizando pacotes

    Bom dia pessoal,

    Estou instalando o clamav para posteriormente instalar o amavis. Porém estou usando um Suse 9, e na hora de instalar o clamav de um rpm tenho o seguinte problema:

    server:/opt # rpm -ivh clamav-0.88.2-0.1.i586.rpm
    error: Failed dependencies:
    libc.so.6(GLIBC_2.3.4) is needed by clamav-0.88.2-0.1
    libcurl.so.3 is needed by clamav-0.88.2-0.1

    Percebi que o problema está na versão do meu glibc (que atualmente é a 2.3.2-88) e no curl (esta versão do curl é requerida por módulos do yast!!)

    Como posso fazer para acertar este problema e não causar problemas no meu sistema, pois estes dois pacotes são requeridos por outros???

  2. #2

    Padrão Re: Compatibilizando pacotes

    usa o apt para atualizar, mas sempre existe a changce de dar algum problema, outra opcao é vc instalar outro gcc do fonte manualmente em algum diretorio tipo /opt/gcc-X, ai qdo vc for compilar o clamav vc da um export GCC=/opt/gcc-X/bin/gcc e compila



  3. #3

    Padrão Re: Compatibilizando pacotes

    Valeu pela dica!