+ Responder ao Tópico



  1. #1
    juniox
    Visitante

    Padrão Placa de Rede no Debian

    Debian: 3.1
    Kernel: 2.6.8
    Placa de Rede: Intel Pro 100

    tentei:
    modprobe e100
    até carregou, mas depois tentei
    ifconfig eth0 xxx.xxx.xxx.xxx
    ele retornou:
    SIOCSIFADDR: Dispositivo inexistente
    eth0: ERROR while getting interface flag: Dispositivo inexistente
    o mesmo aconteceu com o módulo eepro100

    alguém tem noção do que pode ser?

    ----------------------
    mais informações
    ----------------------

    outra coisa, fui instalar o driver e1000-4-2-17 e ele retornou:
    *** Linux kernel source not found. Stop.
    então, baixei o kernel-source.2.6.8.deb e instalei:
    dpkg --install kernelsource.2.6.8.deb

    então, tentei novamente compilar o driver e1000, mas o mesmo erro continua.

    alguém tem alguma sugestão qualquer sobre isso??
    não sei mais o que fazer


    ----------------------
    mais informações
    ----------------------

    executei lspci e retornou:
    0000:05:08.0 Ethernet controller: Intel Corp.: Unknown device 27dc (rev 01)
    porém, a placa não é pci!! é onboard

  2. #2

    Padrão Re: Placa de Rede no Debian

    a placa aparece no seu dmesg?
    (dmesg | grep -i eth)

    se não aparecer, é pq tá pifada. Se aparecer e não funciona então o drive correto não foi carregado.




  3. #3
    juniox
    Visitante

    Padrão Re: Placa de Rede no Debian

    então cara, no dmesg não aparecia nada, realmente
    mas no windows ela funciona.

    a solução encontrada foi instalar uma 3com pci

    valeu

  4. #4
    mhp
    Visitante

    Padrão Re: Placa de Rede no Debian

    Dispositivos on-board são vistos como pci ou até mesmo isa, isto é normal.
    Seu caso pode ter a ver com a interrupção, já aconteceu comigo. As placas de rede não funcionam se compartilharem a IRQ com outro dispositivo. O Ruindows quase sempre resolve estes conflitos sozinho realocando os recursos. No caso do Linux, pode-se tentar mexer no setup do BIOS, mudar a placa de slot (se for on-board não tem jeito :-P), ajustar os parâmetros do kernel no boot, fuçar o módulo, orar, fazer macumba, etc.



  5. #5

    Padrão Re: Placa de Rede no Debian

    Concordo com o MHP, também acho que o problema pode ser conflito de irq.

  6. #6
    juniox
    Visitante

    Padrão Re: Placa de Rede no Debian

    então, via lspci ele encontrava a placa e na frente exibia: "unknown device"

    como era urgente, acabei colocando uma da 3COM mesmo

    revirei o google e achei muita gente com esse mesmo problema com a placa intel

    valeu
    até mais