Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    juniox
    Debian: 3.1
    Kernel: 2.6.8
    Placa de Rede: Intel Pro 100

    tentei:
    modprobe e100
    até carregou, mas depois tentei
    ifconfig eth0 xxx.xxx.xxx.xxx
    ele retornou:
    SIOCSIFADDR: Dispositivo inexistente
    eth0: ERROR while getting interface flag: Dispositivo inexistente
    o mesmo aconteceu com o módulo eepro100

    alguém tem noção do que pode ser?

    ----------------------
    mais informações
    ----------------------

    outra coisa, fui instalar o driver e1000-4-2-17 e ele retornou:
    *** Linux kernel source not found. Stop.
    então, baixei o kernel-source.2.6.8.deb e instalei:
    dpkg --install kernelsource.2.6.8.deb

    então, tentei novamente compilar o driver e1000, mas o mesmo erro continua.

    alguém tem alguma sugestão qualquer sobre isso??
    não sei mais o que fazer


    ----------------------
    mais informações
    ----------------------

    executei lspci e retornou:
    0000:05:08.0 Ethernet controller: Intel Corp.: Unknown device 27dc (rev 01)
    porém, a placa não é pci!! é onboard

  2. a placa aparece no seu dmesg?
    (dmesg | grep -i eth)

    se não aparecer, é pq tá pifada. Se aparecer e não funciona então o drive correto não foi carregado.




  3. #3
    juniox
    então cara, no dmesg não aparecia nada, realmente
    mas no windows ela funciona.

    a solução encontrada foi instalar uma 3com pci

    valeu

  4. #4
    mhp
    Dispositivos on-board são vistos como pci ou até mesmo isa, isto é normal.
    Seu caso pode ter a ver com a interrupção, já aconteceu comigo. As placas de rede não funcionam se compartilharem a IRQ com outro dispositivo. O Ruindows quase sempre resolve estes conflitos sozinho realocando os recursos. No caso do Linux, pode-se tentar mexer no setup do BIOS, mudar a placa de slot (se for on-board não tem jeito :-P), ajustar os parâmetros do kernel no boot, fuçar o módulo, orar, fazer macumba, etc.



  5. Concordo com o MHP, também acho que o problema pode ser conflito de irq.






Tópicos Similares

  1. Placas de rede no debian
    Por netuno no fórum Servidores de Rede
    Respostas: 4
    Último Post: 22-08-2007, 22:55
  2. Segundo placa de rede no Debian 3.1
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 6
    Último Post: 21-03-2006, 13:50
  3. erro ao configurar placa de rede no debian
    Por jrctec2 no fórum Servidores de Rede
    Respostas: 19
    Último Post: 30-04-2005, 07:42
  4. placa de rede no debian
    Por rrlucatto no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-04-2005, 09:33
  5. duas placas de rede no debian
    Por stumm no fórum Servidores de Rede
    Respostas: 7
    Último Post: 07-01-2005, 07:41

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L