+ Responder ao Tópico



  1. #1

    Padrão MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    Pessoal,

    Encontrei uma peculiaridade muito sinistra no MK... Quando utilizamos o PPPoE com o software RAS-PPPoE instalado sob o Windows 98 ou 98SE a maioria dos sites não abre. TODOS os clientes que tenho com essa versão de Windows conseguem abrir apenas alguns sites, entre eles:

    Google
    Orkut
    Cade
    BuscaPe

    Os que testei foram esses, mas sites como UOL, Terra, Hotmail e Yahoo nem pensar. Quando começou a aparecer esse tipo de disturbio imaginei que fosse algum vírus mas do dia que instalei o MK nessa torre pra hoje já foram 6 clientes com Windows 98 e EXATAMENTE o mesmo problema.

    Alguém tem alguma idéia do que pode ser feito?

  2. #2

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    Pessoal,

    Resolvido o problema. A situação era devido a uma configuração de MTU. Tive que verificar qual o máximo de tamanho que um pacote poderia ter para alcançar um site. Resultou que na minha rede o máximo MTU para conexões ao Mikrotik é 1452.

    Agora todos os sites abrem normalmente...



  3. #3

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    rapaz voce pode me explicar como faço isso e de que maneira voce resolveu

    estou tendo o mesmo problema com o meus clientes

  4. #4

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    balisteri,

    Não vou saber te explicar técnicamente o que é pois não tive tempo hábil de estudar a fundo esse MTU e MRU mas, enfim, a situação é que um determinado pacote não pode chegar a um determinado site com fragmentação, ou seja, em vários pedidos. Isso é o que o MTU faz... é o máximo tamanho de uma unidade (medido em bytes pelo que entendo). Uma rede ethernet aceitaria pedidos de até 1500 bytes (MTU) já em redes wireless isso diminui bastante mas normalmente a gente não nota pois o AP em modo bridge gerenciaria essa situação.

    No meu caso que a rede é roteada e eu uso PPPoE o cliente chega, ele mesmo, ao site e por isso o MTU tem que ser ajustado. No servidor você deve ir nas configurações do servidor PPPoE (não sei se tu usa o Winbox ou terminal, eu prefiro terminal, então vou te passar como fazer por terminal):

    Código :
    [[email protected]] > /interface pppoe-server server print 
    Flags: X - disabled 
     0  service-name="CNett" interface=local max-mtu=1452 max-mru=1452 
       authentication=pap keepalive-timeout=10 one-session-per-host=no 
       max-sessions=0 default-profile=pppoe-profile 
     
     1  service-name="CNett" interface=ema01 max-mtu=1452 max-mru=1452 
       authentication=pap keepalive-timeout=10 one-session-per-host=no 
       max-sessions=0 default-profile=pppoe-profile 
     
     2  service-name="CNett" interface=ema02 max-mtu=1452 max-mru=1452 
       authentication=pap keepalive-timeout=10 one-session-per-host=no 
       max-sessions=0 default-profile=pppoe-profile 
    [[email protected]] >

    Veja que existe um ITEM MAX-MRU e MAX-MTU. Para alterar esses itens você deve executar assim:

    Código :
    [[email protected]] > /interface pppoe-server server set 0 max-mtu="valor" max-mru="valor"

    Esse valor você terá que determinar dentro da sua rede usando a seguinte sintaxe:

    Código :
    ping -f -l 1500 [url]www.bol.com.br[/url]

    O BOL é um dos sites com a pior condição de chegada. Esse 1500 você deve ir diminuindo até que não receba mais erros, veja abaixo (com erro):

    Código :
    C:\Documents and Settings\CNett>ping -f -l 1500 [url]www.bol.com.br[/url]
     
    Pinging amazonas.uol.com.br [200.221.8.49] with 1500 bytes of data:
     
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
     
    Ping statistics for 200.221.8.49:
      Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
     
    C:\Documents and Settings\CNett>

    E agora sem erro:

    Código :
    C:\Documents and Settings\CNett>ping -f -l 1472 [url]www.bol.com.br[/url]
     
    Pinging amazonas.uol.com.br [200.221.8.49] with 1472 bytes of data:
     
    Reply from 200.221.8.49: bytes=1472 time=39ms TTL=58
    Reply from 200.221.8.49: bytes=1472 time=30ms TTL=58
    Reply from 200.221.8.49: bytes=1472 time=46ms TTL=58
    Reply from 200.221.8.49: bytes=1472 time=32ms TTL=58
     
    Ping statistics for 200.221.8.49:
      Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
      Minimum = 30ms, Maximum = 46ms, Average = 36ms
     
    C:\Documents and Settings\CNett>

    Depois disso você deve ajustar esse MTU nos seus clientes que usam PPPoE. No Windows 98 usando o RAS-PPPoE existe como ajustar isso e nos LinuxAP ou servidores Linux também pode ser configurado.



  5. #5

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    Estou com o mesmo problema...
    Win 98 e no win2k tb.
    Baixei o mtu e o mru do pppoe e ainda nao resolveu... Eh nescessaria essa modificacao no raspppoe do win98 tb?
    eu nao encontrei onde fazer isso.
    Voce baixou o mru e o mtu somente do pppoe ou baixou tb da pci que esta transmitindo?

  6. #6

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    Achiodi,

    Apenas no servidor PPPoE. No RASPPPoE também é necessário que seja setado, a opção existe dentro dos parâmetros do protocolo ndiswan pppoe.



  7. #7

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    Um colega me falou de um outro discador...Ele nao lembra o nome agora mas vai me passar o nome mais tarde.. Diz ele que testou no 98 e ficou perfeito.
    Vc tem a opcao de colocar sua logo nele.

    Vou testar e se der certo posto a resposta!

    vlw ai cara

  8. #8

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    achiodi,

    Manda uma cópia pra gente desse discador. A maioria deles usa o RASPPPoE como base (o CFoz de um provedor americado é um dos mais usados no Brasil e usa o RASPPPoE, mas ele implementa uma alteração onde o MTU/MRU é pego diretamente no concentrador PPPoE e isso o RASPPPoE puro não consegue).



  9. #9

    Padrão Re: MK + Windows 98/98SE + PPPoE (não abrem alguns sites)

    O problema desse discador eh que eh proprietario.
    Eh uma empresa que desenvolveu e vende.

    Mas ele funciona certinho. Instalei ele em 2 micros q estava tendo problema e ele comecou a funfar.

    Vou tentar axar outra solucao e posto aki no forum.