Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá Galera

    Estou re-compilando o kernel Linux de uma maquina e estou com problemas, a conifguracao do kernel e instalacao dele ocorre sem problemas mas quando vou executa-lo através do lilo-boot, ocorre um problema Kernel Panic, abaixo coloquei a mensagem de erro que é gerada:


    kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno =2
    VFS: Cannot open root device "801"or 08:01
    Please append a correct "root=" boot option
    Kernel Panic: VFS Unable to mount root fs 08:01

    Acredito que isto esteja ocrrendo por causa que o hd sata é linux nao esteja reconhecendo a contralodora, mas especifiquei no kernel habilitar suporte para hd sata.

    A maquina é PIV com HD "sata samgsumg" rodando o Slackware 10.2 com kernel 2.4.31

    Se alguém pode me ajudar agradeco .

    Obrigado.

  2. edita o .config e habilida o SATA (e coloca como builtin o driver e o tipo do FS)



  3. Modulo do FS
    CONFIG_REISERFS_FS=y
    CONFIG_REISERFS_CHECK=y
    CONFIG_REISERFS_PROC_INFO=y

    Modulo SATA
    CONFIG_BLK_DEV_IDE_SATA=y
    CONFIG_SCSI_SATA=y
    CONFIG_SCSI_SATA_AHCI=m
    CONFIG_SCSI_SATA_SVW=m
    CONFIG_SCSI_SATA_NV=m
    CONFIG_SCSI_SATA_QSTOR=y
    CONFIG_SCSI_SATA_PROMISE=m
    CONFIG_SCSI_SATA_SX4=m
    CONFIG_SCSI_SATA_SIL=m
    CONFIG_SCSI_SATA_SIS=m
    CONFIG_SCSI_SATA_ULI=m
    CONFIG_SCSI_SATA_VIA=m
    CONFIG_SCSI_SATA_VITESSE=m


    Modelo da placa Intel® Desktop Board D101GGC

    Eu ja ative o suporte a SATA e mesmo assim o problema persiste.

  4. A configuracao do hardware SATA da maquina.

    lspci

    00:11.0 IDE interface: ATI Technologies Inc ATI 437A Serial ATA Controller (rev 80)
    00:12.0 IDE interface: ATI Technologies Inc ATI 4379 Serial ATA Controller (rev 80)

    lspci -v

    00:11.0 IDE interface: ATI Technologies Inc ATI 437A Serial ATA Controller (rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
    Subsystem: Intel Corporation: Unknown device d600
    Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
    I/O ports at ff00 [size=8]
    I/O ports at fe00 [size=4]
    I/O ports at fd00 [size=8]
    I/O ports at fc00 [size=4]
    I/O ports at fb00 [size=16]
    Memory at fe02f000 (32-bit, non-prefetchable) [size=512]
    Expansion ROM at <unassigned> [disabled] [size=512K]
    Capabilities: [60] Power Management version 2
    Capabilities: [50] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

    00:12.0 IDE interface: ATI Technologies Inc ATI 4379 Serial ATA Controller (rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
    Subsystem: Intel Corporation: Unknown device d600
    Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 10
    I/O ports at fa00 [size=8]
    I/O ports at f900 [size=4]
    I/O ports at f800 [size=8]
    I/O ports at f700 [size=4]
    I/O ports at f600 [size=16]
    Memory at fe02e000 (32-bit, non-prefetchable) [size=512]
    Expansion ROM at <unassigned> [disabled] [size=512K]
    Capabilities: [60] Power Management version 2
    Capabilities: [50] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

    Alguem aqui sabe qual modulo do kernel 2.4.31 é mais indicado para este tipo hardware ?

    Obrigado ai pessoal.



  5. no 2.6 tem uma parte de emular scsi como sata.. nao lembro..

    eu tenho uma Silicon rodando blzinha veja soh:

    CONFIG_SCSI_SATA=y
    CONFIG_SCSI_SATA_AHCI=m
    CONFIG_SCSI_SATA_SVW=m
    CONFIG_SCSI_SATA_MV=m
    CONFIG_SCSI_SATA_NV=m
    # CONFIG_SCSI_SATA_QSTOR is not set
    CONFIG_SCSI_SATA_PROMISE=m
    CONFIG_SCSI_SATA_SX4=m
    CONFIG_SCSI_SATA_SIL=y
    CONFIG_SCSI_SATA_SIL24=y
    CONFIG_SCSI_SATA_SIS=m
    CONFIG_SCSI_SATA_ULI=m
    CONFIG_SCSI_SATA_VIA=m
    CONFIG_SCSI_SATA_VITESSE=m
    CONFIG_SCSI_SATA_INTEL_COMBINED=y


    olha a ultima opção !!!

    meu kernel eh o 2.6.15.6






Tópicos Similares

  1. Problemas para atualizar o kernel
    Por LeoJfa no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-02-2005, 14:22
  2. Problema ao compilar o Kernel 2.6.10
    Por alexandre@ensist.com.br no fórum UnderLinux
    Respostas: 1
    Último Post: 07-01-2005, 03:27
  3. ñ inicia hd scsi depois de re-compilar kernel 2.4.26
    Por Gera no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-11-2004, 21:06
  4. Respostas: 3
    Último Post: 13-11-2004, 01:38
  5. Problemas para recompilar kernel
    Por Skorpyon no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-06-2004, 07:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L