Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    andersonjmello
    Utilizo o Conectiva 10 com compartilhamento de Internet utilizando Squid como proxy, mas não sei o que esta ocorrendo que o emule não esta conectando o que eu faço!?? Segue abaixo meu squid.conf

    ### SQUID By Anderson J. Méllo ###
    http_port 3128
    visible_hostname Palherani

    ### Cache De Páginas ###
    cache_mem 32 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_dir ufs /var/spool/squid 2000 16 256
    cache_access_log /var/log/squid/access.log
    refresh_pattern ^ftp: 20 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    ### ACLs ###
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl Safe_ports port 80 #HTTP
    acl Safe_ports port 21 # FTP
    acl Safe_ports port 2021 # FTP Passivo
    acl Safe_ports port 443 563 10000 # HTTPS SNEWS
    acl Safe_ports port 70 # GOPHER
    acl Safe_ports port 210 # WAIS
    acl Safe_ports port 1025-65535 # UNRESGISTRED PORTS
    acl Safe_ports port 280 # HTTP-MGMT
    acl Safe_ports port 488 # GSS-HTTP
    acl Safe_ports port 591 # FILEMAKER
    acl Safe_ports port 777 # MULTILING HTTP
    acl Safe_ports port 901 # SWAT
    acl Safe_ports port 5800 # VNC
    acl Safe_ports port 5900 # VNC
    acl Safe_ports port 3007 # ?CONSULTA?
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports

    ### Libera Acesso Local ###
    acl redelocal src 192.168.0.0/24
    http_access allow localhost
    http_access allow redelocal

    ### Bloqueia Acessos Externos ###
    http_access deny all

    ### Proxy Transparente ###
    httpd_accel_host virtualh
    ttpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

  2. talvez nao seja problema com proxy, passa as regras de iptables tmb se puder, :wink:



  3. #3
    andersonjmello
    Citação Postado originalmente por djhulk
    talvez nao seja problema com proxy, passa as regras de iptables tmb se puder, :wink:
    Pode ser configuração do rc.local

  4. #4
    514ck
    Ó, vc pode tentar liberar explicitamente as portas do emule na acl safe_ports:

    acl Safe_ports port 4662 # emule tcp
    acl Safe_ports port 4672 # emule udp

    e liberar explicitamente as portas

    http_access allow Safe_ports

    ou, caso a sua cadeia FORWARD esteja fechada e vc não esteja usando o MASQUERADE, nós precisamos colocar regras no iptables. qué vê ó...
    primeiro nós aceitamos o FORWARD dessas portas:

    # Libera portas do e-mule
    $IPT -A FORWARD -p tcp --dport 4662 -j ACCEPT
    $IPT -A FORWARD -p udp --dport 4672 -j ACCEPT

    depois roteamos as portas para a máquina específica:

    #Roteando portas
    $IPT -t nat -A PREROUTING -i eth1 -p tcp --dport 4662 -j DNAT --to 192.168.0.2:4662
    $IPT -t nat -A PREROUTING -i eth1 -p udp --dport 4672 -j DNAT --to 192.168.0.2:4672

    é importante que vc coloque as regras "Libera portas do e-mule" antes de fechar a cadeia FORWARD.

    espero ter ajudado...
    :mrgreen:



  5. olha... nunca tive problema com programas, p2p, streaming, IM, rdp, etc.. que estivessem sendo prejudicados com proxy.

    o complicado é que os servidor do eMule usam todos portas diferentes! e detalhe!! vc deve redirecionar uma porta para a maquina do eMule, snao voce vai baixar mto lento! a uns 3kbps...

    faça o teste q tem no site, pra saber se a porta esta aberta...

    meu tempo ta curto....
    t++
    :-D






Tópicos Similares

  1. emule não conecta em por decreto! ajudem...
    Por vgimenes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-08-2007, 16:39
  2. emule não conecta...
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-07-2005, 10:01
  3. Seu Speedy é PPPOE ? Não conecta? Não navega??
    Por zerocoolll no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-03-2003, 09:09
  4. Help Help Licq não conecta no servidor
    Por Itise no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-01-2003, 11:03
  5. Mysql não conecta com FrontEnd!!!
    Por AndrewAmorimdaSilva no fórum Servidores de Rede
    Respostas: 2
    Último Post: 07-01-2003, 17:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L