+ Responder ao Tópico



  1. #1
    diogoroos
    Pesoal,
    Tenho um roteador configurado com UM IP INTERNO 192.168.0.254 e uma porta wan com 200.XXX (conectada ao modem).
    Hoje está funcionando assim:

    Entrada
    ------------ ------------ ---------- ---------
    | Internet | -----> | modem | >>> | router | >> | DST | > REDE INTERNA
    ------------ ------------ ---------- ---------
    Onde DTS é o destino. Por exemplo, se um usário (com uma conexão externa(de fora)) tentar conectar na porta 21 não vai conseguir porque ele vai parar no roteador. Ah não ser que eu faça o redirecionamento no roteador pro Linux.

    A porta LAN do roteador (192.168.0.254) tá conectada no meu switch, junto com as outras máquinas, inclusive o servidor Linux (192.168.0.1).

    Tudo que que sai, passa pelo linux pra depois ir pro roteador e em seguida pro modem (porta wan)...
    Tudo que entra é pelo roteador e não pelo Linux.

    Eu preciso mudar essa estrutura para que tudo que entre e/ou saia, seja pelo Linux.

    ------------ ------------ ---------- --------
    | Internet | -----> | modem | >>> | router | > | linux | > REDE INTERNA
    ------------ ------------ ---------- --------
    ^
    Assim, tudo que o roteador receber manda pro Linux, também para tudo que enviar, deverá passar pelo Linux pra depois ir pelo roteador, e assim pro desitno...

    Bom, nesse caso eu devo utilizar duas placas, uma conectada com o router e outra pra rede interna
    Seria algo como:
    eth0=192.168.0.1 (Rede interna)
    (conectada com switch)

    eth1=192.168.0.5
    (conectada com o router)

    lan0=192.168.0.254
    (Lan do roteador)

    wan0=200.XXX
    (Wan do roteador)

    Passei a tarde tentando resolver isso mas não consegui. É "engraçado" que eu consigo usar a internet conectando o roteador na placa eth1 com gateway do ip do roteador, mas não consigo pingar nenhuma máquina da rede, logicamente tando com o ip definido como acima (eth0).

    As máquinas da rede interna estão com GW 192.168.0.1 (do Linux).
    Elas tbm podem usar o GW do router (192.168.0.254) que funciona. Conectada no switch, é como se o router fosse uma máquina mesmo, o que não é pra ser.

    Se eu ativo a eth0 e depois a eth1 a internet não funciona, mas a rede interna sim.
    Se eu ativo a eth1 e depois a eth0 eu consigo navegar mas não pingar outras máquinas.

    Bom, é isso.
    Desculpe a extensão, mas quis deixar bem claro a situação.

    Obrigado

  2. na pode colocar 2 ips da mesma classe em interfaces diferentes assim...


    mude o ip do seu roteador para 10.0.0.1

    eth0: 10.0.0.2 (liga o router aqui)
    eth1: 192.168.0.1 (liga no switch pra sua rede)

    pronto






Tópicos Similares

  1. ROTEADOR NAT 486
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-11-2002, 08:53
  2. Roteador
    Por ergs no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-11-2002, 16:52
  3. Logs de roteadores
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-11-2002, 14:37
  4. Roteador
    Por ediguedes no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-10-2002, 23:48
  5. Roteador
    Por teso2600 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-03-2002, 21:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L