+ Responder ao Tópico



  1. #1
    tabajara
    Pessoal,

    Estou tentando fechar um tunel entre duas empresas... estou usando openvpn com chave estática... porém no log da filial da o seguinte erro:

    Fri Jul 7 19:25:00 2006 SIGUSR1[soft,ping-restart] received, process restarting
    Fri Jul 7 19:25:00 2006 Restart pause, 2 second(s)
    Fri Jul 7 19:25:02 2006 Re-using pre-shared static key
    Fri Jul 7 19:25:02 2006 LZO compression initialized
    Fri Jul 7 19:25:02 2006 Preserving previous TUN/TAP instance: tun0
    Fri Jul 7 19:25:02 2006 Data Channel MTU parms [ L:1545 D:1450 EF:45 EB:23 ET:0 EL:0 AF:3/1 ]
    Fri Jul 7 19:25:02 2006 Local Options hash (VER=V4): 'e9663582'
    Fri Jul 7 19:25:02 2006 Expected Remote Options hash (VER=V4): 'a723a149'
    Fri Jul 7 19:25:02 2006 UDPv4 link local (bound): [undef]:1195
    Fri Jul 7 19:25:02 2006 UDPv4 link remote: xxx.xxx.xxx.xxx:1195
    Fri Jul 7 19:25:02 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:12 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:12 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:22 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:22 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:32 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)
    Fri Jul 7 19:25:32 2006 read UDPv4 [ECONNREFUSED]: Connection refused (code=111)

    Jah deixei os dois firewall aberto e mesmo assim continua com esse connection refused...

    Se alguem puder me ajudar fico agradecido.

    Sds,
    Tabajara Jr.

  2. Passa pra gente os seus arquivos de configuração do cliente e do servidor.



  3. #3
    tabajara
    Citação Postado originalmente por xstefanox
    Passa pra gente os seus arquivos de configuração do cliente e do servidor.
    Segue arquivos:

    matriz.conf

    dev tun
    ifconfig 172.16.0.1 172.16.0.2
    up ./matriz.up
    secret static.key
    port 1194
    user nobody
    group nobody
    comp-lzo
    keepalive 10 120
    persist-tun
    persist-key
    verb 3

    filial.conf

    dev tun
    ifconfig 172.16.0.2 172.16.0.1
    up ./filial.up
    secret static.key
    remote xxx.xxx.xxx.xxx
    port 1195
    user nobody
    group nobody
    comp-lzo
    keepalive 10 120
    persist-tun
    persist-key
    verb 3


    Dae pessoal? alguma idéia do que pode estar errado? Refiz tudo novamento agora utilizando chaves dinâmicas com CA e ocorre a mesma mensagem de erro.....

    Valeu....

  4. As portas devem ser iguais! :-P

    É por isso que dá conexão recusada, ele chega na filial mas a porta não bate!!

    Ab, Duca. :-D



  5. #5
    tabajara
    Citação Postado originalmente por Duca
    As portas devem ser iguais! :-P

    É por isso que dá conexão recusada, ele chega na filial mas a porta não bate!!

    Ab, Duca. :-D

    Valeu Galera!!!! Era isso mesmo... ajustei as portas e rodou blz!!!!!

    Vlw.






Tópicos Similares

  1. grub no CL10-2
    Por mirror no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-05-2004, 14:05
  2. Erro esquisito na instalacao do CL10
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-04-2004, 22:14
  3. OpenVPN
    Por pssgyn no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-02-2004, 09:39
  4. Freeswan ou OpenVPN ???
    Por pssgyn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 22-01-2004, 23:42
  5. OpenVpn x FreesWan no Conectiva 8
    Por pssgyn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-01-2004, 20:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L