+ Responder ao Tópico



  1. #1

    Padrão Não encontreino forum

    Ola pessoal, estou com problemas, sou nova no esquid e não estou conseguindo levantar não sei se errei em algun momento por isso vou relar todos os meus passos ate o erro que esta dando aqui.

    uso o slack 10.1
    baixei o #squid-2.5.STABLE10-i486-1maew.tgz*
    e instalei usando o installpkg
    configurei o squid.conf com aqulas 4 linha para usar o proxy transparente e fiz mais uma alteração na linha onde ele vai armazenar os arquivos do cache eu mudei para o #cache_dir ufs /cache 2100 16 256.
    execultei o
    #squid -z
    para criar os subdiretorios do cache e depois execultei o:

    #./RunCache &

    mas ele da o seguinte erro:

    [email protected]:/etc/squid# ./Runcache &
    [2] 4469
    [1] Exit 127 ./Runcache
    -bash: ./Runcache: No such file or directory
    [email protected]:/etc/squid#

    o q esta acontecendo vcs podem me ajudar?
    Fico grato desde já.

  2. #2

    Padrão Re: Não encontreino forum

    No fórum pode não existir documentação do tipo "how-to", porque não é o lugar.

    No wiki tem o projeto sobre Squid e tem uma penca de documentação, se tu procurar um pouquinho no Google:

    http://wiki.under-linux.org/index.ph...etos/Squid-Doc


    Abraços!



  3. #3

    Padrão Re: Não encontreino forum

    o RunCache não é um comando para ser executado a partir do diretorio /etc/squid/.

    Quando vc instala o squid a partir dos fontes ele fica em /usr/local/squid/bin. Tendo em vista que vc usou um pacote tgz, provavelmente ele esta em /usr/bin ou apenas /bin.

    Localize usando which RunCache, ou procureo nestes diretorios.

    Até

    mtec

  4. #4

    Padrão Re: Não encontreino forum

    Citação Postado originalmente por xstefanox
    No fórum pode não existir documentação do tipo "how-to", porque não é o lugar.

    No wiki tem o projeto sobre Squid e tem uma penca de documentação, se tu procurar um pouquinho no Google:

    http://wiki.under-linux.org/index.ph...etos/Squid-Doc


    Abraços!
    Uma otima documentação, mas eu não falei que não encontrei documentação referente a utilização do Squid e sim ao erro que esta dando na minha instalação.
    Obrigado pela documentação ele ja foi e ainda vai ser de muita utilidade, mas se vc souber de alguma coisa sobre esse meu erro eu fico muito grato.



  5. #5

    Padrão Re: Não encontreino forum

    Embora eu não utilize Slackware, de fato eu duvido que esse shell-script fique dentro do diretório /etc/squid. Tente localizá-lo com o whereis e execute o binário com o caminho apontado.

    Código :
    # whereis RunCache.sh[/b]
     
     
    Abraços.

  6. #6

    Padrão Re: Não encontreino forum

    Citação Postado originalmente por mtec
    o RunCache não é um comando para ser executado a partir do diretorio /etc/squid/.

    Quando vc instala o squid a partir dos fontes ele fica em /usr/local/squid/bin. Tendo em vista que vc usou um pacote tgz, provavelmente ele esta em /usr/bin ou apenas /bin.

    Localize usando which RunCache, ou procureo nestes diretorios.

    Até

    mtec
    É realmente vc tem rasão execultei o comando apartir do local que vc me indicou e ele tenta chamar o programa mas agora ele esta dando um outro erro:

    [email protected]:/usr/bin# ./RunCache &
    [2] 2438
    [email protected]:/usr/bin# Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    RunCache: EXITING DUE TO REPEATED, FREQUENT FAILURES

    vc tem ideia do que é isso?



  7. #7

    Padrão Re: Não encontreino forum

    Se alguem poder me ajudar eu agradeço muito!
    Eu ju fiz tudo que o meu conhecimento deixou que num é la muita coisa, agora estou precisando da ajuda de vcs do conhecimento de vcs.
    eu ja tentei mudar as premições do diretorio do cache dei permisão total criei um usuario squid criei um groupo squid já tentei de tudo mas não da certo quando eu ativo o redirecionamento para a porta do squid que vou no navegador ele aprece uma mensagem do squid e quando eu tento levantar o #./RunCache & ele da um erro

    [email protected]:/usr/bin# ./RunCache &
    [2] 3806
    [email protected]:/usr/bin# Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    Running: squid -sY >> /var/lib/squid/squid.out 2>&1
    RunCache: EXITING DUE TO REPEATED, FREQUENT FAILURES

    porfavor uma alma caridosa me ajude que eu já estou ficando doido!
    Agradeço desde já.

  8. #8

    Padrão Re: Não encontreino forum

    veja os logs do sistema que ele vai te mostrar exatamente oq ta errado, mas soh pra garantir execute squid -z antes de tentar inicia-lo.

    se vc quiser ver direto na tela os erros vc pode inicia-lo com squid -d 6
    qq mensagem ele vai printar no console



  9. #9

    Padrão Re: Não encontreino forum

    Citação Postado originalmente por 1c3m4n
    veja os logs do sistema que ele vai te mostrar exatamente oq ta errado, mas soh pra garantir execute squid -z antes de tentar inicia-lo.

    se vc quiser ver direto na tela os erros vc pode inicia-lo com squid -d 6
    qq mensagem ele vai printar no console
    Valew, muito obrigado
    depois de muito tempo consegui com sua ajuda e a ajuda de todos os companheiros colocar o squid para funcionar...
    no erro dizia que o arquivo access.log não existia dentro do diretorio /var/log/squid/access.log
    depois que eu criei ele pediu para mudar o direito de uso ai foi só execultar o ./RunCache &

    se não for pedir demais... eu sou leigo no squid, eu gostaria de saber se tem como testar no servidor para ver o squid funcionado
    alguma coisa que eu pode-se ver ele funcionando
    antes de tudo valew!!!