+ Responder ao Tópico



  1. Estou montando uma estrutura de VPN aqui na empresa e em um dos servidores clientes estou tendo uma dificuldade.
    Ele é o meu gateway de saida de internet, dessa forma ele está configurado para mascará as conexões da rede interna. Só que quando fecho as VPN's com outras redes, o gateway não pode mascarar os pacotes com destino a essas redes (vpn's), então, não estou conseguindo fazer essas regras, vejam o exemplo abaixo:

    Rede_Interna: 192.168.0.0/24
    Rede_vpn1: 192.168.0.1/24
    Rede_vpn2: 192.168.0.2/24

    A regra que existia antes da VPN era essa:
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -j MASQUERADE

    Depois da VPN, alterei para:
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -d ! $Rede_vpn1 -j MASQUERADE

    até aí tudo funcionou beleza, conseguo acessar a vpn sem problemas. Ai iniciei a segunda VPN e como como coloca a regra ??
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -d ! $Rede_vpn1 -j MASQUERADE
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -d ! $Rede_vpn2 -j MASQUERADE
    Dessa forma não funciona. Como faço para resolver essa quersão de forma que eu possa me conectar a várias vpn's desse gateway ??

    Abraços.

  2. Bem... teoricamente tudo o quê você tem que fazer é fazer o NAT entre as redes, da seguinte maneira:

    Código :
    # iptables -t nat -A POSTROUTING -j MASQUERADE

    E depois tu controla qual rede enxerga qual utilizando a chain FORWARD. Fica mais fácil.


    Abraço.



  3. Peguei uma dica lá no forum do Openswan que resolveu meu problema.
    Para cada rede da vpn eu uso a opção -j RETURN, ficou assim as regras:

    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -d $Rede_vpn1 -j RETURN
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -d $Rede_vpn2 -j RETURN
    $IPTABLES -t nat -A POSTROUTING -o $TELEMAR_INTERFACE -j MASQUERADE

    Valeu.






Tópicos Similares

  1. Um firewall para varios IPFIXOS em iptables.
    Por rafaelmr77 no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-06-2004, 11:43
  2. Postfix - Nao envia para extranet !!!!!!!!!
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 15-07-2003, 10:50
  3. Sendmail não remete para extranet
    Por Apocalipse no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-07-2003, 07:32
  4. OpenOffice para vários Usuários
    Por PandaAzul no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-02-2003, 15:35
  5. sendmail não envia para hotmail.com.br
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-02-2003, 10:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L