Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Opa pessoal, beleza? o/

    Tipo galera, estou tendo um problema meio que bizarro na configuração do Squid. Eu realizei a instalação do programa e depois configurei as ACL's, e etc, belezinha.

    O caso é que toda vez que um host faz uma requisição de acesso sem ter o proxy configurado no Browser, o host acessa normalmente a internet. Ela não é barrada.

    Já vi diversas vezes o Iptables e as regras de redirecionamento de portas, olhei a porta de configuração do Squid, e nada.

    Uma coisa curiosa foi que uma vez, apareceu a tela do Apache sem exibir nenhuma mensagem de erro, mas sim a página padrão do programa.

    Onde posso estar errando?

    Valeu pessoal. o/

  2. Certifique-se que os usuários estão realmente passando pelo proxy com o seguinte procedimento:

    1 - Analise os logs do Squid em tempo real, com o comando:
    Código :
    # tail -f /var/log/squid/access.log

    2 - Faça uma requisição para a internet e cheque se aparece alguma coisa no terminal em questão. Caso alguma coisa apareça no terminal, verifique a ordem das suas ACL's.



  3. Vc ta usando proxy trasnparente? se nao tiver por questou praticas e administrativas sugiro que passe a usar pois e bem mais facil de se adminstrar, caso modifque vc nao terá esse tipo de problema pois as conexoes nao precisarao ser setadas no navegador e os hosts serao obirgados a sair pelox proxy.

  4. Citação Postado originalmente por LeoJfa
    Vc ta usando proxy trasnparente? se nao tiver por questou praticas e administrativas sugiro que passe a usar pois e bem mais facil de se adminstrar, caso modifque vc nao terá esse tipo de problema pois as conexoes nao precisarao ser setadas no navegador e os hosts serao obirgados a sair pelox proxy.
    Exato, é justamente isso que estou tentando fazer, um proxy transparente, mas não estou conseguindo.
    Toda vez que um usuário tenta acessar um site sem ter o proxy configurado no browser, ele navega normalmente.

    Mesmo tentando redirecionar as requisições de acesso c/ iptables para o squid, não estou conseguindo barrar o acesso.



  5. Mas o bloquei no acesso vai depender de como sua acl esta configura, da uma olhada no arquivo de liberação e bloqueio eu tive serios problemas pois tinha ponto (.) e barra no arquivo (/) o que faz eles ficarem locous e liberarem tudo outra coisa posta sua regra aki pra eu dar uma olhada.






Tópicos Similares

  1. Proxy + Squid - Problema com link de 1MB
    Por Andre_TI no fórum Servidores de Rede
    Respostas: 7
    Último Post: 23-11-2005, 16:36
  2. problemas com configuração de duas placas de rede
    Por mario meirles fielho no fórum Redes
    Respostas: 3
    Último Post: 04-05-2005, 16:53
  3. Problemas com configuração de Prompt do bash
    Por fdotta no fórum Linguagens de Programação
    Respostas: 11
    Último Post: 01-09-2004, 12:18
  4. Problemas com configuração de Prompt
    Por fdotta no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-08-2004, 11:21
  5. Respostas: 3
    Último Post: 27-08-2003, 15:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L