Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Ae Pessoal, instalei o squid pelo seu pacote tgz, nao apresenta erro durante compilação, acontece que quando o inicio (squid -D) no log de cache ele apresenta o seguinte log:

    2006/08/07 11:53:23| Starting Squid Cache version 2.5.STABLE10 for i686-pc-linux-gnu...
    2006/08/07 11:53:23| Process ID 4994
    2006/08/07 11:53:23| With 1024 file descriptors available
    2006/08/07 11:53:23| DNS Socket created at 0.0.0.0, port 32784, FD 5
    2006/08/07 11:53:23| Warning: Could not find any nameservers. Trying to use localhost
    2006/08/07 11:53:23| Please check your /etc/resolv.conf file

    2006/08/07 11:53:23| or use the 'dns_nameservers' option in squid.conf.
    2006/08/07 11:53:23| Unlinkd pipe opened on FD 10
    2006/08/07 11:53:23| Swap maxSize 6291456 KB, estimated 483958 objects
    2006/08/07 11:53:23| Target number of buckets: 24197
    2006/08/07 11:53:23| Using 32768 Store buckets
    2006/08/07 11:53:23| Max Mem size: 102400 KB
    2006/08/07 11:53:23| Max Swap size: 6291456 KB
    2006/08/07 11:53:23| Rebuilding storage in /var/lib/squid/cache (DIRTY)
    2006/08/07 11:53:23| Using Least Load store dir selection
    2006/08/07 11:53:23| Current Directory is /root
    2006/08/07 11:53:23| Loaded Icons.
    2006/08/07 11:53:23| Accepting HTTP connections at 0.0.0.0, port 3128, FD 11.
    2006/08/07 11:53:23| Accepting ICP messages at 0.0.0.0, port 3130, FD 12.
    2006/08/07 11:53:23| Accepting SNMP messages on port 3401, FD 13.
    2006/08/07 11:53:23| WCCP Disabled.

    Caso o problema seja o dns , nao entendo o pq , já que o dns que coloquei eh o mesmo que uso pra navegar em clientes.

    Segue abaixo também, o squid.conf:

    http_port 3128
    visible_hostname Slackware

    #Configuracao do Cache
    cache_mem 100 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_dir ufs /var/lib/squid/cache 6144 16 256

    cache_access_log /var/lib/squid/logs/access.log
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost

    cache_effective_user nobody
    cache_effective_group nogroup


    # Configuracao da senha para internet

    acl redelocal src 192.168.10.104
    http_access allow localhost
    http_access allow redelocal
    http_access deny all

    #Proxy Transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    >>> Quando o Inicio, nas maquinas clientes elas nao navegam, apesar de ecntrar o dominio, mas nao carrega, penso tb que possa ser um problema no cache. mas as permissões foram dadas para escrita ao usuário nobody

  2. O quê está acontecendo é que o Squid quando não encontra um DNS ou a diretiva dns_nameservers não está preenchida, o Squid não inicia. Para ignorar os testes de DNS na inicalização do serviço, adicione o flag -D no script de inicialização.

    Achei estranho ele estar dando este problema mesmo com o argumento. Dê uma olhada para ver se o seu resolv.conf está com os servidores DNS apontados. Lembrando que o parâmetro -D é referente aos testes iniciais de DNS, mas ele pode dar problemas depois.

    Qualquer coisa, posta de novo aí pra gente.


    Abraços!



  3. xstefanox ,
    Realmente já havia apontado a diretiva dns_nameservers no script , no resolv.conf tb, mesmo assim nao navega. Alguma sugestão ? Espero ajuda. Abraço!

  4. soh pra garantir no resolv vc colocou na sintaxe correta neh?
    nameserver IP
    nameserver IP2
    etc,etc

    e nao tem nenhum firewall barrando a saida dos pacotes neh?



  5. Nao Nao amigao, Veja o Log agora depois que ajustei a diretiva dns_nameservers e o resolv.conf :

    2006/08/07 20:41:52| Starting Squid Cache version 2.5.STABLE10 for i686-pc-linux-gnu...
    2006/08/07 20:41:52| Process ID 6753
    2006/08/07 20:41:52| With 1024 file descriptors available
    2006/08/07 20:41:52| Performing DNS Tests...
    2006/08/07 20:41:52| Successful DNS name lookup tests...
    2006/08/07 20:41:52| DNS Socket created at 0.0.0.0, port 32801, FD 5
    2006/08/07 20:41:52| Adding nameserver 200.223.0.83 from squid.conf
    2006/08/07 20:41:52| Adding nameserver 200.223.0.84 from squid.conf
    2006/08/07 20:41:52| Unlinkd pipe opened on FD 10
    2006/08/07 20:41:52| Swap maxSize 6291456 KB, estimated 483958 objects
    2006/08/07 20:41:52| Target number of buckets: 24197
    2006/08/07 20:41:52| Using 32768 Store buckets
    2006/08/07 20:41:52| Max Mem size: 102400 KB
    2006/08/07 20:41:52| Max Swap size: 6291456 KB
    2006/08/07 20:41:52| Rebuilding storage in /var/lib/squid/cache (DIRTY)
    2006/08/07 20:41:52| Using Least Load store dir selection
    2006/08/07 20:41:52| Current Directory is /root
    2006/08/07 20:41:52| Loaded Icons.
    2006/08/07 20:41:57| Accepting HTTP connections at 0.0.0.0, port 3128, FD 11.
    2006/08/07 20:41:57| Accepting ICP messages at 0.0.0.0, port 3130, FD 12.
    2006/08/07 20:41:57| Accepting SNMP messages on port 3401, FD 13.
    2006/08/07 20:41:57| WCCP Disabled.

    Mas nao navega ainda ...






Tópicos Similares

  1. Problemas no Squid, 'Memory pools are 'off'; limit: 2.00 MB'
    Por H_Franzin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 31-03-2005, 15:07
  2. Amigos estou com sérios problemas no squid(RunCache)
    Por bandlinux no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-03-2005, 06:07
  3. Problemas no Squid com firewall
    Por Dick_Vigarista no fórum Servidores de Rede
    Respostas: 4
    Último Post: 03-11-2003, 15:09
  4. Problemas no squid com a porta 8088
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 08:42
  5. problemas no squid
    Por roggy no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-09-2002, 15:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L