Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá Srs. tudo bom?
    Estou com um problema estranho no meu servidor de DHCP.
    Eu tinha uma rede dividida por dois GNU/Linux fazendo o papel de roteador, firewall e dhcp. Uma destas maquinas foi eliminada ficando somente com uma para gerenciar tudo. Quando fiz isso algumas maquinas não conseguiram mais renovar o ip. No syslog mostra todos os pacotes discovery, request offer etc. Mas as maquinas, que são WinXP em sua maioria, não param de tentar renovar. Já almentei a faixa, que não precisava pois era grande o suficoente, ja zerei o arquivo dhcpd.leasse mas nada. Configurei um servidor Windows (vejam que barbaridade) para verificar o problema e la mostrava um erro de BAD_ALIASES mas este servidor pelomenos tentava oferecer outro ip. No GNU/Linux apesar dos pacotes parecerem estar trafegando bem o mesmo insiste em oferecer o mesmo ip e estes não estão amarrados no MAC.
    Alguem pode me ajudar??
    Valeu.

  2. difícil saber o que se passa. Bem, vc pode começar com o tcpdump (ou ethereal) com filtragem. O dhcpd atribui um ip-addr quando solicitado via um broadcast. Considerando-se que deverá responder assim que receber o bcast, pergunta-se:

    a) há bcast na rede?
    b) o server ESTÁ recebendo os bcasts e, mais importante, tenta (ou consegue) respondê-los?
    c) se respondendo, o cliente ESTÁ ENTENDENDO a resposta?

    aproveite a APAGUE o /etc/leases para que hajam respostas válidas aos requests. Vai que o seu lease-time esteja alto?

    divirta-se.



  3. Cara já usei tanto o tcdpum quanto verifiquei a chegada da solicitação no syslog. Ta tudo beleza.
    Agora o bicho pegou de vez. Instalei o dhcpd3 e tambem ta com a mesma porcaria.

  4. Citação Postado originalmente por Kalil de Albuquerque Carvalho
    Cara já usei tanto o tcdpum quanto verifiquei a chegada da solicitação no syslog. Ta tudo beleza.
    Agora o bicho pegou de vez. Instalei o dhcpd3 e tambem ta com a mesma porcaria.
    bem.. por partes (again):

    a solicitação chegou.. e..??
    foi gerado um /etc/lease para a solicitação que vc viu?
    se foi, pq o cliente não assume o ip-addr ??

    evite acrescentar variáveis ao problema original. Se não temos um funcionamento adequedo, se não conseguimos definir o problema e, uma vez que não sabemos AINDA o que é.. por que trocar o daemon?

    não tenho certeza se existe, mas.. /var/log/dhcp OU /var/log/messages pra ver o que anda contecendo.



  5. Cara os pacotes chegam mas é como se os clientes não aceitasem ai ao inves do servidor oferecer outro ele insiste no mesmo ip.
    Esse arquivo /etc/lease não existe. Eu to acompanhando tudo pelo /var/lib/dhcp/dhcpd.leases, /var/log/syslog
    O problema é que todos os pacotes chegam e saem do servidor mas, como avia dito, tem um conflito com aliases.
    Quando configurei um Windows ele dava o mesmo erro mas pelo menos comessava a oferecer outros ips ate o cliente aseitar.
    Os ips não estão amarado, mas o comportamente é muito semelhante a como se estivesem






Tópicos Similares

  1. Servidor dhcp nao libera internet
    Por Warken no fórum Servidores de Rede
    Respostas: 8
    Último Post: 03-06-2008, 19:01
  2. Servidor DHCP não funciona
    Por derson no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-10-2006, 14:10
  3. Servidor VSFTP nao aceita conexoes de fora da rede local
    Por Sergio Jr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-12-2005, 16:42
  4. Tratar Whitespace de forma correta
    Por Super_Diaulas no fórum Linguagens de Programação
    Respostas: 4
    Último Post: 17-10-2005, 13:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L