+ Responder ao Tópico



  1. #1

    Padrão Servidor fica lento somente em determinada hora

    Meu servidor é um Debian 3.1, tenho um nat nele com 50 clientes, e ja a uma semana na mesma hora 1h da manha comeco a perder pacotes para a placa de rede eth1 nele, se eu reseto o server volta tudo ao normal, ja troquei as placas de rede por 3com e continua na mesma. Alguem tem um luz ? Obrigado

  2. #2

    Padrão Re: Servidor fica lento somente em determinada hora

    bem.. não dá pra saber, com "toda" essa informação que vc deu. Será preciso que vc FIQUE lá, de madrugada, pra testar:

    a) ethereal, pra medir o tráfego e avalia-lo
    b) lsof e ps ax pra saber os arquivos e processos nessa hora..

    hmm.. pensando bem.. vc pode fazer o seguinte:

    um cron com entrada chamando um bash script que iniciem os processos às 00:45 e outra terminando às 1:30 (por exemplo). Seriam chamados:

    tcpdump [parâmetros] >> /path_qualquer/tcpdump.arq

    bem.. poderia também ser feita entrada no cron para, dentro do perído, fazer o dump do ps e lsof:

    ps ax >> /path_qualquer/registro.txt
    lsof >> /path_qualquer/registro.txt

    dia seguinte vc fará:

    a) ler TODO o arquivo /var/log/messages DENTRO DO PERÍODO
    b) usar o ethereal pra ler o arquivo gerado pelo tcpdump

    divirta-se. Não será muito fácil.




  3. #3

    Padrão Re: Servidor fica lento somente em determinada hora

    cara...

    não seria alguma coisa que rode em seu servidor neste horário???

    como logrotate, geralmente ele está programado para as 4 da madruga, mas vai saber...

  4. #4

    Padrão Re: Servidor fica lento somente em determinada hora

    Bom...mude a hora do seu computaddor pra 00:55, e fica esperando dar 1:00 e monitore com top, ps -aux e ethereal.... se for algum processo nesse horario vc vai ver com certeza.



  5. #5

    Padrão Re: Servidor fica lento somente em determinada hora

    Citação Postado originalmente por tecnic
    Meu servidor é um Debian 3.1, tenho um nat nele com 50 clientes, e ja a uma semana na mesma hora 1h da manha comeco a perder pacotes para a placa de rede eth1 nele, se eu reseto o server volta tudo ao normal, ja troquei as placas de rede por 3com e continua na mesma. Alguem tem um luz ? Obrigado
    Como está o controle de Banda ...???
    os grandes nossos grandes vilões ( Emule, Kazza e Downloads extenssos ) são os responssáveis diretos ...
    pra saber realmente ... só monitorando ...
    abraços ....

    Falow ...