Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. fala galera, como estão as coisas??

    pessoal to com um probleminha aqui, parece ser simples mas não consegui resolver, faz pouco tempo q estou usando o Debian, antes usava conectiva..

    é assim:

    quando o micro inicia não seta o gateway padrão, então preciso fazer manualmente:

    route add default gw 192.168.200.254

    A situação é a seguinte:
    eth0 - rede interna - 10.0.0.254
    eth1 - internet - 192.168.200.250

    /etc/network/interfaces:
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 10.0.0.254
    netmask 255.255.25.0
    network 10.0.0.0
    broadcast 10.0.0.255
    dns-nameservers 10.0.0.254
    dns-search x.com

    auto eth1
    iface eth1 inet static
    address 192.168.200.250
    netmask 255.255.25.0
    network 192.168.200.0
    broadcast 192.168.200.255
    gateway 192.168.200.254
    dns-nameservers 192.168.200.250
    dns-search x.com
    no conectiva havia um arquivo onde configurava o gateway padrão, no slackware é no mesmo arquivo que configura as interfaces, no debian a princípio também é no mesmo arquivo que configura as interfaces, mas não está resolvendo o problema... :/

    valeu
    []'s

  2. bem.. quando se muda de uma distribuição para outra é conveniente vc ESTUDAR as características dessa nova. Porque são diferentes, algumas MUITO diferentes, outras nem tanto. Bem, vamos lá:

    no seu /etc/network/interfaces acrescente a expressão:

    (usando o seu exemplo)

    [.. snip..]
    face eth1 inet static
    address 192.168.200.250
    gateway AAA.BBB.CCC.DDD
    [..snip..]

    a expressão 'gateway' pode estar em qualquer ponto das definições da interface, mas é hábito coloca-la logo após o ip-addr.

    mais detalhes: http://www.debian-administration.org/articles/254

    sugiro também ler atentamente o focalinux: http://focalinux.cipsga.org.br/index.html

    divirta-se.





  3. oo camarada..

    concordo plenamente que é preciso estudar a distribuição a ser usada...

    mas vim até este fórum pq não consegui resolver meu problema sozinho...

    ainda mais que tenho aqui outros micros com o debian instalado e rodando, e somente este deu problema para setar o gateway padrão...

    valeu
    []'s

  4. #4
    MASTERGTx
    cara, na pior das hipóteses adiciona esse comando no rc.local

    /etc/rc.d/rc.local

    blz..



  5. galera...

    tá resolvido o problema...

    não havia postado antes q já tinha resolvido pq esqueci de fazer isso...

    o problema era a máscara q tava errada... 255.255.25.0

    valeu






Tópicos Similares

  1. Configuracao do Servidor X
    Por hchave no fórum Servidores de Rede
    Respostas: 3
    Último Post: 08-02-2003, 00:19
  2. Configuracao do qmail admin
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-01-2003, 00:43
  3. Configuracao do X
    Por no fórum Servidores de Rede
    Respostas: 16
    Último Post: 05-12-2002, 23:34
  4. Instalação e Configuração do Snort
    Por no fórum Segurança
    Respostas: 2
    Último Post: 05-12-2002, 23:23
  5. Configuração do LILO
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-05-2002, 19:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L