Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde,
    pessoal estou instalando o Apache 2 com php, digito o seguinte comando para compilar
    ./configure --with-apxs2=/usr/sbin/apxs


    Apresenta a seguinte mensagem de erro:
    Configuring SAPI modules
    checking for AOLserver support... no
    checking for Apache 1.x module support via DSO through APXS... no
    checking for Apache 1.x module support... no
    checking for mod_charset compatibility option... no
    checking for Apache 2.0 filter-module support via DSO through APXS... no
    checking for Apache 2.0 handler-module support via DSO through APXS... apxs:Error: Invalid query string `APU_BINDIR'.
    apxs:Error: Invalid query string `APR_BINDIR'.
    ./configure: line 1: /apr-config: No such file or directory
    ./configure: line 1: /apu-config: No such file or directory
    configure: error: Please note that Apache version >= 2.0.44 is required

    Este erro apresenta tanto no php 5 quanto no 4, estou usando o http 2.0.40 sera que preciso atualizar para 2.0.44.







  2. Pelo que eu vi , está dizendo que o diretório do apxs não existe, vc deve apontar o diretório onde foi instalado....
    Salve engano, o apxs fica no diretório bin do apache: /usr/local/apache2/bin/

    Outra coisa, vc compilou seu apache com suporte a módulos, --enable-so?

    Ab, Duca. :-)



  3. Velho pelo q entendi esse erro esta em virtude da vesao do apagce 2 q vc ta usando, quano ele diz:

    configure: error: Please note that Apache version >= 2.0.44 is required

    ele ta dizendo q a versao do apache tem q ser maior ou igual a >= 2.0.44, q versao vc esta usando?

  4. isso eu entendi...
    mas li varios materiais dizendo que a versao que estou usando é compativel com o php 5 e 4
    porem os dois apresentaram a mesma mensagem.... estava tentando resolver isso sem precisar atualizar o apache mas acho que nao vai ter jeito......

    valeu pela intenção...



  5. entao Duca o caminho do APX esta certo..
    agora o apache com suporte a --enable.so, nao sei quando cheguei na empresa ele ja estava instalado, acredito que seja o default da instalacao do rh9.. acho que terei que baixar outra versao do apache.






Tópicos Similares

  1. LINUX apache com PHP acessando banco Interbase
    Por Gabriel_Kritikos no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 27-10-2005, 17:50
  2. LINUX apache com PHP acessando banco Interbase
    Por Gabriel_Kritikos no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-10-2005, 17:40
  3. Problemas com o Apache e PHP
    Por GhOsTLip no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-09-2004, 07:37
  4. instalar configuração mínima do apache com PHP
    Por redoctober no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-01-2004, 07:17
  5. Instalando um apache com php e suporte a Oci8 num conectiva
    Por Futuremax no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-12-2002, 15:23

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L