+ Responder ao Tópico



  1. #1

    Padrão Slack não reconhece eth1 - RESOLVIDO!

    Senhores Experts,

    Minha placa mãe ASUS A8N SLI Premim tem duas placas de rede on boad. A eth0 o Slackware 10.2 reconheceu logo na instalação. Na segunda (eth1), o bicho pegou.

    Tenho o driver no CD da ASUS. O driver é um tal de Marvell 88E1001.

    Há alguma forma de utilizá-lo no Slack???

    Já atualizei a BIOS.

    Agradeço antecipadamente às sugestões.

    PS: Começo a me encantar com o Linux.

  2. #2

    Padrão Re: Slack não reconhece eth1

    digita:
    $lsmod --> pega os modulos carregados
    $lspci --> pega as pcis do micro

    $ifconfig eth1 10.0.0.1 netmask 255.255.255.252 up --> ve o que acontece e se da erro !!!

    Posta ai que nois da um jeito.



  3. #3

    Padrão Re: Slack não reconhece eth1

    La vai....


    Module Size Used by Not tainted
    soundcore 3396 0 (autoclean)
    usb-ohci 19368 0 (unused)
    ehci-hcd 17516 0 (unused)
    usbcore 59084 1 [usb-ohci ehci-hcd]
    forcedeth 9868 1
    ohci1394 23888 0 (unused)
    ieee1394 41604 0 [ohci1394]
    pcmcia_core 39140 0
    ide-scsi 9392 0
    --------------------------------------------------------------------------------------------------------------
    [email protected]:~# lspci
    00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
    00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
    00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
    00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
    00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
    00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
    00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
    00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
    00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
    00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
    00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
    00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
    00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
    00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
    00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
    01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
    05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
    05:0c.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
    [email protected]:~#

    ------------------------------------------------------------------------------------------------

    [email protected]:~# ifconfig eth1 10.0.0.1 netmask 255.255.255.252 up
    SIOCSIFADDR: No such device
    eth1: unknown interface: No such device
    SIOCSIFNETMASK: No such device
    eth1: unknown interface: No such device
    [email protected]:~#

    ------------------------------------------------------------------------------------------------------------------

  4. #4

    Padrão Re: Slack não reconhece eth1

    Acabo de perceber uma coisa:

    Há uma referência ao Driver da eth1 na última linha do lspci:

    05:0c.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)

    Só não sei como habilitar.



  5. #5

    Padrão Re: Slack não reconhece eth1

    Ta facinho entra no /usr/src/linux da um make menuconfig entra na parte de redes la dentro vc vai ver que o modulos para placas marvel nao sao selecionados seleciona eles mara M de modular e depois sai e da um make module depois make modules install

  6. #6

    Padrão Re: Slack não reconhece eth1

    Caro William,

    Cara, dei uns três pulos de alegria quando vi o ledzinho da eth1 piscando.

    Valeu mesmo companheiro.

    Delson



  7. #7

    Padrão Re: Slack não reconhece eth1

    só mais uma coisinha: como faço para carregar o modulo no system start?

  8. #8

    Padrão Re: Slack não reconhece eth1

    Geralmente o modulo sobe sozinho mas se nao tiver subindo da um insmod "nome do modulo" que ele sobe.




  9. #9

    Padrão Re: Slack não reconhece eth1

    Com "lsmod" ele carrega o módulo, mas depois que reinicio o micro o driver (sk98lin) some de novo.

    Toda vez que inicializo preciso fazer:
    # modprobe sk98lin
    # ifconfig eth1 192.168.0.1

    Haveria uma forma de o Slack carregar esses comandos na inicialização?


  10. #10

    Padrão Re: Slack não reconhece eth1

    oppps

    lsmod == ls (list ) mod (module)

    insmod = ins (insert) mod (module)


    da uma editada no /etc/rc.d/rc.modules --> para carregar modulos
    /etc/rc.d/rc.inet1.conf -- para configurar a rede !!!!

    Acho que agora vc ta com tudo ok

    abraco



  11. #11

    Padrão Re: Slack não reconhece eth1

    William,

    editei o /etc/rc.d/rc.modules e incluí a seguinte linha:

    #/sbin/modprobe sk98lin

    tentei também:

    modprobe sk98lin


    Em /etc/rc.d/rc.inet1.conf acrescentei a seguinte linha:

    ifconfig eth1 192.168.200.1

    Porém o driver não subiu. É só reiniciar que o eth1 desaparece do mapa.

    Com o insmod tenho o mesmo resultado obtido com o modprobe.




  12. #12

    Padrão Re: Slack não reconhece eth1

    heheheh nao precida sar if config dentor do arquivo mano !!!!!

    da uma olhada de como e a lexica do arquivo !

    com relacao ao modulo nao esqueca de dar um chmo 755 /etc/rc.d/rc.modules

    um pedacinho do /etc/rc.d/rc.inet1.conf

    # Config information for eth0:
    IPADDR[0]="192.168.100.1"
    NETMASK[0]="255.255.255.0"
    USE_DHCP[0]=""
    DHCP_HOSTNAME[0]=""

    # Config information for eth1:
    IPADDR[1]="192.168.200.2"
    NETMASK[1]="255.255.255.252"
    USE_DHCP[1]=""
    DHCP_HOSTNAME[1]=""





  13. #13

    Padrão Re: Slack não reconhece eth1

    Para resolver de vez o problema, tive que compilar o Kernel.
    Agora a eth1 sobe no start up.

    Meus agradecimentos ao Willian Pires, pela prestimosa colaboração.

  14. #14

    Padrão Re: Slack não reconhece eth1 - RESOLVIDO!

    Por dia tente deixar 1kb do seu conhecimento na internet somente 1 kb 1024 caracteres !!!!

    Um abraço qualquer coisa é só chamar !