+ Responder ao Tópico



  1. #1

    Padrão SSH no Slackware

    Pessoal esses dias andei instalando algums slacks 10.2 e em todos eles estou tendo dificuldades no SSH, vou explicar, eu me logo pelo ssh com o putty e apos algums segundos de conexão eu sou derrubado da maquina... ai faço o login novamente e quando dou o comando w vejo q não tem ninguem conectado a ela(só para confirmar se foi problema de rede ou desconexão da maquina)... e com conectiva não estou tendo esse problemas, apenas com slack... tem algum macete? algum bug conhecido? algum configuração especial a ser feita no servidor ssh do slack? aguardo retorno de vocês e obrigado desde já.

  2. #2

    Padrão Re: SSH no Slackware

    Uma coisa eu garanto, não é problema do sshd do slack ;], passo horas conectado em servidores diferentes aqui e nunca tive esse problema. Não conheço a fundo as opções putty, pode ser que exista algo que feche a conexões inativas, não sei, mas bug do slack não É.



  3. #3

    Padrão Re: SSH no Slackware

    Bem... o SSH possui uma opção de timeout para conexões inativas... mas você não mencionou se isso acontece apenas quando você deixa a máquina largada lá com o PuTTY aberto ou se você é desconectado enquanto está digitando alguma coisa...

  4. #4

    Padrão Re: SSH no Slackware

    Estou sendo desconectado quando estou digitando qualquer coisa.... e não tem momento especifico... as vezes estou só dando algum comando no bash, outras vezes estou editando algum arquivo.... e o interessante é...... se eu estou editando algum arquivo, o trabalho é fechado... ex: uso o nano para editar, dai eu sou desconectado da maquina, quando reconecto nela o nano foi fechado e dou o w e vejo q não existe mais nem vestigio da minha conexão.... isso só acontece com slack..... conectiva, debian, mandriva... nunca tive problema, apenas com slack..... estou realmente sem saber o que é.....

    Um edit, estou acrescentando o meu arquivo do sshd do slack para que vocês analizem... aguardo retorno.

    Código :
    #    $OpenBSD: sshd_config,v 1.72 2005/07/25 11:59:40 markus Exp $
     
    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.
     
    # This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin
     
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.
     
    Port 22
    Protocol 2,1
    AddressFamily any
    ListenAddress 0.0.0.0
    #ListenAddress ::
     
    # HostKey for protocol version 1
    HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
     
    # Lifetime and size of ephemeral version 1 server key
    KeyRegenerationInterval 1h
    ServerKeyBits 768
     
    # Logging
    # obsoletes QuietMode and FascistLogging
    SyslogFacility AUTH
    LogLevel INFO
     
    # Authentication:
     
    LoginGraceTime 2m
    PermitRootLogin yes
    StrictModes yes
    MaxAuthTries 6
     
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile   .ssh/authorized_keys
     
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes
     
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication yes
    PermitEmptyPasswords no
     
    # Change to no to disable s/key passwords
    ChallengeResponseAuthentication yes
     
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
     
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
     
    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no
     
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
     
    # no default banner path
    #Banner /some/path
     
    # override default of no subsystems
    Subsystem    sftp  /usr/libexec/sftp-server



  5. #5

    Padrão Re: SSH no Slackware

    tenta assim:


    # $OpenBSD: sshd_config,v 1.72 2005/07/25 11:59:40 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    Port 22
    Protocol 2
    #AddressFamily any
    ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    # obsoletes QuietMode and FascistLogging
    SyslogFacility AUTH
    LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication yes
    PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    ChallengeResponseAuthentication no

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no

    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10

    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/libexec/sftp-server

  6. #6

    Padrão Re: SSH no Slackware

    Olá, não tive tempo de responder antes.... coloquei as configurações que você pediu lá..... só que não me toquei da porta que você colocou que era a 22.... ai perdi o acesso a maquina, pois o meu firewall só aceita conexão ssh na porta 10000.... vou ter que ir onde a maquina está e mudar a porta para voltar a ter acesso.... ai lhe dou o retorno para dizer se vai dar certo ou não. Até mais.



  7. #7
    RodrigoICN
    Visitante

    Padrão Re: SSH no Slackware

    Olá.
    A linha de config "LoginGraceTime" permite que o serv. te derrube no tempo especificado na mesma. No seu caso 2m, comente ela e tente novamente. abraços.

  8. #8

    Padrão Re: SSH no Slackware

    Pessoal mesmo colocando as regras como mostrado aqui no topico a conexão continua caindo... RodrigoICN a opção LoginGraceTime é para caso eu não faça login na maquina no tempo especificado eu seja derrubado... o problema é que eu faço login normal, mas quando estou conectado na maquina ela me desconecta enquanto eu estou usando.... estou sendo desconectando sem motivo.... por enquanto sem solução, se alguem poder me dar mais algum ajuda eu agradeço... lembrando que esse problema só está acontecendo com slack, com outras distros não tenho nenhum problema, obrigado a todos e aguardo retorno.



  9. #9

    Padrão Re: SSH no Slackware

    recompila o servidor ssh !!

  10. #10

    Padrão Re: SSH no Slackware

    Alexandre...... rsrs..... pode acreditar eu já tentei... rsrs... sempre que começo a compilar um novo servidor ssh a conexão cai.... num sei se é pra rir ou pra chorar.... vou tentar compilar esse troço de outra forma.... obrigado pela ajuda.



  11. #11

    Padrão Re: SSH no Slackware

    www.linuxpackages.net

    procura um pacote para seu slack ai

  12. #12

    Padrão

    Tente usar esse cliente de ssh e muito melhor do que o putty, pois nunca tive problemas com o ssh do slackware, muito pelo contrario sempre funcionou 100%


    SSH - Secure Shell


    Abraçao