+ Responder ao Tópico



  1. Olá pessoal,

    Tenho instalado o apache2 com php5 e mysql5, até ai tudo bem. No servidor web, tenho 3 dominios.

    servidor 1 => firewall e dns
    servidor 2 => web

    O problema é que quando acesso o www.dominio1.com.br ou www.dominio2.com.br, webmail.dominio1.com.br, entre outros, está indo tudo para o mesmo site.

    O que pode estar errado? abaixo irei colocar algumas configurações:

    Arquivos do APACHE2
    dominio1.net (virtualhost)
    <VirtualHost *>
    ServerName dominio1.net
    ServerAlias www.dominio1.net
    DocumentRoot /var/www/dominio1.net/
    Transferlog /var/www/dominio1.net/tras.log
    ErrorLog /var/www/dominio1.net/erro.log
    </VirtualHost>

    <VirtualHost *>
    ServerName webmail.dominio1.net
    ServerAlias email.dominio1.net
    DocumentRoot /var/www/dominio1.net/webmail/
    Transferlog /var/www/dominio1.net/tras.log
    ErrorLog /var/www/dominio1.net/erro.log
    </VirtualHost>

    dominio2.com.br (virtualHost)
    <VirtualHost *>
    ServerName dominio2.com.br
    ServerAlias www.dominio2.com.br
    DocumentRoot /var/www/dominio2.com.br
    </VirtualHost>

    Arquivos do DNS
    Dominio1
    ;
    ; BIND data file for site Dominio1
    ;
    $TTL 604800
    @ IN SOA infantaria.dominio1.net . root.dominio1.net. (
    1 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL

    NS infantaria.dominio1.net.

    ;
    localhost. IN A 127.0.0.1
    dominio1.net. IN A 192.168.1.3
    www IN A 192.168.1.3
    webmail IN A 192.168.1.3

    Dominio2
    ;
    ; BIND data file for site Dominio2
    ;
    $TTL 604800
    @ IN SOA infantaria.dominio2.com.br. root.dominio2.com.br. (
    1 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL

    NS infantaria.dominio2.com.br.

    ;
    localhost. IN A 127.0.0.1
    dominio2.com.br. IN A 192.168.1.3
    www IN A 192.168.1.3



    O que pode estar errado?

  2. eu estava com esse problema e a unica coisa que eu tentei e deu certo foi com a seguinte configuração

    NameVirtualhost 200.xxx.xxx.xxx //lembra que isso é meu ip
    <VirtualHost videos.meudominio.com.br>>
    ServerName videos.meudominio.com.br>
    ServerAdmin nilson@meudominio.com.br>
    DocumentRoot /var/www/videos.meudominio.com.br>/html

    ScriptAlias /cgi-bin "/var/www/videos.meudominio.com.br>/cgi-bin"
    <Directory "/var/www/videos.meudominio.com.br>/cgi-bin">
    AllowOverride None
    Options ExecCGI
    Order allow,deny
    Allow from all
    </Directory>


    </VirtualHost>

    <VirtualHost webmail.meudominio.com.br>
    ServerName webmail.meudominio.com.br
    ServerAdmin nilson@meudominio.com.br
    DocumentRoot /var/www/webmail.meudominio.com.br/html
    </VirtualHost>






Tópicos Similares

  1. Problemas com DNS Reverso
    Por TheMage no fórum Servidores de Rede
    Respostas: 11
    Último Post: 11-03-2005, 16:33
  2. Problemas com DNS reverso
    Por devlinmaxx no fórum Servidores de Rede
    Respostas: 3
    Último Post: 24-01-2005, 07:45
  3. Problema com DNS
    Por Cyber_Raven no fórum Servidores de Rede
    Respostas: 6
    Último Post: 01-07-2004, 14:26
  4. problemas com DNS?
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-06-2004, 14:30
  5. problemas com DNS
    Por beastie no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-08-2003, 09:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L