Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Viva colegas, vejam só.. tenho um servidor slackware 10.1
    ah pouco tempo, eu comprei uma caixa de USB 2.0 para ligar um disco IDE por usb
    liguei, tudo funcionou bem... etc
    so que no linux tá dando pau..
    eu tenho um macintosh IBook, liguei ele lá e tudo funciona mto bem, portanto o disco está bom fisicamente.
    no linux ja vi N how tos, como connectar discos externos, porem no meu slackware o dispositivo /dev/sda* nem seker existe... logo n posso montar, tentei cria-los ah mao, mas nem assim... diz que " sda..sda1..etc is not a valid block device" :S
    ja activei o hotplug faço um lsusb e apareçe la o disco, tal como os modulos usb-storage e companhia que tb foram carregados...
    creio que o problema é memso nos devices que n existem...
    alguem sabe como resolver o meu problema?
    Um abraço[][]

  2. Boa tarde amigo!

    O /dev/sda é padrao do kernel 2.4, se for 2.6 ele existe em /dev/uba.
    Se o device nao existir mesmo assim, faça:

    cd /dev
    ./MAKEDEV

    E procure os modulos ativos, como voce ja disse que eles ja estao loadados, isso deve resolver seu problema!
    Voce pode checar também se ele nao 'bindou' ele pra outro device, tal como hdb1, etc.

    Qualquer duvida volte a postar!



  3. caro colega, o meu kernel é o 2.6.16, na verdade o unico device que tenho é /dev/usbdev1.1 e /dev/usbdev1.2
    de qq modo tb n consigo montar eles...
    n sei que se passa.... todos os modulos possiveis e imaginarios estao carregados... contudo continuo sem conseguir aceder ao disco...

  4. Entendi..

    Bom, tente fazer o seguinte:

    cd /dev
    ./MAKEDEV

    Depois, por favor cole aqui pra mim, o que voltar de: lspci e lsusb, pra eu dar uma olhada de perto.
    O que eu posso dizer agora, é que voce pode checar se tem algo em /proc/scsi/usb-*, e olhe tambem por favor, o conteudo do syslog, sobre o hotplug e se ele volta algo do usb mass storage.

    Se for o caso, tente rodar o hotplug denovo, e olha o que ele volta. Por enquanto eu aguardo o retorno dos comandos!

    Uma coisa que já funcionou pra mim antes com dispositivos externos usb, foi pluga-los ao computador e reiniciar o sistema com ele plugado, ai ele reconhecia, pode tentar isso tambem.

    Qualquer duvida estamos aqui!



  5. desculpem a demora, n estava em casa..
    knto ao ./MAKEDEV ele tb n existe dentro do directorio /dev...
    a saida do lsusb é:

    root@Gotica:~# lsusb
    Bus 001 Device 002: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
    Bus 001 Device 001: ID 0000:0000
    root@Gotica:~#

    dps temos a seguir:

    root@Gotica:~# cat proc/scsi/usb-*
    cat: proc/scsi/usb-*: No such file or directory
    root@Gotica:~#

    estas sao as linhas depois de desligar e voltar a ligar o dispositivo:

    Jan 23 10:21:31 Gotica kernel: usb 1-1: new full speed USB device using uhci_hcd and address 3
    Jan 23 10:21:31 Gotica udevsend[2530]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2534]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2542]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2545]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2548]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2527]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:31 Gotica udevsend[2603]: udevd daemon started
    Jan 23 10:21:31 Gotica udevsend[2608]: udevd daemon started
    Jan 23 10:21:31 Gotica udevsend[2560]: udevd daemon started
    Jan 23 10:21:31 Gotica udevsend[2565]: udevd daemon started
    Jan 23 10:21:31 Gotica kernel: usb 1-1: configuration #1 chosen from 1 choice
    Jan 23 10:21:31 Gotica kernel: scsi1 : SCSI emulation for USB Mass Storage devices
    Jan 23 10:21:34 Gotica udevsend[2603]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:34 Gotica udevsend[2608]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:34 Gotica udevsend[2560]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:34 Gotica udevsend[2565]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:36 Gotica udevsend[2670]: udevd daemon started
    Jan 23 10:21:36 Gotica udevsend[2673]: udevd daemon started
    Jan 23 10:21:36 Gotica kernel: Vendor: FUJITSU Model: MPC3043AT Rev: 0811
    Jan 23 10:21:36 Gotica kernel: Type: Direct-Access ANSI SCSI revision: 00
    Jan 23 10:21:39 Gotica udevsend[2670]: unable to connect to event daemon, try to call udev directly
    Jan 23 10:21:39 Gotica udevsend[2673]: unable to connect to event daemon, try to call udev directly
    root@Gotica:~#

    para n restar duvidas, vou deixar tb os modulos carregados:

    root@Gotica:~# lsmod
    Module Size Used by
    nvidiafb 51932 0
    ehci_hcd 29128 0
    uhci_hcd 31472 0
    ohci_hcd 19652 0
    usb_storage 33220 0
    scsi_mod 84452 1 usb_storage
    usbcore 120900 5 ehci_hcd,uhci_hcd,ohci_hcd,usb_storage
    8139too 22688 0
    reiserfs 230384 1
    root@Gotica:~#

    essa dica de reiniciar com o USB ja plugado tb ja tentei, mas n funciona na mesma... como vcs podem ver, ele detecta o disco, mas n cria um device para ele, nem pelo udev, nem pelo mknod eu consigo criar um device para o disco...

    alguma ideia?







Tópicos Similares

  1. Respostas: 2
    Último Post: 10-10-2012, 10:41
  2. Respostas: 7
    Último Post: 30-01-2012, 22:50
  3. mouse usb com roda
    Por max_mori no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 11-08-2006, 17:47
  4. + shell script com o diabo no código !!!
    Por The-shadow no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 07-05-2006, 10:20
  5. Linux-2.6.6 e mouse USB com rodinha
    Por c0dek no fórum Servidores de Rede
    Respostas: 6
    Último Post: 14-05-2004, 21:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L