+ Responder ao Tópico



  1. #1
    cbjulio
    Visitante

    Padrão Mount no ubuntu

    boa tarde galera...alguém ai pode me ajudar a montar uma partição windows aqui com os nomes certos?
    to montando uma partição fat32 no ubuntu, mas ao copiar alguns arquivos para essa partição, ele modifica alguns nomes de arquivos, colocando por exemplo, onde tem um ç ele coloca um Ã, ou coisa parecida...mas isso soh aparece quando inicio o windows! aqui no ubuntu aparece tudo normal.
    fiz um teste: gravei um cd no k3b aqui agora, com vários mp3, com nomes variados, e no windows, esse mesmo cd aparece com os nomes normais! Ou seja, acho q o problema é no mount...
    também coloquei alguns parâmetros no meu mount(achei uns artigos falando sobre), para ver se tinha alguma coisa a ver com a codificação: um exemplo...mount -t vfat dev/hda1 media/hda1 -o iocharset=iso8859-1 ou utf8...tb mexi com os locales, colocando soh pra utf8, ou soh pra iso!
    Olha como fica: também
    backde rsrs...ja procurei em um monte de lugar, e não achei nada q resolvesse o problema!
    q chato!
    mas o interessante é que ao gravar o cd, ele usou a codificação certa para o windows de forma a reconhecer os caracteres de forma normal!
    Alguém pode me ajudar?

  2. #2

    Padrão Re: Mount no ubuntu

    Am... tenta montar utilizando como opção iso-8859-1. Funciona pra mim.



  3. #3
    cbjulio
    Visitante

    Padrão Re: Mount no ubuntu

    Achei o problema!!
    Valeu pela resposta amigo!! Descobri que tenho q fazer 2 modificações...a primeira eh mudar o locales do debian pra utf8(deixei soh esse locales instalado)...fiz o comando no ubuntu: #dpkg-reconfigure locales
    O proximo passo foi colocar isso que você falou, ou seja, montar o sistemas de arquivos (que no meu caso é fat32) com os parâmetros que especifiquei no locales...ou seja, ja que usei utf8 no locales, uso o utf8 no mount também!
    ai o comando de montagem ficou assim:
    #mount /dev/hda1 /media/hda1/ -t vfat -o iocharset=utf8
    Aqui fiz exatamente o que falei em cima...
    Obrigado pela ajuda!
    Até

  4. #4

    Padrão Re: Mount no ubuntu

    Ah sim, o meu funciona porque eu uso como charset do meu sistema iso-8859-1 =)

    Mas bacana, fico muito feliz por ter funcionado! =)



  5. #5
    cbjulio
    Visitante

    Padrão Re: Mount no ubuntu

    Valeu Stéfano. obrigado