+ Responder ao Tópico



  1. Observei a ordem das regras tentei assim, e não deu certo.

    reply_body_max_size 1597440 allow all
    reply_body_max_size 5242880 allow proxy_auth fulano

    Mudei a ordem dessas linhas e nada, da a mesma mensagem de erro, deem uma olhada nela

    squid.conf line 2019: reply_body_max_size 52428800 allow proxy_auth fulano
    aclParseAccessLine: ACL name 'proxy_auth' not found.
    squid.conf line 2019: reply_body_max_size 52428800 allow proxy_auth fulano
    aclParseAccessLine: ACL name 'fulano' not found.
    squid.conf line 2019: reply_body_max_size 52428800 allow proxy_auth fulano
    aclParseAccessLine: Access line contains no ACL's, skipping

    Agradeço desde ja a ajuda de todos.

  2. Do arquivo de configuração do Squid, squid.conf:

    # TAG: reply_body_max_size bytes allow|deny acl acl...
    # This option specifies the maximum size of a reply body in bytes.
    # It can be used to prevent users from downloading very largefiles,
    # such as MP3's and movies. When the reply headers are recieved,
    # the reply_body_max_size lines are processed, and the first line with
    # a result of "allow" is used as the maximum body size for this reply.
    # This size is checked twice. First when we get the reply headers,
    # we check the content-length value. If the content length value exists
    # and is larger than the allowed size, the request is denied and the
    # user receives an error message that says "the request or reply
    # is too large." If there is no content-length, and the reply
    # size exceeds this limit, the client's connection is just closed
    # and they will receive a partial reply.
    #
    # WARNING: downstream caches probably can not detect a partial reply
    # if there is no content-length header, so they will cache
    # partial responses and give them out as hits. You should NOT
    # use this option if you have downstream caches.
    #
    # If you set this parameter to zero (the default), there will be
    # no limit imposed.
    #
    #Default:
    # reply_body_max_size 0 allow all
    O problema é que você não declarou as ACL's que você está puxando, como proxy_auth e fulano, só para lembrar um pouco, proxy_auth é um tipo de ACL, e não pode ser utilizado como o nome de ACL's.

    Para utilizar da maneira que deseja, você deve criar uma ACL, chamada fulano:

    Código :
    acl fulano proxy_auth uepaehmeunomedeusuario

    E utilizar a tag da seguinte maneira:

    Código :
    reply_body_max_size 20971520 allow fulano

    Sacou, sacou?


    Um abraço!
    E utilizar da seguinte maneira:




  3. Deu 100% certo, agradeço a ajuda de todos só tem fera aqui na under, espero aprender muito aqui com vc's.
    Abraço a todos

  4. O karma positivo ninguém lembra, hehehehe.




  5. Stéfano ...........

    De Squid é sopa para voê ..........
    Eu fico só acompanhando e aprendendo ...........hehehehehehe
    E continue assim .................
    Squid é contigo mesmo ............... :-)






Tópicos Similares

  1. Limitar Download de Arquivos
    Por xadouron no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-01-2008, 16:20
  2. Como limitar downloads
    Por tomega no fórum Redes
    Respostas: 2
    Último Post: 07-03-2007, 17:22
  3. Limitar Download
    Por rafaelmontek no fórum Servidores de Rede
    Respostas: 12
    Último Post: 30-08-2006, 13:39
  4. Delay pool - limitar download
    Por cvr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-08-2006, 23:03
  5. limitar download tamanho do arquivo
    Por tes454 no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-06-2005, 02:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L