+ Responder ao Tópico



  1. #1
    tonto
    Caros colegas!

    Estou com linux debian 3.1 sarge instalado em um PC IV 1.6 ghz com 256 de ram hd 40 GB com duas placas de redes sendo uma on board SIS 900 e outra off board VIA.

    1º quando uso o comando IFCONFIG a placa de rede eth 1 não aparece ,,ai eu tenho que complementa o comando o a eth 1 isso é normal...?

    2º ao utiliza o comando IFCONFIG ETH 1 17.0.0.12 (rede local) eu reinicio o pc e a eth 1 pede a configuração de rede. Isso é normal?

    3º tenho um link speedy power 500 pppoe onde este ligado na eth0 (a eth0 esta sem ip, pois ao declarar o ip o link pppoe para de funcionar! Isso é norma)?

    4º o mais frustrante é que o básico do iptables que é o compartilhamento da Internet eu não consigo fazer funcionar.!!

    Alguém poderia me orientar nas duvidas , procedimento e execução.?


    100 = Tonto

  2. Olá amiguinho!

    Bem... vamos responder suas perguntas, uma a uma:

    1 - Geralmente o ifconfig mostra todas as interfaces levantadas. Quando a gente quer ver apenas uma das interfaces (O quê é bem comum quando se tem 50 placas de rede no servidor e trabalha-se com resolução de 80x25), nós o utilizamos da seguinte maneira:

    Código :
    # ifconfig ethX
    Onde "X" é o número da sua placa de rede. Sem espaços, diferentemente do modo que você está utilizando.

    2 - Sim, é normal. É normal porque o Debian não configura as duas placas de rede na instalação e você tem que configurar a outra manualmente. Para configurá-la, utilize o arquivo /etc/network/interfaces. Sua sintaxe correta está no MAN (man interfaces) ou no Focalinux. O link é bem mais direto e eu recomendo sua lida. 99% de certeza que vai resolver seu problema.

    3 - Eu sinceramente estou por fora dos novos planos da Telefônica em relação ao Speedy, mesmo porque eu possuo em casa um plano antigo e geralmente só trabalho com LP's, mas a regra geralmente é essa: Speedy Business a gente deixa a placa para pegar DHCP e Speedy Home a gente configura uma interface PPP. Para o primeiro caso, você vai encontrar a solução no próprio Focalinux, sobre como deixar a interface para pegar IP automaticamente. Para o segundo, basta fazer uso do script pppoeconf (Relaxa, ele já faz parte do sistema básico Debian e já vai estar instalado. Só rodar no shell). Ele é um shell-script utilizando dialog fazendo perguntas simples de serem respondidas por qualquer usuário. Acredite, QUALQUER usuário.

    Lembre-se de reiniciar os serviços de rede depois das configurações.

    Talvez como conseqüência disso você tenha que editar a sua rota-padrão do sistema, você pode colocar um script na inicialização editando as rotas, algo como:

    a) Crie o script dentro de /etc/init.d, com o nome "roteamento" com este conteúdo:
    Código :
    #!/bin/bash
    route del default
    route add default dev ppp0

    b) Dê permissão de execução:
    Código :
    # chmod +x roteamento

    c) Coloque-o na inicialização
    Código :
    # update-rc.d roteamento start 99 2 3 4 5 .

    4 - O básico do roteamento do IPTables é o básico do roteamento do IPTables, hehehe.

    Tu pode editar o arquivo /etc/network/options e liberar o roteamento de pacotes alterando a primeira linha para "yes" (Eu acho que é na primeira linha), ou fazendo o bom e velho:

    Código :
    # echo 1 > /proc/sys/net/ipv4/ip_forward
    # iptables -t nat -A POSTROUTING -o $INTERFACE_SAIDA -j MASQUERADE

    Acho que isso resolve o seu problema, mas posta o resultado, dando certo ou não.

    PS: Não entendi sua última frase, hehehehe.


    Abraços!



  3. rapaiz..

    depois de uma receita dessa é só colocar o bolo no forno, preparar a manteiga e o kisuco.. hehehe






Tópicos Similares

  1. Estou Ficando Louco
    Por adelsonbbg no fórum Redes
    Respostas: 10
    Último Post: 14-05-2008, 21:57
  2. Sera que só eu estou tendo esse problema?
    Por diegofsousarn no fórum Sistemas Operacionais
    Respostas: 11
    Último Post: 08-08-2006, 07:11
  3. dns confuso.Ou eu estou louco?
    Por fisiconuclear18 no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-05-2006, 07:32
  4. estou ficando doido já com o fetcmail.
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-09-2005, 10:50
  5. Por Favor :( estou ficando louco com iptables
    Por alimasilva no fórum Servidores de Rede
    Respostas: 24
    Último Post: 15-08-2005, 16:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L