+ Responder ao Tópico



  1. #1
    bandlinux
    Visitante

    Padrão Erro ao ingressar máquina em domínio samba/ldap

    Boa tarde,

    Pessoal estou com um problema na hora de inserir máquinas no samba usando ldap em outro servidor como autenticador.

    "erro durante a tentativa de ingresso no dominio "exemplo.com""
    Não foi possível locallizar o nome de usuário.

    Agradeço desde já a ajuda...

  2. #2
    eudesafp
    Visitante

    Padrão Re: Erro ao ingressar máquina em domínio samba/ldap

    Olá !
    Não tenho muito conhecimento em LDAP-SAMBA mas no entanto implantei a pouco tempo na minha empresa este seviço, fiz um PDC com ldap e samba. Também tive esse erro no começo... eu usei também o pacote smbldap-tools
    A principio verifique se o usuário foi criado...(Para criar use os comandos)

    smbldap-useradd -m -a username
    smbldap-passwd username
    smbpasswd username

    Veja tb:
    http://www.samba.org/samba/docs/man/...ide/happy.html

    Me diga se deu certo !



  3. #3
    eudesafp
    Visitante

    Padrão Re: Erro ao ingressar máquina em domínio samba/ldap

    Mais um detalhe...
    Uma ferramenta que usei e me ajudou muito foi o phpldapadmin...

  4. #4
    bandlinux
    Visitante

    Padrão Re: Erro ao ingressar máquina em domínio samba/ldap

    Bom dia..
    Cara Obrigado pela atençao, mas este procedimento já havia realizado...

    Estou desconfiado pois quando utilizei a ferramenta smbldap-tools, pois o usuário que estou utilizando aqui como cn=Administrador está criado , chega a criar o nome da máquina no ldap mas mesmo assim me retorna o erro..

    Abraços.



  5. #5
    eudesafp
    Visitante

    Padrão Re: Erro ao ingressar máquina em domínio samba/ldap

    Esse problema que vc está descrevendo aconteceu identico ao meu...
    Mas tem uma coisa que vc disse que achei estranho...
    Normalmente o smbldap-tools cria um usuário root que vai adicionar as máquinas no domínio...
    Caso vc esteja utilizando este usuário e ainda está dando erros, veja como está o seu aquivos:
    /etc/openldap/ldap.conf /etc/ldap.conf /etc/pam.d/system-auth
    Provavelmente algum deles está com algum erro.

    Veja:
    http://ufpr.dl.sourceforge.net/sourc...o_20060710.pdf

    Falow