Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    cl2b2r
    Ola Forum
    Tentei a não muito tempo configurar um compartilhamento de internet

    atravéz de banda larga via radio e não tive exito. Muito embora eu

    tenha revisado os logs e as configurações por diversas vezes não achei

    nenhuma justificativa para não ter dado certo, por isso peço que

    alguem me ajude a enxergar onde errei; eu tinha a seguinte situação:

    placa eth0 ( Link da internet)
    ip 192.168.3.48
    mascara 255.255.255.0
    gateway 192.168.3.100
    dns 200.157.229.140


    placa eth1 (placa de saida do dhcp)

    ip 192.168.1.1
    mascara 255.255.255.0
    dns 192.168.1.1


    Fiz as configurações do dhcp3-server:

    ddns-update-style none;
    server-identifier 192.168.1.1;
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.10 192.168.1.50;
    option domain-name "internet.local";
    option domain-name-servers 192.168.1.1, 200.157.229.140;
    option routers 192.168.1.1;*
    }

    *OBS: tentei tb com 192.168.3.100

    meu DNS estava configurado assim:

    named.conf
    zone "internet.local" {
    type master;
    file "/etc/bind/db.internet.local";
    };

    zone "1.168.192.in-addr.arpa" {
    type master;
    file "/etc/bind/db.1.168.192";


    meu arquivo db.internet.local
    $TTL 604800
    @ IN SOA servidor.internet.local. root.internet.local.

    (
    1 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    servidor IN A 192.168.1.1
    www IN A 192.168.1.1
    mail IN A 192.168.1.1
    ;
    @ IN MX 5 servidor.internet.local.
    @ IN NS servidor.internet.local.
    @ IN A 192.168.1.1


    Meu arquivo db.1.168.192
    $TTL 604800
    @ IN SOA servidor.internet.local. root.internet.local.

    (
    1 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS servidor.internet.local.
    1 IN PTR servidor.internet.local.
    mail IN CNAME servidor.internet.local.
    www IN CNAME servidor.internet.local.


    apos estas configurações eu apliquei a seguinte regra do iptables:

    iptables -A POSTROUTING -t nat -s 192.168.3.0/24 -d 0/0 -j MASQUERADE

    e não foi, daí tentei tb

    iptables -A POSTROUTING -t nat -s 192.168.0.0/24 -d 0/0 -j MASQUERADE

    e tb não foi! O curioso é que as maquinas pegaram IP normalmente, nos
    dois casos acharam o gateway, pingavam o servidor pelo nome de dominio
    mas ... entrar na internet que é bom nada!
    OBS: O servidor esta acessando normalmente, o problema e o
    compartilhamento
    Se alguém puder me dar uma força ficarei imensamente grato




  2. Nao li a fundo seus arquivos de configuracao mas acredito que o seu problema seja apenas habilitar o encaminhamento de pacotes, ja que os clientes pegam ip, gateway e dns.

    para verificar se o mesmo está ativo, entre com o comando:

    sysctl -a | grep ip_forward

    Para alterar seu estado (0 para off, 1 para on)

    sysctl -w net.ipv4.ip_forward=1

    Para configuracao permanente, adicione a linha net.ipv4.ip_forward=1 no arquivo /etc/sysctl.conf

    Fabio K. Lima
    LPIC1/81913




  3. #3
    cl2b2r
    Muito obrigado pela dica Fabio mais eu habilitei sim o roteamento, sendo que no meu caso como estou usando debian eu fiz pelo arquivo :
    /etc/network/option(s?)
    la eu coloquei :
    ip-foward=yes
    mas mesmo com isso habilitado o compartilhamento não funcionou de maneira nenhuma.
    Não sei se tem alguma relação mais a placa eth0 é uma sis900 on-board e a eth1 é uma realtek.
    Tenho outra pergunta:
    No meu caso, qual seria o gateway correto a utilizar, o meu endereço 192.168.1.1; ou o gateway do provedor de internet 192.168.3.100 ?

  4. O gateway das maquinas atrás do seu servidor esta' correto, 192.168.1.1.
    Lendo suas regras de mascaramento agora, as duas estão incorretas, corriga-as e veja se soluciona o problema. A regra correta é:

    iptables -t nat -A POSTROUTING -o eth0 -s 192.168.1.0/24 -j MASQUERADE

    Só uma duvida, as maquinas da rede 192.168.1.0/24 enchergam normalmente o gateway (192.168.1.1) ?

    Att,

    Fabio K. Lima
    LPIC1/81913




  5. #5
    cl2b2r
    vc diz meu gateway 192.168.1.1?
    so quando eu coloco la no dhcp.conf:
    option routers 192.168.1.1;
    fora isto não chegam não

    obs: não sei se é por isso mais as maquinas são windows xp






Tópicos Similares

  1. COMPARTILHAMENTO DE INTERNET USANDO FREEBSD COM MODEM ADSL EM BRIDGE
    Por xXNeoXx no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 19-07-2011, 10:40
  2. Respostas: 1
    Último Post: 09-06-2009, 12:00
  3. Compartilhamento de Internet
    Por no fórum Servidores de Rede
    Respostas: 17
    Último Post: 25-04-2003, 22:12
  4. Compartilhamento de Internet
    Por Bruno no fórum Servidores de Rede
    Respostas: 4
    Último Post: 17-01-2003, 09:15
  5. Compartilhamento de internet (Linux como cliente)
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-01-2003, 11:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L