+ Responder ao Tópico



  1. NetWath para que sabe

    Gostaria de saber o que este conjunto de script faz, e que peguei um backup de
    um amigo e achei isto ai la e gostaria de entender este script.

    / tool netwatch
    add host=200.199.252.68 timeout=1s interval=1m up-script=LINK1-UP \
    down-script=LINK1-DOWN comment="TESTE LINK1" disabled=no
    add host=200.253.251.32 timeout=1s interval=1m up-script=LINK2-UP \
    down-script=LINK2-DOWN comment="TESTE LINK2" disabled=no
    add host=200.199.252.72 timeout=1s interval=1m up-script=LINK3-UP \
    \n comment="TESTE LINK3" disabled=no
    add host=200.203.191.8 timeout=1s interval=1m up-script=LINK4-UP \
    down-script=LINK4-DOWN comment="TESTE LINK4" disabled=no


    / system script
    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-UP" source="/ip route set \[/ip route find comment=link3\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-UP" source="/ip route set \[/ip route find comment=link4\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-DOWN" source="/ip route set \[/ip route find comment=link3\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-DOWN" source="/ip route set \[/ip route find comment=link4\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox

  2. pro2,

    O netwatch verifica links (usando um ping simples) para ver quem está online ou offline. É muito usado para mudar a rota default de uma máquina quando um dos links cai. Sinceramente acho que o script do seu amigo está completamente equivocado:

    http://www.mikrotik.com/docs/ros/2.9/tools/netwatch



  3. Cara, pelo que parece o primeiro script faz a checagem dos Links de Internet (tipo, balanceamento) se estão down. Se sim, ai no segundo script ele vai definir o que fazer caso o LinkX esteja down.

  4. roney,

    Veja que tanto o script de UP quanto o de DOWN fazem a mesma coisa... Ele procura o gateway do link que caiu e seta ou desativa ele. A não ser que ele deixe todos os links ativos e quando um cai ele só remove o gateway esse script estaria errado.

    Normalmente você faz o UP para habilitar o link normal e desativar o secundário e o DOWN para fazer o contrário.






Tópicos Similares

  1. Respostas: 6
    Último Post: 31-08-2012, 15:03
  2. Respostas: 1
    Último Post: 21-08-2003, 16:18
  3. dominio virtual no openwebmail que sabe????
    Por Leyzem no fórum Servidores de Rede
    Respostas: 1
    Último Post: 31-03-2003, 07:53
  4. Respostas: 1
    Último Post: 10-03-2003, 11:37
  5. para que servem estes comandos?
    Por no fórum Servidores de Rede
    Respostas: 20
    Último Post: 17-01-2003, 20:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L