+ Responder ao Tópico



  1. #1
    fernando_ramos
    Amigos,

    Estou tendo alguns problemas para configurar o DNS.

    Vamos lá:

    os meus arquivos:

    named.conf.options
    Código :
    options {
        directory "/var/cache/bind";
     
        // If there is a firewall between you and nameservers you want
        // to talk to, you might need to uncomment the query-source
        // directive below. Previous versions of BIND always asked
        // questions using port 53, but BIND 8.1 and later use an unprivileged
        // port by default.
     
        // query-source address * port 53;
     
        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.
     
        // forwarders {
        //   0.0.0.0;
        // };
     
        auth-nxdomain no;  # conform to RFC1035
     
    };

    named.conf

    Código :
    include "/etc/bind/named.conf.options";
     
    // prime the server with knowledge of the root servers
    zone "." {
        type hint;
        file "/etc/bind/db.root";
    };
     
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
     
    zone "localhost" {
        type master;
        file "/etc/bind/db.local";
    };
     
    zone "127.in-addr.arpa" {
        type master;
        file "/etc/bind/db.127";
    };
     
    zone "0.in-addr.arpa" {
        type master;
        file "/etc/bind/db.0";
    };
     
    zone "255.in-addr.arpa" {
        type master;
        file "/etc/bind/db.255";
    };
     
    zone "framosip.sytes.net"{
        type master;
        file "/slave/dns/db-framosip";
    };
     
    zone "0.168.192.in-addr.arpa"{
        type master;
        file "/slave/dns/db-framosip.rev";
    };
    include "/etc/bind/named.conf.local";

    db-framosip:

    Código :
    $ORIGIN framosip.sytes.net.
    $TTL 3600
    @ IN SOA fr01 root (
        2
        500
        300
        2w
        1w
        )
    @ IN NS fr01
    @ IN MX 1 fr01
    fr01 IN A 192.168.0.1
    fr02 IN A 192.168.0.2


    db-framosip.rev:

    Código :
    $TTL 3600
    @ IN SOA fr01 root (
        22
        500
        300
        2w
        1w
        )
    @ IN NS fr01
    @ IN MX 1 fr01
    1 IN PTR fr01
    2 IN PTR fr02


    vamos aos problemas:

    1º Quando dou um named-checkconf db-framosip o que retorna é:

    Código :
    db-framosip:1: unknown option '$ORIGIN'
    db-framosip:17: unexpected token near end of file


    2º Minha conexão é ADSL(VELOx - RJ), então quando o velox conecta, ele limpa o meu arquivo resolv.conf e coloca os NAMESERVERs do velox, ou seja, a minha configuração do DNS no resolv.conf vai pro espaço...alguma ideia pra resolver isso?


    abraços!

  2. 1 - Pra tu resolver esse problema de atualizar o resolv.conf, tu pode editar o seu cliente do DHCP para não puxar esse tipo de configuração. Não dá pra falar o procedimento porque depende do client DHCP que você está utilizando =/

    2 - Estranho ele reclamar de uma linha que teoricamente não existe no arquivo... no db-framosip não existe a linha 17... mas apaga a linha $ORIGIN que funfa.


    Abraços!



  3. #3
    fernando_ramos
    Amigo,

    Fiquei na duvida, por que nao tenho DHCP no meu servidor Debian, este problema do resolv.conf esta ao se conectar ao velox, que limpa o resolv.conf e coloca os ips do velox!

    Quanto ao problema do DNS, se eu tiro a linha do $ORIGIN ele da erro na próxima linha...e assim por diante....

    estranho...não?

    abraços!

  4. #4
    mhp
    Para usar a diretiva $ORIGIN voce tem que antes definir a zona raiz (somente um ponto).
    Aí vai a configuração que eu uso, então garanto que funciona (adapte à sua necessidade):

    mhp.zone:
    Código :
    $ORIGIN .
    $TTL 604800   ; 1 week
    mhp           IN SOA rt. root.rt. (
                    1        ; serial
                    604800     ; refresh (1 week)
                    86400      ; retry (1 day)
                    2419200     ; expire (4 weeks)
                    604800     ; minimum (1 week)
                    )
                NS   rt.mhp.
                A    192.168.144.250
    $ORIGIN mhp.
    rt            A    192.168.144.250
    kakin         A    192.168.144.220
    sucata         A    192.168.144.230
    trash          A    192.168.144.240

    mhp.zone-rev:
    Código :
    $ORIGIN .
    $TTL 604800   ; 1 week
    144.168.192.in-addr.arpa    IN SOA rt. root.rt. (
                    1        ; serial
                    604800     ; refresh (1 week)
                    86400      ; retry (1 day)
                    2419200     ; expire (4 weeks)
                    604800     ; minimum (1 week)
                    )
                NS   rt.mhp.
    $ORIGIN 144.168.192.in-addr.arpa.
    $TTL 604800   ; 1 week
    250           PTR   rt.mhp.
    240           PTR   trash.mhp.
    230           PTR   sucata.mhp.
    220           PTR   kakin.mhp.

    Quanto ao arquivo resolv.conf estar sendo sobrescrito, procure pela diretiva "usepeerdns" no arquivo de configuração do provedor ADSL (no meu caso é /etc/ppp/peers/dsl-provider) e comente-a. Depois edite o arquvo resolv.conf colocando apenas o endereço do seu servidor.






Tópicos Similares

  1. Compartilhamento de internet com dhcp e bind9, help, please!
    Por cl2b2r no fórum Servidores de Rede
    Respostas: 10
    Último Post: 13-09-2006, 09:45
  2. MOVIDO: Bind9
    Por Duca no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-09-2006, 09:33
  3. DNS dinâmico, bind9+dhcp não conversam.
    Por adrianoc no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-02-2005, 04:54
  4. Iniciar o BIND9 sem o rncd ????
    Por Mita no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-04-2004, 21:40
  5. BIND9
    Por Ibere Spadoto no fórum Servidores de Rede
    Respostas: 0
    Último Post: 01-04-2004, 09:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L