Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal, boa noite.
    Tentei instalar no meu SUSE 10.0 o amsn, porem ele reclamou da libc.so.6, ai percebi que teria que atualizar a glibc, para a glibc-2.4, mas apos algumas tentativas ele reporta o seguinte erro:
    este erro e finalizando o make install
    rm -f /tmp/glibc-build/elf/symlink.list
    rm: relocation error: /lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
    make[1]: *** [install-symbolic-link] Error 127
    make[1]: Leaving directory `/tmp/glibc-2.4'
    make: *** [install] Error 2
    # dmesg
    dmesg: relocation error: /lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
    Poderiam me ajudar?
    Agradeco a atencao de todos.

  2. Também utilizo o suse 10, e instalei o amsn nele.
    Baixei o fonte, como você fez. verifique o seguinte:

    se o tk está instalado, tls, e posta ai pra nos o resultado do make.

    Flw



  3. Olá Vitor, tudo bem?
    Muito obrigado pela resposta, poderia me dizer, como instalou o amsn no SUSE 10.0?
    Tipo ele pede uma biblioteca nova, a glibc.6.so e não encontro o rpm dela.
    Poderia me ajudar?
    Abraço e muito obrigado.
    PS:Em relação ao caso acima, sem chances, formatei a maquina e reinstalei o suse 10 novamente, mas obrigado.

  4. Estas tentando instalar do rpm? Com ele tive o problema de dependencia do glibc.
    Mesmo eu tendo o glibc instalado no meu SuSE, ele pedia uma versão mais nova.

    Na página de download do amsn, http://amsn.sourceforge.net/download.php eu baixei o tarball source, descompactei e dei um ./configure para verificar quais dependencias faltavam.
    depois de tudo certo, dei um make e make install. Posta aí pra nós a saída do ./configure antes de continuarmos, pode ser?



  5. Vitor, bom dia.
    Fiz o procedimento que voce recomendou, porem segue abaixo o erro:
    Linux:/tmp/amsn-0.96RC1 # ./configure
    checking for prefix by checking for wish... /usr/bin/wish
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for g++... g++
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking tcl build dir... ./configure: line 2770: locate: command not found
    using tcl library in /usr/lib
    checking tk build dir... using tk library in /usr/lib
    checking for main in -lstdc++... yes
    checking how to run the C preprocessor... gcc -E
    checking for X... no
    "Could not find X11 devel package
    checking for ftello... yes
    checking for fseeko... yes
    checking for getpt... yes
    checking for strcasestr... yes
    checking for memmem... yes
    checking for dlopen... no
    checking for pthread_create in -lpthread... yes
    checking if mmx should be used... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating utils/linux/capture/config.h
    config.status: utils/linux/capture/config.h is unchanged

    compile time options summary
    ============================

    X11 : no
    Tcl : 8.4
    TK : 8.4
    DEBUG : no
    STATIC : no






Tópicos Similares

  1. Instalação do AMSN
    Por shupe no fórum Servidores de Rede
    Respostas: 4
    Último Post: 03-09-2005, 23:44
  2. Instalaçao do amsn
    Por edu_uti no fórum Redes
    Respostas: 5
    Último Post: 23-02-2005, 21:27
  3. Atualização da glibc
    Por chvt no fórum Linguagens de Programação
    Respostas: 4
    Último Post: 17-02-2004, 16:28
  4. atualização da glibc afeta o Kylix ?
    Por Wronieri no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-10-2003, 11:45
  5. Instalação do Driver da Nvidia no Red Hat 8.0
    Por Elvis no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-01-2003, 08:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L