+ Responder ao Tópico



  1. #1

    Padrão Balanceamento problemas

    Olá galera, sou iniciante no mikrotik, mas vi que não é um sistema muito complicado, meu problema é o seguinte:
    Coloquei o mikrotik em uma maquina com 4 placas de rede, fazendo balanceamento de acordo com esse link http://wiki.mikrotik.com/wiki/Load_Balancing_Persistent. O Balanceamento está funcionando, porém apresenta um problema, por exemplo se um link parar o acesso web fica lento. alguém pode me ajudar.
    agradeço.

  2. #2

    Padrão Re: Balanceamento problemas

    Caro Sérgio

    Seria interessante você detalhar de quanto é seu link principal, o secundário (se é full ou ADSL)
    Sao 2 links de entrada e 2 saidas?
    Detalhe melhor a configuração das suas placas de rede.

    Há outro tutorial para isso (agora nao consegui localizar aqui), mas tem em outro topico, que ja utilizei e funciona perfeitamente.

    Vá relatando os detalhes da sua rede, que vamos tentando ajudar.



  3. #3

    Padrão Re: Balanceamento problemas

    Citação Postado originalmente por Liandro Paulo Carniel
    Caro Sérgio

    Seria interessante você detalhar de quanto é seu link principal, o secundário (se é full ou ADSL)
    Sao 2 links de entrada e 2 saidas?
    Detalhe melhor a configuração das suas placas de rede.

    Há outro tutorial para isso (agora nao consegui localizar aqui), mas tem em outro topico, que ja utilizei e funciona perfeitamente.

    Vá relatando os detalhes da sua rede, que vamos tentando ajudar.
    Serão três links sendo 1 telemar, e 2 ADSL, o primario é o telemar.
    o esquema de balanceamento é o seguinte, entra tres links de internet e sai apenas um, tu me entendes Liandro?

  4. #4

    Padrão Re: Balanceamento problemas

    Explica melhor isso... tá complicado de entender o qu fez... Entra 3 e sai 1??????



  5. #5

    Padrão Re: Balanceamento problemas

    É o Seguinte,

    Tenho um mikrotik, com 4 placas de rede, nenhuma esta com conflito de irq, todas em irq diferente.

    dessas 4 placas 3 recebem internet e 1 passa internet para rede interna.

    as 3 que recebem internet, esta configurada da seguinte forma:
    1. 192.168.0.1/24
    2. 192.168.1.1/24
    3. 201.x.x.x/29

    a 4 placa que envia para rede internet está 10.1.1.1/8

  6. #6

    Padrão Re: Balanceamento problemas

    Posta suas regras que usou no balanceamento...



  7. #7

    Padrão Re: Balanceamento problemas

    Citação Postado originalmente por brenovale
    Posta suas regras que usou no balanceamento...
    ip firewall mangle


    add chain=prerouting src-address-list=gw1 in-interface=ether4 action=mark-connection new-connection-mark=gw1 passthrough=yes

    add chain=prerouting src-address-list=gw1 in-interface=ether4 action=mark-routing new-routing-mark=gw1


    add chain=prerouting src-address-list=gw2 in-interface=ether4 action=mark-connection new-connection-mark=gw2 passthrough=yes

    add chain=prerouting src-address-list=gw2 in-interface=ether4 action=mark-routing new-routing-mark=gw2


    add chain=prerouting src-address-list=gw3 in-interface=ether4 action=mark-connection new-connection-mark=gw3 passthrough=yes

    add chain=prerouting src-address-list=gw3 in-interface=ether4 action=mark-routing new-routing-mark=gw3


    add chain=prerouting in-interface=ether4 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=gw1 passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface=ether4 connection-mark=gw1 action=mark-routing new-routing-mark=gw1 passthrough=no comment="" disabled=no


    add chain=prerouting in-interface=ether4 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=gw2 passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface=ether4 connection-mark=gw2 action=mark-routing new-routing-mark=gw2 passthrough=no comment="" disabled=no


    add chain=prerouting in-interface=ether4 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=gw3 passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface=ether4 connection-mark=gw3 action=mark-routing new-routing-mark=gw3 passthrough=no comment="" disabled=no



    ----------------


    ip firewall nat


    add chain=srcnat connection-mark=gw1 action=src-nat to-addresses=201.x.x.x to-ports=0-65535 comment="" disabled=no

    add chain=srcnat connection-mark=gw2 action=src-nat to-addresses=192.168.100.254 to-ports=0-65535 comment="" disabled=no

    add chain=srcnat connection-mark=gw3 action=src-nat to-addresses=192.168.101.254 to-ports=0-65535 comment="" disabled=no


    ----------------


    ip route


    add dst-address=0.0.0.0/0 gateway=201.x.x.x scope=255 target-scope=10 routing-mark=gw1 comment="" disabled=no

    add dst-address=0.0.0.0/0 gateway=192.168.100.1 scope=255 target-scope=10 routing-mark=gw2 comment="" disabled=no

    add dst-address=0.0.0.0/0 gateway=192.168.101.1 scope=255 target-scope=10 routing-mark=gw3 comment="" disabled=no

    add dst-address=0.0.0.0/0 gateway=201.x.x.x scope=255 target-scope=10 comment="" disabled=no

  8. #8

    Padrão Re: Balanceamento problemas

    Não observei com muita atenção mas parece que quando cai uma conexao, o acesso fica lento, pois me parece que nas primeiras regras do Mangle ele força (Persistent) a ficar aquela rota naquele GW.


    Tente analisar esse outro tutorial

    http://wiki.mikrotik.com/wiki/Improv...tiple_Gateways

    As poucas diferenças estão no Mangle (creio que retirar as 6 primeiras regras do Mangle), e trocar os valores do nth, pois como você tem 3 links de entrada, os valores tem que mudar. Pois vocë tem nth=1,1,0 para o GW 2 e o mesmo valor para o GW3

    Tente (não sei se vai dar certo) nth=1,1,0 - nth=2,1,0 - nth=2,1,1
    Mas acho que o principal sáo as 6 primeiras regras... Como esse outro tutorial voce conseguirá



  9. #9

    Padrão Re: Balanceamento problemas

    Estou estudando os efeitos desses scripts : funciona 100% num load balance de um amigo meu com 4 links. Dê uma lida que vc vai entender o objetivo deles. Faça suas alterações e poste aqui o resultado.

    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-UP" source="/ip route set \[/ip route find comment=link3\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-UP" source="/ip route set \[/ip route find comment=link4\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-DOWN" source="/ip route set \[/ip route find comment=link3\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-DOWN" source="/ip route set \[/ip route find comment=link4\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox

    Falow ...!

  10. #10

    Padrão Re: Balanceamento problemas

    Citação Postado originalmente por Liandro Paulo Carniel
    Não observei com muita atenção mas parece que quando cai uma conexao, o acesso fica lento, pois me parece que nas primeiras regras do Mangle ele força (Persistent) a ficar aquela rota naquele GW.


    Tente analisar esse outro tutorial

    http://wiki.mikrotik.com/wiki/Improv...tiple_Gateways

    As poucas diferenças estão no Mangle (creio que retirar as 6 primeiras regras do Mangle), e trocar os valores do nth, pois como você tem 3 links de entrada, os valores tem que mudar. Pois vocë tem nth=1,1,0 para o GW 2 e o mesmo valor para o GW3

    Tente (não sei se vai dar certo) nth=1,1,0 - nth=2,1,0 - nth=2,1,1
    Mas acho que o principal sáo as 6 primeiras regras... Como esse outro tutorial voce conseguirá
    Na verdade eu já tirei as seis primeiras regras, e nao mudou muito não, vou ve a questão do nth.



  11. #11

    Padrão Re: Balanceamento problemas

    Citação Postado originalmente por rps67
    Estou estudando os efeitos desses scripts : funciona 100% num load balance de um amigo meu com 4 links. Dê uma lida que vc vai entender o objetivo deles. Faça suas alterações e poste aqui o resultado.

    add name="LINK1-UP" source="/ip route set \[/ip route find comment=link1\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-UP" source="/ip route set \[/ip route find comment=link2\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-UP" source="/ip route set \[/ip route find comment=link3\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-UP" source="/ip route set \[/ip route find comment=link4\] \
    disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="LINK1-DOWN" source="/ip route set \[/ip route find comment=link1\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK2-DOWN" source="/ip route set \[/ip route find comment=link2\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK3-DOWN" source="/ip route set \[/ip route find comment=link3\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="LINK4-DOWN" source="/ip route set \[/ip route find comment=link4\] \
    disabled=yes" policy=ftp,reboot,read,write,test,winbox

    Falow ...!
    Olá, tem como vc passar esse script completo? Agradeço, pois fica melhor para estudar como ele funciona.

  12. #12

    Padrão Re: Balanceamento problemas

    Se você não tiver muita pressa, me procure durante a semana, que podemos dar uma olhada "inloco" ai no seu servidor (remotamente logico)