+ Responder ao Tópico



  1. #1

    Padrão erro Mysql (bobo mais não sei...)

    Ops, galera to com uma dúvida achu q pode ser muito simples mais como estou apredendo agora mysql quem quer aprender tem q perguntar então ai vai conseguir instalar o mysql e tal estou usando o slackware 10.1 e instalei do proprio CD usei a instalação [full] agora estou usando o tutorial do jeffestanislau http://www.vivaolinux.com.br/artigos...o=455&pagina=3 para gerenciar o bando de dados mais quando dou o comando:
    [email protected]:/usr/bin# mysqladmin -u root password
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user: '[email protected]' (Using password: NO)'
    [email protected]:/usr/bin#
    Da esse erro, alguem sabe o que pode ser ou sera que estou fazendo alguma coisa errada... So quero trocar a senha pra aprender a trabalhar com ele obrigado a todos!!!

    .:: bA

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão Re: erro Mysql (bobo mais não sei...)

    primeiramente execute
    mysql_install_db

    depois chown mysql.mysql /var/lib/mysql -R
    depois
    /etc/rc.d/rc.mysqld restart

    ai finalmente

    mysqladmin -u root password



  3. #3

    Padrão Re: erro Mysql (bobo mais não sei...)

    Ops e ae Benatto tranquilo, valew pela dica mais continua dando o erro. Dessa vez apareceu isso:

    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user: '[email protected]' (Using password: YES)'

    Ta dificil rsrss alguma outra dica! Sera que foi algum erro que cometi depois da instalação se caso eu remover o mysql e instalar denovo sera que funciona ou nunca tentou fazer isso. Valew fico no aguardo...

    .:: bA :-)

  4. #4

    Padrão Re: erro Mysql (bobo mais não sei...)

    Bem, eu não sou usuário de Slackware, mas MySQL é MySQL.

    O quê você está fazendo de errado é não especificar que está utilizando uma senha na hora de efetuar um logon no servidor MySQL. Tente da seguinte maneira:

    Código :
    # mysql -u root -psenha

    Se você omitir o hostname (-h), ele acessa o localhost. A senha é grudada mesmo junto ao "-p". Lembre-se também que a senha de root do banco não é a mesma senha de root do sistema, então são duas senhas distintas. O Debian por padrão deixa o serviço sem senha, agora no Slackware eu já não sei.


    Abraços!



  5. #5

    Padrão Re: erro Mysql (bobo mais não sei...)

    Citação Postado originalmente por Stéfano
    Código :
    # mysql -u root -psenha
    Opa e ae Stéfano tranquilo bom kra valew ae pelas diacas mais olhe so q estranho pensei ate que fosse funfa mais... Quando dou o comando aparece:

    [email protected]:/usr/bin# mysql -u root -psapato
    ERROR 1045: Access denied for user: '[email protected]' (Using password: YES)
    [email protected]:/usr/bin#

    Tentei usar a senha sapato o comando ta certo neh, igual o q vc me passu porque sera q ta dando esse erro sera que tem alguma coisa q eu possa fazer falowww!!!

    .:: bA q:-)

  6. #6

    Padrão Re: erro Mysql (bobo mais não sei...)

    Kra vai ai como eu sempre uso no meu slack 10.2:

    -> Instalar a base de dados
    mysql_install_db

    -> Permissao
    chown mysql.mysql /var/lib/mysql -R

    -> Iniciar o servico
    mysqld_safe &

    -> Criar a senha de root
    mysqladmin -u root password 'senha'

    -> Configuração de seguranca
    mysql_secure_installation
    -> Responda Y para todas as perguntas e repita a senha do root criada anteriormente

    -> Acessar
    mysql -u root -p

    -> Criar a base de dados
    create database NOMEDABASEDEDADOS;

    -> Dar permissao para as outras maquinas acessar o BD
    grant all privileges on <BaseDados>.* to '<user>'@'<IPEstacao ou %(indica tudo)>' identified by '<senha' with grant option;

    Espero q ajude...



  7. #7

    Padrão Re: erro Mysql (bobo mais não sei...)

    Ops agora parece que deu certo hehehehe a under mais uma vez obrigado a todos que colaboraram e deculpe a amolação rsrsrss. Até a proxima...


    .:: bA q:-)