+ Responder ao Tópico



  1. #1
    mhp
    Visitante

    Padrão Segunda placa de rede

    Olá,

    Estou tentando instalar uma placa de rede pci Via Rhine III em uma PCCHIPS M863G (sim, eu sei que é uma porcaria).
    Acontece o seguinte: sem a placa pci, a interface onboard (sis900) é reconhecida e configurada como eth0, mas se a pci for instalada, esta se torna a eth0. O problema é que a partir daí a interface onboard não é mais reconhecida, ou seja, se eu tentar levantá-la, retorna o erro "eth1: ERROR while getting interface flags: No such device", apesar de ser detectada e ter o módulo sis900 carregado. Já testei outras placas pci com chips diferentes e, para piorar, nem desabilitando a sis900 e colocando duas pci o sistema levanta a eth1.
    Estou usando a Debian testing (Etch), kernel 2.6.17. O mais curioso é que dei boot com o cd System Rescue (baseado na Gentoo, kernel 2.6.15) e as duas interfaces funcionaram.

    Alguma idéia?

  2. #2

    Padrão Re: Segunda placa de rede

    Ops e amigo! Não sei vai ajudar mais ai vai uma dica talvez resolva. Se os modulos das duas placa estão carregando tenta fazer o seguinte edita o arquivo /etc/modules.conf

    alias eth0 (modulo)
    alias eth1 (modulo)

    depois é so fazer a configuração da placas no arquivo /etc/rc.d/rc.inet1.conf e reinicie a máquina de o comando ifconfig como root para ver se aceitou a configuração. Estou usando o slackware mais achu q deve funfa com vc se não posta ae quem sabe outros podem podem te ajudar ou pelo menos tentar como eu hehehehe falow um abraço!

    .:: bA q:-)



  3. #3
    mhp
    Visitante

    Padrão Re: Segunda placa de rede

    O caso é com a merda da placa-mãe mesmo. Experimentei instalar a HD em outra máquina, com uma Soyo , e funcionou direitinho. Deve ter alguma coisa a ver com o roteamento das IRQs, ACPI, sei lá. Vou ter que continuar lutando, porque nesta altura vai pegar mal se eu pedir ao cliente que troque de máquina. Ô lixo de PC "Ching-Ling" :x

  4. #4

    Padrão Re: Segunda placa de rede

    caso ajude!

    nos testes que realizei, todas as placas de rede onboard ficam como secundárias nas pcchips.. já configurei uma m863 na boa!
    a placa off-board estava no slot pci1

    abraços..



  5. #5
    mhp
    Visitante

    Padrão Re: Segunda placa de rede

    O caso já foi resolvido. Instalei a Debian stable (Sarge), com o kernel 2.6.8 e as duas interfaces funcionaram. Quando eu tiver mais tempo quero pesquisar a causa do problema, mas acho que deve ser algum bug específico da distribuição testing atual. De qualquer modo, agradeço muito a atenção de vocês.
    Um grande abraço a todos.