+ Responder ao Tópico



  1. Pessoal

    Estou precisando implantar QOS no gateway linux para dar prioridade para o VOIP.
    Segui o tutorial http://www.vivaolinux.com.br/artigos...hp?codigo=4042 que usao o IPTABLES para marcar pacotes, mas nao tive sucesso.
    Entao olhando na internet estou tentanto algo mais simples so com o TC;
    O meu script que nao funciona é este:
    # rede local
    tc qdisc add dev eth0 root handle 1: htb default 20
    tc class add dev eth0 parent 1: classid 1:0 htb rate 512kbit

    tc class add dev eth0 parent 1:0 classid 1:10 htb rate 256kbit ceil 256kbit
    tc class add dev eth0 parent 1:0 classid 1:20 htb rate 256kbit ceil 256kbit

    tc qdisc add dev eth0 parent 1:10 handle 10: sfq perturb 10
    tc qdisc add dev eth0 parent 1:20 handle 20: sfq perturb 10

    tc filter add dev eth0 parent 1:0 protocol ip prio 1 u32 match ip dport 80 0xffff flowid 1:10
    tc filter add dev eth0 parent 1:0 protocol ip prio 1 u32 match ip dport 8081 0xffff flowid 1:20

    Coloquei o controle na placa de rede local para testar internamente, fazendo com que nestas duas portas a velocidade maxima seja 256 para download simultaneos.
    Fazendo o teste no terminal do proprio servidor os dois downloads chegam a 10MB e um anda mais rapido que outro.
    Onde esta meu erro?
    Depois de resolver este problema talvez eu volta a usar o IPTABLES para marcar pacotes.


    laerciok

  2. alguem pode ajudar?
    Sera que pode ser a versao do iproute? tenho a 20041019.
    como posso ver se os pacotes estao marcados?


    laerciok



  3. mais a placa que vai para os terminais é a eth0 mesmo ????

  4. Benatto

    eth0 - rede local
    eth1 - internet

    laerciok



  5. Citação Postado originalmente por laerciok Ver Post
    Benatto

    eth0 - rede local
    eth1 - internet

    laerciok
    Olá, eu resilvi o problema de controle de banda usando o HTB-Tools, até entaum eu estava tentando fazer tudo via codigo, o problema que eu naum conseguia limitar a banda por ip, somente para a iface inteira.

    Dai instalei e configurei o HTB-tools e Graças a Deus eu estou com este problema por enquanto solucinonado, blz, tente dar uma olhada, nele.






Tópicos Similares

  1. Controle de banda não funciona completamente Htb+tc
    Por lfernandosg no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-10-2010, 07:45
  2. HTB não funciona
    Por macvitor no fórum Servidores de Rede
    Respostas: 3
    Último Post: 25-04-2009, 09:54
  3. Mkpasswd não funciona
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-11-2002, 10:53
  4. Respostas: 3
    Último Post: 25-11-2002, 18:22
  5. Função Mail() não funciona
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 26-09-2002, 16:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L