+ Responder ao Tópico



  1. #1

    Padrão Compilar kernel em processador 64 bits

    fala galera.. como estão as coisas??

    pessoal, to com um problema aqui pra compilar o kernel em um micro com processador 64 bits...

    é um athlon 64 3000+
    debian sarge 3.1r3 x86_64
    o kernel atualmente instalado é o kernel-image-2.6.8-12-amd64-k8-smp
    estou com as versões do gcc instaladas:
    # dpkg -l gcc*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=========================-=========================-==================================================================
    ii gcc 3.3.5-3 The GNU C compiler
    un gcc-2.95 <none> (no description available)
    un gcc-3.2 <none> (no description available)
    ii gcc-3.3 3.3.5-13 The GNU C compiler
    ii gcc-3.3-base 3.3.5-13 The GNU Compiler Collection (base package)
    un gcc-3.3-doc <none> (no description available)
    ii gcc-3.4 3.4.3-13sarge1 The GNU C compiler
    ii gcc-3.4-base 3.4.3-13sarge1 The GNU Compiler Collection (base package)
    un gcc-3.4-doc <none> (no description available)
    un gcc-doc <none> (no description available)
    quando executo o make aparece a seguinte mensagem:

    # make
    CHK include/linux/version.h
    CC arch/x86_64/kernel/asm-offsets.s
    cc1: error: code model `kernel' not supported in the 32 bit mode
    make[1]: *** [arch/x86_64/kernel/asm-offsets.s] Error 1
    make: *** [prepare0] Error 2
    alguém sabe como resolver isso???

    valeu

  2. #2

    Padrão Re: Compilar kernel em processador 64 bits

    Viva Colega
    o seu compilador é para 32 bits, e nao para 64...
    vc tem de arranjar uma versao do gcc para 64 bits
    Um abraço.



  3. #3

    Padrão Re: Compilar kernel em processador 64 bits

    puts... q treta mesmo...

    mas to até vendo... o problema será instalar esse compilador 64 bits.. dará falha de dependência.. hehehe

    eu to vendo aqui, acho q vou usar outra distribuição... :/..

    na verdade eu não queria, mas como o debian pra 64 ainda é testing.. terei q fazer..