Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    zamberlan
    Pessoal, seguinte, estou com um problema para instalar a placa de som no meu Debian 3.1, acontece que tem o driver que vem junto com o CD da placa mãe que é a alsa-driver-1.0.9b, não estava conseguindo levantar o módulo da mesma, então, recompilei meu kernel com suporte a mais drivers de som para ver se conseguia levantar com algum, mas tb nada....

    Coloquei todos os suportes a drivers de som que tinha disponivel...

    zamberlan:/usr/src/linux-2.6.16.29/sound/pci# ls
    ac97 rme32.c snd-es1968.mod.c
    ad1889.c rme32.o snd-es1968.mod.o
    ad1889.h rme9652 snd-es1968.o
    ad1889.o rme96.c snd-fm801.ko
    ali5451 rme96.o snd-fm801.mod.c
    als4000.c snd-ad1889.ko snd-fm801.mod.o
    als4000.o snd-ad1889.mod.c snd-fm801.o
    atiixp.c snd-ad1889.mod.o snd-intel8x0.ko
    atiixp_modem.c snd-ad1889.o snd-intel8x0m.ko
    atiixp_modem.o snd-als4000.ko snd-intel8x0m.mod.c
    atiixp.o snd-als4000.mod.c snd-intel8x0m.mod.o
    au88x0 snd-als4000.mod.o snd-intel8x0m.o
    azt3328.c snd-als4000.o snd-intel8x0.mod.c
    azt3328.h snd-atiixp.ko snd-intel8x0.mod.o
    azt3328.o snd-atiixp.mod.c snd-intel8x0.o
    bt87x.c snd-atiixp-modem.ko snd-maestro3.ko
    bt87x.o snd-atiixp-modem.mod.c snd-maestro3.mod.c
    built-in.o snd-atiixp-modem.mod.o snd-maestro3.mod.o
    ca0106 snd-atiixp-modem.o snd-maestro3.o
    cmipci.c snd-atiixp.mod.o snd-rme32.ko
    cmipci.o snd-atiixp.o snd-rme32.mod.c
    cs4281.c snd-azt3328.ko snd-rme32.mod.o
    cs4281.o snd-azt3328.mod.c snd-rme32.o
    cs46xx snd-azt3328.mod.o snd-rme96.ko
    cs5535audio snd-azt3328.o snd-rme96.mod.c
    emu10k1 snd-bt87x.ko snd-rme96.mod.o
    ens1370.c snd-bt87x.mod.c snd-rme96.o
    ens1370.o snd-bt87x.mod.o snd-sonicvibes.ko
    ens1371.c snd-bt87x.o snd-sonicvibes.mod.c
    ens1371.o snd-cmipci.ko snd-sonicvibes.mod.o
    es1938.c snd-cmipci.mod.c snd-sonicvibes.o
    es1938.o snd-cmipci.mod.o snd-via82xx.ko
    es1968.c snd-cmipci.o snd-via82xx.mod.c
    es1968.o snd-cs4281.ko snd-via82xx-modem.ko
    fm801.c snd-cs4281.mod.c snd-via82xx-modem.mod.c
    fm801.o snd-cs4281.mod.o snd-via82xx-modem.mod.o
    hda snd-cs4281.o snd-via82xx-modem.o
    ice1712 snd-ens1370.ko snd-via82xx.mod.o
    intel8x0.c snd-ens1370.mod.c snd-via82xx.o
    intel8x0m.c snd-ens1370.mod.o sonicvibes.c
    intel8x0m.o snd-ens1370.o sonicvibes.o
    intel8x0.o snd-ens1371.ko trident
    Kconfig snd-ens1371.mod.c via82xx.c
    korg1212 snd-ens1371.mod.o via82xx_modem.c
    maestro3.c snd-ens1371.o via82xx_modem.o
    maestro3.o snd-es1938.ko via82xx.o
    Makefile snd-es1938.mod.c vx222
    mixart snd-es1938.mod.o ymfpci
    nm256 snd-es1938.o
    pcxhr snd-es1968.ko
    zamberlan:/usr/src/linux-2.6.16.29/sound/pci#

    Inclusive tem o alguns modulos que imaginava que poderia dar certo para funcionar e tentei com modprobe e nada...

    Outra coisa, quando tento pelos drivers do cd, digito ./configure e vai beleza até o final, mas quando dou make aparece a seguinte mensagem:

    make[3]: Leaving directory `/usr/audio/alsa-driver-1.0.9b/pci/vx222'
    make[2]: Leaving directory `/usr/audio/alsa-driver-1.0.9b/pci'
    make[2]: Entering directory `/usr/audio/alsa-driver-1.0.9b/usb'
    make[3]: Entering directory `/usr/audio/alsa-driver-1.0.9b/usb/usx2y'
    make[3]: Leaving directory `/usr/audio/alsa-driver-1.0.9b/usb/usx2y'
    make[2]: Leaving directory `/usr/audio/alsa-driver-1.0.9b/usb'
    make[1]: Leaving directory `/usr/audio/alsa-driver-1.0.9b'
    make -C /lib/modules/2.6.16.29/source SUBDIRS=/usr/audio/alsa-driver-1.0.9b O=/lib/modules/2.6.16.29/build modules
    make[1]: Entering directory `/usr/src/linux-2.6.16.29'
    CC [M] /usr/audio/alsa-driver-1.0.9b/acore/hwdep.o
    In file included from /usr/audio/alsa-driver-1.0.9b/include/adriver.h:677,
    from /usr/audio/alsa-driver-1.0.9b/include/sound/driver.h:42,
    from /usr/audio/alsa-driver-1.0.9b/acore/hwdep.c:22:
    include/linux/pci.h:460: error: syntax error before numeric constant
    make[4]: ** [/usr/audio/alsa-driver-1.0.9b/acore/hwdep.o] Erro 1
    make[3]: ** [/usr/audio/alsa-driver-1.0.9b/acore] Erro 2
    make[2]: ** [_module_/usr/audio/alsa-driver-1.0.9b] Erro 2
    make[1]: ** [modules] Erro 2
    make[1]: Leaving directory `/usr/src/linux-2.6.16.29'
    make: ** [compile] Erro 2
    zamberlan:/usr/audio/alsa-driver-1.0.9b#

    Se alguem quiser olha o meu lspci:

    zamberlan:/usr/audio/alsa-driver-1.0.9b# lspci
    0000:00:00.0 Host bridge: VIA Technologies, Inc.: Unknown device 0314
    0000:00:00.1 Host bridge: VIA Technologies, Inc.: Unknown device 1314
    0000:00:00.2 Host bridge: VIA Technologies, Inc.: Unknown device 2314
    0000:00:00.3 Host bridge: VIA Technologies, Inc.: Unknown device 3208
    0000:00:00.4 Host bridge: VIA Technologies, Inc.: Unknown device 4314
    0000:00:00.7 Host bridge: VIA Technologies, Inc.: Unknown device 7314
    0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    0000:00:0f.0 IDE interface: VIA Technologies, Inc.: Unknown device 3349
    0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
    0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
    0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
    0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
    0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
    0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
    0000:00:11.0 ISA bridge: VIA Technologies, Inc.: Unknown device 3287
    0000:00:11.7 Host bridge: VIA Technologies, Inc.: Unknown device 287e
    0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
    0000:00:13.0 PCI bridge: VIA Technologies, Inc.: Unknown device 287b
    0000:00:13.1 PCI bridge: VIA Technologies, Inc.: Unknown device 287a
    0000:01:00.0 VGA compatible controller: VIA Technologies, Inc.: Unknown device 3344 (rev 01)
    0000:02:00.0 PCI bridge: VIA Technologies, Inc.: Unknown device 287c
    0000:02:00.1 PCI bridge: VIA Technologies, Inc.: Unknown device 287d
    0000:02:01.0 0403: VIA Technologies, Inc.: Unknown device 3288

    e o lsmod:

    zamberlan:/usr/audio/alsa-driver-1.0.9b# lsmod
    Module Size Used by
    isofs 33848 1
    md5 4224 1
    ipv6 231680 14
    appletalk 33584 20
    parport_pc 33092 1
    lp 11204 0
    parport 33992 2 parport_pc,lp
    shpchp 42944 0
    pci_hotplug 10628 1 shpchp
    via_agp 9856 1
    agpgart 33244 1 via_agp
    ehci_hcd 27400 0
    usbcore 118660 2 ehci_hcd
    via_rhine 22148 0
    mii 5632 1 via_rhine
    crc32 4480 1 via_rhine
    nls_iso8859_1 4352 1
    vfat 12288 1
    fat 48156 1 vfat
    nls_cp437 6016 3
    ntfs 95092 1
    ide_cd 39044 1
    cdrom 36640 1 ide_cd
    ext3 124680 5
    jbd 50708 1 ext3
    ide_disk 15872 9
    ide_generic 1664 0 [permanent]
    via82cxxx 8964 0 [permanent]
    trm290 4484 0 [permanent]
    triflex 4096 0 [permanent]
    slc90e66 5888 0 [permanent]
    sis5513 14856 0 [permanent]
    siimage 11520 0 [permanent]
    serverworks 9096 0 [permanent]
    sc1200 7296 0 [permanent]
    rz1000 3072 0 [permanent]
    piix 10244 0 [permanent]
    pdc202xx_old 10624 0 [permanent]
    pdc202xx_new 8448 0 [permanent]
    opti621 4612 0 [permanent]
    ns87415 4552 0 [permanent]
    hpt366 18048 0 [permanent]
    hpt34x 5376 0 [permanent]
    generic 4868 0 [permanent]
    cy82c693 4868 0 [permanent]
    cs5530 5504 0 [permanent]
    cmd64x 11292 0 [permanent]
    atiixp 6032 0 [permanent]
    amd74xx 13724 0 [permanent]
    alim15x3 11532 0 [permanent]
    aec62xx 7424 0 [permanent]
    ide_core 114568 27 ide_cd,ide_disk,ide_generic,via82cxxx,trm290,triflex,slc90e66,sis5513,siimage,serverworks,sc1200,rz1000,piix,pdc202xx_old,pdc202xx_new,opti621,ns87415,hpt366,hpt34x,generic,cy82c693,cs5530,cmd64x,atiixp,amd74xx,alim15x3,aec62xx
    sd_mod 15888 0
    scsi_mod 135912 1 sd_mod
    unix 25136 404


    será que alguem pode me ajudar ?? :? :? :?

  2. Será que dá pra falar o modelo da sua placa de som e o modelo da sua placa-mãe?



  3. #3
    zamberlan
    Placa mãe ASUS P5V800-MX, o som é on-board.
    Descrição SoundMax ADI1986A Audio Driver V5.10.01.4150A

    No cd da placa mãe tem o driver de instalação para o linux dela ALSA-DRIVER-1.0.9B, e quando faço os procedimentos ./configure; make; make install que da o erro mencionado logo acima.

    Será que isso ajuda ?

  4. Tá usando qual versão do kernel? Se for a versão 2.4, atualize para a 2.6, pois vai facilitar muito a sua vida, a partir do momento que o ALSA está imbutido no kernel, então você não tem que compilar nada. Só instalar o kernel novo e no máximo intalar alguns binários do alsa, como o alsautils. Daí é só rodar o alsaconf e correr pro abraço.

    Tenho a mesma placa de som, mas a minha placa-mãe é uma A7V8X-X.



  5. #5
    zamberlan
    já estou usando a versão 2.6, mas inda não funcionou!
    olha a mensagem:

    zamberlan:/usr/audio/alsa-driver-1.0.9b# alsaconf
    modinfo: could not find module snd
    modinfo: could not find module snd
    modinfo: could not find module snd
    Unloading ALSA sound driver modules: (none loaded).
    Building card database...
    modinfo: could not find module snd-opl3sa2
    modinfo: could not find module snd-cs4236
    modinfo: could not find module snd-cs4232
    modinfo: could not find module snd-cs4231
    modinfo: could not find module snd-es18xx
    modinfo: could not find module snd-es1688
    modinfo: could not find module snd-sb16
    modinfo: could not find module snd-sb8
    zamberlan:/usr/audio/alsa-driver-1.0.9b#






Tópicos Similares

  1. Placa de som no Debian 3.1
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 5
    Último Post: 02-03-2006, 14:52
  2. Placa de Som no CL10 não reconhece
    Por Terry no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 06-04-2005, 15:20
  3. duas placas de rede no debian
    Por stumm no fórum Servidores de Rede
    Respostas: 7
    Último Post: 07-01-2005, 07:41
  4. Configurar placa de som no conectiva linux 8.0
    Por Slayter no fórum Servidores de Rede
    Respostas: 0
    Último Post: 01-12-2004, 09:36
  5. placa de som no slack 10(SW-5.1 Value da genius)
    Por no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 03-10-2004, 20:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L