+ Responder ao Tópico



  1. #1
    Su6mund0
    Visitante

    Padrão Proxy Transparente Squid 2.6!

    Estou usando a distribuição slackware 10.2, com o kernel 2.4.31. Infelizmente o proxy transparente não está funcionando. A baixo segue as opções que usei para compilá-lo:

    ./configure --prefix=/usr/local/squid --enable-delay-pools --enable-cache-digests --enable-arp-acl --enable-default-err-language=Portuguese --enable-storeio=aufs,coss,diskd,null,ufs --enable-removal-policies=heap,lru --enable-linux-netfilter --enable-pf-transparent

    Após o comando acima apareceu essa mensagem: Cannot find necessary PF HEADER FILE.

    Estou usando no: squid.conf: http_port 192.168.87.254:3128 transparent
    rc.firewall: iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
    rc.firewall: echo 1 > /proc/sys/net/ipv4/ip_forward.

    Infelizmente apenas o proxy transparente ainda não conseguir funcionar!


    Obrigado! :cry:

  2. #2

    Padrão Re: Proxy Transparente Squid 2.6!

    É que pra compilar o Squid tu precisa das bibliotecas do IPTables, incluido a libipt.h. Instale-a e tente de novo...



  3. #3
    Su6mund0
    Visitante

    Padrão Re: Proxy Transparente Squid 2.6!

    Desculpe a minha ignorância, mas meu iptables já foi instalando desde o inicio. Se possível detalhe melhor a forma correta de solucionar o problema citado.

    Obrigado!

  4. #4

    Padrão Re: Proxy Transparente Squid 2.6!

    remove

    --enable-pf-transparent

    e coloca isso

    --enable-linux-netfilter

    ai no http_port

    vc faz:

    http_port 3128 transparent




  5. #5

    Padrão Re: Proxy Transparente Squid 2.6!

    Citação Postado originalmente por Su6mund0
    Desculpe a minha ignorância, mas meu iptables já foi instalando desde o inicio. Se possível detalhe melhor a forma correta de solucionar o problema citado.

    Obrigado!
    Você provavelmente tem os binários do iptables, e não os headers...

  6. #6

    Padrão Re: Proxy Transparente Squid 2.6!

    Kra eu tenho o squiid rodadno no slack 10.2 comproxy transparente file.. fiz assim:

    Na instalação:
    ./configure --enable-default-err-language=Portuguese --enable-err-language="Portuguese" --bindir=/bin --sbindir=/sbin --sysconfdir=/etc/squid --libdir=/lib --enable-delay-pools --enable-linux-netfilter

    No final do squid.conf
    # Proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    coredump_dir /var/cache/squid

    No iptables:
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 3128

    *No meu caso a eth0 é a placa onde estão as estações da rede e a eth1 é onde entra a internet....

    Vo te indica meu professor de squid:
    http://www.linuxman.pro.br/squid/

    Espero q ajude, qualquer coisa posta ai...



  7. #7

    Padrão Re: Proxy Transparente Squid 2.6!

    --enable-pool ou --enable-epool (2.6)

    isso ajuda na performance !!!

  8. #8
    Su6mund0
    Visitante

    Padrão Re: Proxy Transparente Squid 2.6!

    Citação Postado originalmente por Stéfano
    Citação Postado originalmente por Su6mund0
    Desculpe a minha ignorância, mas meu iptables já foi instalando desde o inicio. Se possível detalhe melhor a forma correta de solucionar o problema citado.

    Obrigado!
    Você provavelmente tem os binários do iptables, e não os headers...

    Eu tenho instalado: iptables -V iptables v1.3.3 e também a instalação do iptables em /tmp/source/iptables-1.3.3. Como informo na configuração do squid a localização do iptables, para que possa resolver este problema?



  9. #9
    Su6mund0
    Visitante

    Padrão Re: Proxy Transparente Squid 2.6!

    Citação Postado originalmente por tuxson
    Kra eu tenho o squiid rodadno no slack 10.2 comproxy transparente file.. fiz assim:

    Na instalação:
    ./configure --enable-default-err-language=Portuguese --enable-err-language="Portuguese" --bindir=/bin --sbindir=/sbin --sysconfdir=/etc/squid --libdir=/lib --enable-delay-pools --enable-linux-netfilter

    No final do squid.conf
    # Proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    coredump_dir /var/cache/squid

    No iptables:
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 3128

    *No meu caso a eth0 é a placa onde estão as estações da rede e a eth1 é onde entra a internet....

    Vo te indica meu professor de squid:
    http://www.linuxman.pro.br/squid/

    Espero q ajude, qualquer coisa posta ai...
    tuxson
    Obrigado pela ajuda, mas esse tipo de configuração de proxy transparente não fuinciona no squid 2.6.

  10. #10
    Su6mund0
    Visitante

    Padrão Re: Proxy Transparente Squid 2.6!

    Caro colegas, finalmente conseguir resolver meu problema com o proxy transparente no squid 2.6.
    O problema em questão foi resolvido, com o carregamento do modulo iptable_nat.


    Obrigado a todos pela ajuda! :-D




  11. #11

    Padrão Re: Proxy Transparente Squid 2.6!

    http_port 3128 transparent

    coloca assim e tira as httpd_accel* do squid.. que no 2.6 roda !!