+ Responder ao Tópico



  1. #1

    Padrão Problemas para coloar o kernel 2.6 no slackware 11

    Galera seguinte, ja uso o slackware a um bom tempo e sempre atendeu minhas neceessidades, soh que agora preciso implantar um controle decente de p2p com patch de iptables layer7 e fazer ums ajustes finos no kernel baixei o kernel 2.6.18 ai começaram meus problemas.

    consigo compilar, adiciono as funcionalidades, consigo gerar o bzImage o System.map o config tudo certinho não da erro algum, o procedimento que usei para compilar o kernel foi:
    make clean
    make bzImage
    make modules
    make modules install
    o problema eh justamente os modulos quando copio o kernel novo para dar boot e configuro o lilo.conf ele da boot legal quando chega na parte dos modulos eis a questao naum consegue carregar quando inicia dou um lsmod ele naum retorna nada com isso minha placa de rede vai para o espaço tento subir o modulo dela "modprobe pcnet32" aparece invalid module format. procurei na internet vi em alguns tutoriais que precisava de uma ferramenta o module-init-tools, intalei blz sem erro tb mas mesmo assim nada, lembrando que eu estou em uma maquina virtual criada no vmware, mas acretito que isto naum influa tanto, então sera que ficarei sem o kernel 2.6.18 e minhas funcionalidades layer7 do iptables :?

  2. #2

    Padrão Re: Problemas para coloar o kernel 2.6 no slackware 11

    ???



  3. #3
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Re: Problemas para coloar o kernel 2.6 no slackware 11

    Cara, voce adicionou o suporte necessario a esses modulos na configuracao do kernel?

  4. #4

    Padrão Re: Problemas para coloar o kernel 2.6 no slackware 11

    sim



  5. #5
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão Re: Problemas para coloar o kernel 2.6 no slackware 11


    o layer 7 ta rodando ate o kernel 2.6.17

  6. #6

    Padrão

    Citação Postado originalmente por Benatto Ver Post
    o layer 7 ta rodando ate o kernel 2.6.17
    Benatto, o Layer7 esta funcionando perfeitamente no kernel 2.6.18. Ativei o layer7 como build-in no meu kernel e funcionou normalmente. Estou usando um kernel monolitico, isto é, sem suporte a modulos.
    O unico problema que tenho, é que nao consigo carregar modulos no kernel 2.6.18, pois o mesmo nem cria a pasta 2.6.18 em /lib/modules/. Existe o topico: Problema ao compilar kernel-2-6-18 com layer-7, que trata deste assunto.