sim o https n passa pelo squid tenta fazer isso aqui:

/ ip web-proxy access
add src-address=REDE_INTERNA dst-port=0-65535 action=allow comment="" disabled=no
add dst-port=!443 method=connect action=deny comment="allow CONNECT only to SSL ports 443 \[https\] and 563 \[snews\]" disabled=no
add dst-port=!563 method=connect action=deny comment="" disabled=no
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" disabled=no
add dst-port=0-65535 action=deny comment="Deny everything else" disabled=no

e coloque no seu NAT tmb isso aqui:

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=443 action=accept comment="Liberar SSL" disabled=no

Se for esse o problema vai resolver.