+ Responder ao Tópico



  1. Olá pessoal tudo bem?
    Estou implementando um servidor de buids (cruise control) aqui onde trabalho, e agora cheguei a um ponto onde tenho que fazer com que este servidor (cruisecontrol) que roda no daemon, lance uma aplicacao no servidor X.
    Hoje, da maneira com isso esta configurado da erro pois a aplicacao nao consegue acessar o X, ja que o processo do CruiseControl roda no console.
    O processo so funciona se eu rodar o CruiseControl de dentro do X.
    A pergunta é, existe uma maneira de eu fazer com que ao lancar o aplicativo via console, este aplicativo ache o servidor X e rode nele diretamente, ou eu terei que configurar o CruiseControl para rodar dentro do servidor.

  2. Faaala Von, quanto tempo cara, ve se aparece mais
    Pra rodar aplicacao voce precisa setar o display:

    setenv DISPLAY von:0.0

    Ai ele deve rodar tranquilo :P



  3. Caramba, é o PSY mesmo... faz teeeeeeeeeeeeeeeeempo hein,.,,,,
    hehehe

    Psy, me matei aqui, rodei pra la e pra ca coloquei tudo quanto era display que eu imaginei
    nomedamaquina:0.0, :0.0,:0, localhost:0.0
    e nao funcionou...
    fiz tudo isso com o export, ja que o setenv nao funciona nesta maquina onde estou.
    E o pior de tudo é que quando eu rodo o X eu nao consigo voltar ao console... entao estou p@#$@#$ da vida pois to perdendo o maior tempo para se configurar este cara.
    Vi várias paginas na net que falam a mesma coisa que voce e que explicam tintim por tintim como configurar isso (procurando por DISPLAY:0.0 ficou mais facil).. será que tem mais alguma coisa que eu nao configurei direito?

    Abração e valey psy

  4. Estranho ele nao ir pra outros terminais, ta em init 3?

    Com o export serve também...
    Quanto ao display creio que seja algo como:

    DISPLAY=hostname:0 ou DISPLAY=0.0 ou DISPLAY=0.1
    export DISPLAY
    xfig &

    (bash ou sh)




  5. Aqui funciona direitinho, meu desktop:

    Linux Aurora 2.6.17.13 #3 Wed Oct 11 16:24:43 BRT 2006 i686 prescott GNU/Linux
    Slackware 11.0

    Eu fiz assim:

    DISPLAY=aurora:0
    export DISPLAY
    xfig &

    gaim (por exemplo), ai ele abre o gaim no meu blackbox _o/







Tópicos Similares

  1. Instalar rpm do rh no slack tem como?
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 17
    Último Post: 24-06-2005, 07:52
  2. Ler partição RAID 0 no kurumin, tem como?
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-05-2004, 11:37
  3. WebCam no Linux...tem como???
    Por Vaza no fórum Servidores de Rede
    Respostas: 4
    Último Post: 08-11-2003, 02:01
  4. ASP NO LINUX TEM COMO?
    Por DIVORAK no fórum Servidores de Rede
    Respostas: 5
    Último Post: 06-05-2003, 13:01
  5. Spam no sendmail tem como?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-06-2002, 09:07

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L