+ Responder ao Tópico



  1. #1

    Unhappy Dúvida de proxy - ??? Como resolver???

    Olá amigos...

    Estou com uma dúvida enorme sobre proxy...
    Vou colocar um servidor MK em uma prefeitura para distribuir net para as máquinas internas.
    A prefeitura assina internet via rádio de um provedor. Porém o provedor usa proxy 8080. Hoje na prefeitura, está com servidor windows e utiliza iproxy pra compartilhar internamente.

    Coloquei assim e navega normalmente:
    0 chain=srcnat action=masquerade

    1 chain=dstnat dst-address=0.0.0.0/0 protocol=tcp dst-port=8080
    action=dst-nat to-addresses=IP-Internet to-ports=8080

    Porém essa regra é um dst-nat, ou seja... Não faz web-proxy.. Ele repassa os pacotes sem mesmo analizar..

    Quero saber se tem como eu utilizar o web-proxy pra fazer cache e sair pela porta 8080 na internet.

    E se tiver como não ter que colocar proxy nas máquinas internas melhor ainda.. Tipo fazer transparente... Tudo que vier na porta 80 redirecionar para web-proxy e sair na porta 8080 da internet..

    Alguém pode me ajudar???

    Grato

    Thiago

  2. #2

    Padrão

    Depois de vc ter habilitado o proxy como transparente ( System > Web-proxy > Setting) é só voce colocar o redirecionamento em IP > Firewall > Nat

    add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="" \
    disabled=no



  3. #3

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Depois de vc ter habilitado o proxy como transparente ( System > Web-proxy > Setting) é só voce colocar o redirecionamento em IP > Firewall > Nat

    add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="" \
    disabled=no
    Isso.. tudo bem amigo.. Mas isso é pra redirecionar tudo da porta 80 para a 8080 que está o web-proxy. Mas por default o web-proxy envia as requisições para a porta 80 da "internet". No meu caso ele tem que enviar as requisições para a porta 8080 da "internet"...

    hehe.. Meio complicado ainda né.. Num tem como dizer.. eu tenho que fazer meu web-proxy responder externamente usando a porta 8080...

    ...