+ Responder ao Tópico



  1. #1

    Padrão Problemas com NFS

    Amigos, to com o seguinte problema.

    Tenho o Micro1 e Micro2 (todos linux)

    No micro1 tenho as seguintes configurações:

    Código :
    micro1 [/etc] > cat exports
    /var/spool/mail 192.168.0.1     rw
    /home           192.168.0.1     rw
    /etc            192.168.0.1     rw
    /files/backup   192.168.0.1     rw

    E no micro2 eu tenho o seguinte
    Código :
    micro2 [/micro2/backup/internet/etc] > cat /etc/fstab
    /dev/sda1        swap             swap       defaults         0  0
    /dev/sda3        /                ext3       defaults         1  1
    /dev/sda2        /boot            ext3       defaults         1  2
    /dev/sdc1        /home            ext3       defaults         1  2
    /dev/sdb1        swap             swap       defaults         0  0
    /dev/sdb2        /dados           ext3       defaults         1  2
    /dev/sdd1        /vdocs           ext3       defaults         1  2
    none             /proc            proc       defaults         0  0
    none             /sys             sysfs      noauto           0  0
    none             /dev/pts         devpts     gid=5,mode=620   0  0
    192.168.0.254:/home             /micro2/backup/internet/home            nfs     soft,defaults           1  1
    192.168.0.254:/etc              /micro2/backup/internet/etc             nfs     soft,defaults           1  1
    192.168.0.254:/var/spool/mail   /micro2/backup/internet/mail            nfs     soft,defaults           1  1
    192.168.0.254:/files/backup     /micro2/backup/internet/egroupware      nfs     soft,defaults           1  1
    192.168.0.6:/dados              /micro2/backup/backup/dados             nfs     soft,defaults           1  1
    192.168.0.6:/etc                /micro2/backup/backup/etc               nfs     soft,defaults           1  1
    192.168.0.6:/ide/instalacao     /micro2/backup/backup/instalacao        nfs     soft,defaults           1  1

    Já efetuei o
    Código :
    mount -a
    e também consigo acessar e listar (visualizar) todos os arquivos dos mapeamentos montados, mas não consigo alterar nada.

    Vejam:

    Código :
    micro2 [/micro2/backup/internet/etc] > touch terra
    touch: cannot touch `terra': Permissão negada
    micro2 [/micro2/backup/internet/etc] >

  2. #2

    Padrão

    Eu efetuei as alterações para
    Código :
     /home           192.168.0.1(rw)
    no exports do servidor que está disponibilizando os mapeamnetos...

    E eu entro na pasta no servidor que está acessando os mapeamentos e não consigo fazer nada, pois aparece a mensagem:

    Código :
    micro2 [/micro2/backup/internet/etc] > cp exports exports1
    cp: impossível criar arquivo comum `exports1': Permissão negada
    micro2 [/micro2/backup/internet/etc] >

    Vejam com está meu /etc/fstab:
    Código :
    /dev/sda1        swap             swap       defaults         0  0
    /dev/sda3        /                ext3       defaults         1  1
    /dev/sda2        /boot            ext3       defaults         1  2
    /dev/sdc1        /home            ext3       defaults         1  2
    /dev/sdb1        swap             swap       defaults         0  0
    /dev/sdb2        /dados           ext3       defaults         1  2
    /dev/sdd1        /vdocs           ext3       defaults         1  2
    none             /proc            proc       defaults         0  0
    none             /sys             sysfs      noauto           0  0
    none             /dev/pts         devpts     gid=5,mode=620   0  0
    192.168.0.254:/home             /micro2/backup/internet/home            nfs     soft,defaults           1  1
    192.168.0.254:/etc              /micro2/backup/internet/etc             nfs     soft,defaults           1  1
    192.168.0.254:/var/spool/mail   /micro2/backup/internet/mail            nfs     soft,defaults           1  1
    192.168.0.254:/files/backup     /micro2/backup/internet/egroupware      nfs     soft,defaults           1  1
    192.168.0.6:/dados              /micro2/backup/backup/dados             nfs     soft,defaults           1  1
    192.168.0.6:/etc                /micro2/backup/backup/etc               nfs     soft,defaults           1  1
    192.168.0.6:/ide/instalacao     /micro2/backup/backup/instalacao        nfs     soft,defaults           1  1

    Eu efetuo um
    Código :
    mount -a
    , mas não acontece nada.

    Como eu reverto isso?

    Será que eu tenho que reiniciar o servidor mesmo? O mount -a não funciona?



  3. #3

    Padrão

    Tente no servidor, o comando exportfs -au (para limpar configurações antigas e aceitar as novas)

    Até

    mtec

  4. #4

    Thumbs up

    Me parece que funcionou.

    Vou fazer alguns testes e postarei o resultado....

    Obrigado por enquanto.



  5. #5

    Padrão

    Amigos, eu criei esse mapeamento para efetuar meus backups diários, mas nada.....

    Ainda não está funcionando.

    Ele dá permissão negada para todas as pastas do mapeamento.. pq?