+ Responder ao Tópico



  1. #1

    Question Perda de desempenho com o Squid

    Gente depois que coloquei o squid, minha internet fica muito lenta não sei o porque exatamente, quando eu tiro do firewall o encaminhamento para a porta do squid ela volta ao normal. Quanto entro no meu roteador (físico) e verifico as taxas de down e up elas com o squid startado ficam sempre entre 90% e 100% de uso, quando que após desabilitar o cache o up fica a menos de 2% e o down fica em torno de 20%.

  2. #2
    dbecher
    Visitante

    Padrão

    Caro colega,

    Antes de mais nada, três coisas:
    - Qual é a configuração de hardware do seu servidor de proxy?
    - Cole para nós seu squid.conf, para vermos se pode ser otimizado.
    - O servidor que tem o squid, roda algo mais além do proprio?

    Abraços!



  3. #3

    Post

    [Configuração]

    Intel Celeron 2.4 Ghz
    HD 40 GB PATA
    512 MB RAM
    3 Placas Rede 10/100/1000 - Realtek
    Debian 3.1rc3
    Squid 2.5.9

    [squid.conf]

    Código :
    ################################################################################
    ####                  Arquivo de configuração do Squid 2.5.9                ####
    ####                   Por Junio Vitorino - [email protected]                 ####
    ################################################################################
     
     
            hierarchy_stoplist cgi-bin ?
            acl QUERY urlpath_regex cgi-bin \? no_cache deny QUERY
     
    ### Cache
     
            cache_mem 128 MB
            cache_swap_low 90
            cache_swap_high 95
            maximum_object_size 30000 KB
            minimum_object_size 0 KB
            maximum_object_size_in_memory 4000 KB
            cache_dir ufs /var/spool/squid 5000 16 256
            cache_access_log /var/log/squid/access.log
            cache_log /var/log/squid/cache.log
            cache_swap_log /var/log/squid/swap.log
            debug_options ALL, 2
            dns_nameservers 200.20.158.77
            client_netmask 255.255.255.0 
            error_directory /usr/share/squid/errors/Portuguese
     
    ### Fim de cache
     
            hosts_file /etc/hosts
            refresh_pattern ^ftp:           1440    20%     10080
            refresh_pattern ^gopher:        1440    0%      1440
            refresh_pattern .               0       20%     4320
     
    ### Acl's Personalizadas
     
            acl admin src 10.0.1.230
            acl proibido url_regex -i "/etc/squid/filtros/proibido"
            acl liberado url_regex -i "/etc/squid/filtros/liberado"
            acl ext_block url_regex -i "/etc/squid/filtros/ext_block"
            acl ext_unblock url_regex -i "/etc/squid/filtros/ext_unblock"
     
    ### Fim Acl's Personalizadas
     
    ### http_access personalizadas
     
            http_access deny proibido !liberado !admin
            http_access deny ext_block !ext_unblock !admin
     
    ### Fim http_access personalizadas
     
    ### Acl's Padrões squid.conf
     
            acl all src 0.0.0.0/0.0.0.0
            acl manager proto cache_object
            acl localhost src 127.0.0.1/255.255.255.255
            acl to_localhost dst 127.0.0.0/8
            acl SSL_ports port 443 563      # https, snews
            acl SSL_ports port 873          # rsync
            acl Safe_ports port 80          # http
            acl Safe_ports port 21          # ftp
            acl Safe_ports port 443 563     # https, snews
            acl Safe_ports port 70          # gopher
            acl Safe_ports port 210         # wais
            acl Safe_ports port 1025-65535  # unregistered ports
            acl Safe_ports port 280         # http-mgmt
            acl Safe_ports port 488         # gss-http
            acl Safe_ports port 591         # filemaker
            acl Safe_ports port 777         # multiling http
            acl Safe_ports port 631         # cups
            acl Safe_ports port 873         # rsync
            acl Safe_ports port 901         # SWAT
            acl Safe_ports port 1483        # SQLSERVER
            acl purge method PURGE
            acl CONNECT method CONNECT
     
    ### Fim Acl's Padrões squid.conf
     
    ### Delay Pools
     
            acl administrativo url_regex -i 10.0.1
            acl academico url_regex -i 10.0.0
            delay_pools 2
            delay_class 1 2
            delay_parameters 1 -1/-1 -1/-1
            delay_class 2 2
            delay_parameters 2 5000/5000 5000/5000
            delay_access 1 allow administrativo
            delay_access 2 allow academico
     
    ### Fim Delay Pools
     
    ### Http_Access padrão squid.conf
     
            http_access allow manager localhost
            http_access deny manager
            http_access allow purge localhost
            http_access deny purge
            http_access deny !Safe_ports
            http_access deny CONNECT !SSL_ports
            http_access allow localhost
            http_access allow all
            http_reply_access allow all
     
    ### Fim http_access padrão squid.conf
     
            icp_access allow all
            miss_access allow all
            visible_hostname gateway.facsal.br
            coredump_dir /var/spool/squid
     
    ### Transparencia
     
            httpd_accel_host virtual
            httpd_accel_port 80
            httpd_accel_single_host off
            httpd_accel_with_proxy on
            httpd_accel_uses_host_header on
            http_port 3128
     
    ### Fim de Transparencia

    [Serviços]

    Cara esse computador faz o roteamento de internet e agora to tentando colocar o squid.

  4. #4

    Padrão

    Tente diminuir o valor da tag cache_dir dos 5000 para uns 300, reinicie o Squid e tente novamente. Aproveite e veja também os tamanhos dos seus logs e se alguém está utilizando o seu proxy (É sábio fechar o relay dele).

    Teste e mande os resultados.


    Abraços!



  5. #5

    Padrão

    cara...

    seu squid está com delay pools...

    é bem provável q seja isso q está deixando-o lento..

    esperimente retirar as linhas do daley pools e fazer um teste...

    valeu

  6. #6

    Padrão

    Hummm, ok acho que era o lance do delay pools, pois o desempenho melhorou mesmo, mas o foda e que eu tenho que arrumar um geito de controlar a banda do pessoal do academico, alguem tem alguma sugestão?



  7. #7

  8. #8

    Padrão

    Sabe aonde posso encontrar bons artigos sobre isso? Em minhas buscas no google, estou achando mais posts de pessoas com problemas e não muitos artigos.


    [UPDATE]

    Gente eu achei um tutorial no vivaolinux, que parece ser muito bom, mas lá ele está limitando por ip, ou seja para um pc específico, será que não teria como eu limitar por interface, ou seja a minha eth1?
    Última edição por juniovitorino; 03-11-2006 às 12:52.



  9. #9

    Padrão

    Droga, não consigo nem instalar o HTB, pelo apt-get não vai, e o que pego no site não compila. Foda alguém tem alguma dica?

  10. #10
    Acostamento
    Visitante

    Padrão

    Já exprementou colocar pra rodar ai o rc.bandlimit ?

    o q vc vai precisa é Ipchains ou Iptables , iproute2 , modulos do kernel de CBQ QoS ...

    os modulos CBQ e QoS .. eu creio q vc ja tenha, iptables tb...só msmo o iproute2, pra vc verificar se possui. Eu rodo ele aqui e fica blza..



  11. #11

    Padrão

    Cara com eu uso o Debian o que fiz, instalei o shaper que é o cbq para ele, mas o iproute2 o debian não achava nos repositórios, so achava o iproute então instalei ele.

    Dentro de /etc/shaper criei dois arquivos cbq-0002.academico_in32k e cbq-0002.academico_out32k com os seguintes conteúdos respectivamente:

    DEVICE=eth1,100Mbit,10Mbit #dúvida minhas interfaces são gigabit
    RATE=32Kbit #queria colocar 128 mas não sabia se eram a largura ou a taxa de transferencia aqui.
    WEIGHT=3Kbit
    PRIO=5
    RULE=10.0.0.0/24 # aqui não sei se esta aplicando a todoas as maquinas está certo?
    BOUNDED=yes
    ISOLATED=yes

    e o out.

    DEVICE=eth0,100Mbit,10Mbit
    RATE=32Kbit
    WEIGHT=3Kbit
    PRIO=5
    RULE=10.0.0.0/24,
    BOUNDED=yes
    ISOLATED=yes

    Só que agora, gostaria de saber uma coisa, quando inicio o shaper da essa mensagem, RTNETLINK answers: No such file or directory e não consigo achar o erro. E também gostaria de saber se tem uma forma pratica para testar se esta funcionando.

  12. #12

    Padrão

    cara..

    baixe o HTB-Tools e instale-o, é bem simples a instalação..

    valeu



  13. #13

    Padrão

    Nossa gente tá complicado, eu tava achando que era por causa do Shaper mas parece que não é pois desinstalei ele aqui e abri o monitor do meu roteador para ver como tavam as coisas e vejam só:

    http://www.facsal.br/junio/upload_status.JPG

    Isso nunca aconteceu, meu upload nunca ficou a mais que 10%, não estou vendo o porque disso será que o squid está causando isso? Tem alguma configuração que faz com que o squid faça isso? A internet cai e fica uns 30 segundos fora e depois retorna, achei também que era o shaper mas mesmo depois de desinstalar ele continua acontecendo.

  14. #14

    Padrão

    Aí lucianogf, blza ???

    kra to com o mesmo problema do amigo aí... eu tenho um P4 2.8 com 1GB de memória... como servidor de firewall para uma rede centralizada de 60 usuários ( 20 aqui no escritório, e mais 40 espalhados em duas cidades ). Quando eu ponho o proxy pra rodar nesse servidor ( o proxy no caso é só para os 20 usuários aqui do escritóri, pois nas outras cidades cada uma tem seu proxy ) a internet fica extremamente lenta... tipo, fica lenta pra abrir a página... pra download nao fica lento nao, o negócio é pra abrir página..... e como eu estou meio sem tempo.... tirei esse proxy e coloquei em uma maquina separada... aí ficou blza..... mas gostaria de deixar ele na mesma máquina do servidor de internet.....

    q q será q pode ser ???

    vou postar meu squid.conf

    hierarchy_stoplist cgi-bin ?
    #cache_effective_user squid
    #cache_effective_group root
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    visible_hostname FRIGO
    auth_param basic children 5
    auth_param basic realm Squid proxy-caching web server
    auth_param basic credentialsttl 2 hours
    #cache_mem 256 MB

    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    #INICIANDO AS ACLS
    acl Sites_Liberados url_regex -i "/etc/squid/sites.liberados"
    acl Sites_Bloqueados url_regex -i "/etc/squid/sites.bloqueados"
    acl Extensoes_Bloqueadas urlpath_regex -i "/etc/squid/extensoes.bloqueadas"
    acl rede_loc src 192.168.0.0/255.255.255.0

    #INICIANDO OS ACESSOS

    http_access allow manager localhost
    http_access allow Sites_Liberados !Sites_Bloqueados !Extensoes_Bloqueadas
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny rede_loc
    http_access deny all

    #http_reply_access allow all
    #icp_access allow all
    #coredump_dir /var/lib/squid/cache


    Configuraçao de Hardware ( servidor de internet ):

    Processador: Pentium 4 2.8 ghz
    Memória: 1GB memória ram DDR 400
    Sistema operacional: Slackware linux 11
    kernel 2.4.33