+ Responder ao Tópico



  1. #1
    dbecher
    Pessoal,

    Uso FC4 em dois servidores aqui e estou com uma dificuldade.

    Entro no ssh com o login de usuário normal e após dar um "su" para entrar como root, alguns comandos param de funcionar, inclusive o 'service'.

    Alguém tem idéia de como corrigir isso? Se é que realmente é um problema.

    []s

  2. o path muda quando vc se torna root..

    /sbin/service servico <opcao>

    resolve

    eh soh digitar o caminho completo que funciona

    OU
    colocar isso no bashrc

    export PATH=$PATH:/sbin:/usr/sbin




  3. #3
    dbecher
    Amigo, se não for pedir demais, vc saberia me dizer por quê ele muda o path?

    Resolveu meu problema, porém toda vez que logo como root, preciso dar o comando.
    Como automatiza isso?

    Abraço amigo, e, por enquanto, muito obrigado pela sua ajuda.

  4. Entro no ssh com o login de usuário normal e após dar um "su" para entrar como root, alguns comandos param de funcionar, inclusive o 'service'.
    Isso nao e' necessariamente um problema. O que acontece e' que quando voce digita apenas 'su' voce mantem as variaveis de ambiente (inclusive PATH) do usuario que voce logou, que por ser um usuario normal, sem privilegios, nao tem em seu PATH diretorios com binarios especificos para o super usuario, por isso se voce setar manualmente a variavel funciona.
    Para isso existe o argumento '-' do comando su. Da proxima vez, ao inves de digitar apenas su, digite

    su -

    Isso ira' carregar as variaves de ambiente do root, e voce nao precisara' setar manualmente a variavel PATH.

    Abs.

    Fabio K. Lima
    LPIC1/81913



  5. #5
    dbecher
    Colegas Alexandre e Fábio,

    MUITO OBRIGADO pela força. Obrigado pelas explicações.


    Abraços!






Tópicos Similares

  1. Hotspot não funciona após uma RB em Bridge!
    Por lennonvox no fórum Redes
    Respostas: 1
    Último Post: 29-07-2014, 19:39
  2. WebCam não Funciona após PCC
    Por jcmaster85 no fórum Redes
    Respostas: 25
    Último Post: 09-08-2012, 11:41
  3. AP2000 não funciona após troca da Fonte
    Por xandemartini no fórum Redes
    Respostas: 9
    Último Post: 27-04-2007, 20:11
  4. Respostas: 0
    Último Post: 12-07-2005, 15:42
  5. vsftpd não funciona mais após uma queda de energia
    Por stallion no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-03-2005, 19:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L