+ Responder ao Tópico



  1. #1

    Padrão Dependências para o nagios

    Galera,

    quando vou instalar o nagios via rpm, me aparece a seguinte mensagem xiando de depências:

    rpm -ivh nagios-2.5-1.rh9.rf.i386.rpm
    error: failed dependencies:
    libgd.so.1.8 is needed by nagios-2.5-1.rh9.rf
    libltdl.so.3 is needed by nagios-2.5-1.rh9.rf
    libperl.so is needed by nagios-2.5-1.rh9.rf
    libpng12.so.0 is needed by nagios-2.5-1.rh9.rf
    libttf.so.2 is needed by nagios-2.5-1.rh9.rf

    Como resolver a falta desses arquivos?

    Obrigado!

  2. #2

    Padrão

    Citação Postado originalmente por roggy Ver Post
    Galera,

    quando vou instalar o nagios via rpm, me aparece a seguinte mensagem xiando de depências:

    rpm -ivh nagios-2.5-1.rh9.rf.i386.rpm
    error: failed dependencies:
    libgd.so.1.8 is needed by nagios-2.5-1.rh9.rf
    libltdl.so.3 is needed by nagios-2.5-1.rh9.rf
    libperl.so is needed by nagios-2.5-1.rh9.rf
    libpng12.so.0 is needed by nagios-2.5-1.rh9.rf
    libttf.so.2 is needed by nagios-2.5-1.rh9.rf

    Como resolver a falta desses arquivos?

    Obrigado!
    Cara, quase certeza que vc não tem essas libs instaladas...
    Dai vc vai ter que instalar e ir testando até ele parar de reclamar.

    Procure primeiramente por gd, perl, libpng...
    GD Graphics Library

    mas procura no site rpmseach que é mais facil pra vc.
    Ele pode até funcionar sem algumas dessas libs, mas não fica 100% não..

    Procura as libs, instala e o que não souber... só falar.
    Abraço.



  3. #3

    Padrão

    Cara, quase certeza que vc não tem essas libs instaladas...
    Dai vc vai ter que instalar e ir testando até ele parar de reclamar.
    Com certeza amigo, mas ja estou garimpando aqui para encontrá-las. Só queria saber se havia alguma forma facil de resolver.

    []'s