Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    marcoaurelio
    Olá pessoal,


    Estou compilando o kernel 2.6.18.1 com o modulo Layer7 v2.6, aplicado o patch e setado no make menuconfig, até ai tudo bem, mas na compilação dos modulos ocorre um problema:

    CC [M] net/ipv4/netfilter/ipt_layer7.o
    net/ipv4/netfilter/ipt_layer7.c: In function ‘match_no_append’:
    net/ipv4/netfilter/ipt_layer7.c:253: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘size_t’
    net/ipv4/netfilter/ipt_layer7.c: At top level:
    net/ipv4/netfilter/ipt_layer7.c:473: warning: initialization from incompatible pointer type

    Apliquei o patch e não ocorreu nenhum erro, setei o modulo tranquilo dentro do menuconfig, estou usando a distr. FC6.

    [root@orsp0918 linux-2.6.18.1]# patch -p1 < /usr/src/netfilter-layer7-v2.6/kernel-2.6.18-layer7-2.6.patch


    Se alguem puder dar uma ajuda neste caso agradeço muito.

  2. kra já aconteceu algo assim comigo tbem, dae o que eu fiz, peguei o kernel 2.6.18.2 e peguei o netfilter mais atual e apliquei, dae consegui ter sucesso na compilação, testa ae, veja o que dá, e outra coisa, tu ta marcando este modulos Connection tracking flow accounting e Connection mark tracking support



  3. #3
    marcoaurelio
    Puts cara nem olhei estas opções vou seguir o seu caminho, estou usando o netfilter-layer7.v2.6 só falta pegar o kernel 2.6.18.2. Deixa eu tirar um dúvida precisa recompilar o iptables? pois na distr. que estou usando esta com a versão 1.3.5, e mais, que distr. vc usou ???


    Valeu meu velho, fico no aguardo !

  4. Citação Postado originalmente por marcoaurelio Ver Post
    Puts cara nem olhei estas opções vou seguir o seu caminho, estou usando o netfilter-layer7.v2.6 só falta pegar o kernel 2.6.18.2. Deixa eu tirar um dúvida precisa recompilar o iptables? pois na distr. que estou usando esta com a versão 1.3.5, e mais, que distr. vc usou ???


    Valeu meu velho, fico no aguardo !
    sim tu, vai ter que recompilar o iptables sim. Uso Debian



  5. Por que vc nao usa o kernel 2.4.31 que acompanha o slackware 10.2 ou ate o 2.4.33 que acompanha o 11.0 que dou uma mao, sou apaixonado por esse slackware nao tem nada melhor !!! hehehe


    Abraçao






Tópicos Similares

  1. Compilando Kernel com controladora SCSI
    Por felipeasc no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-07-2005, 09:52
  2. Kernel com Suporte built in.
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-07-2003, 10:27
  3. Compilando PHP com Interbase
    Por PiTsA no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-12-2002, 13:56
  4. Compilando kernel 2.4.20
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-12-2002, 12:21
  5. Atualizaçao kernel com (grub)
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-11-2002, 19:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L