+ Responder ao Tópico



  1. #1

    Unhappy Placas de redes variando

    Pode parecer estranho o título mas é isso mesmo. Eu tenho 3 placas de rede e a cada boot o sistema escolhe uma para ser a eth0.

    Não sei o que fazer. Estou utilizando o suse 9.1 aqui.

    Qual a parte do sistema que reconhece o hardware de rede e escolhe qual a placa será a placa de rede. Ele não está fixando isso.

  2. #2

    Thumbs up

    Amigo, eu li em algum tópico aqui algo sobre isso. Não me lembro agora em que seção. Mas acho que nessa seção mesmo.
    Alguém respondeu exatamente a ordem de boot. E eu também não sabia.
    Eu tive esse problema com um servidor onde instalei na época o Slackware 10.2. Quando colocava as 3 placas, invertia tudo. Aí fui instalando uma a uma e descobrindo quem era quem. Até que deu certo.
    Mas eu sei que alguém respondeu a ordem de carga das placas. Tem algo a ver com alias de cada placa também.
    Vamos ver se alguém mais responde esse tópico.



  3. #3

    Padrão

    Desabilita o hotplug e coloca pra carregar os módulos das placas na ordem que vc quiser.
    Os demais módulos do hotplug vc pode mandar carregar tb. Bom que seu boot fica mais rapido tb.

    Ab | Se não der tudo certo, volte a postar.

  4. #4



  5. #5

    Padrão

    O problema é que o suse não usa mais o hotplug e sim o udev. O problema é esse mesmo. o carregamento dos módulo. No caso eu tenho uma placa que quero que seja a eth0 com módulo e100 e duas que usa o tg3. Na verdade não me importa nem um pouco qual placa vai ser a eth1 e eth2 mas a eth0 tem de ser a off-board com módulo e100. Acho que vou mandar carregar ela logo no início no /etc/modprobe.conf

    Vou testar isso na segunda mas eu quero saber como vou fazer com outro servidor que são 4 placas sendo as 4 IBM com módulo tg3.

    Se tiverem mais idéias e puderem me enviar eu agradeço.

  6. #6

    Padrão

    alguem tem mais alguma idéia?