Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. e ai galera
    to me batendo aki com um balanceamento....
    fiz ele (segue abaixo script) funcionou mas ficou muito lento...
    nao sei o que pode ser....
    deem uma olhada no script abaixo....

    / ip address
    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=Saida comment="" \
    disabled=no
    add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=Link2 \
    comment="" disabled=no
    add address=192.168.0.2/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Link1 \
    comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting in-interface=Saida connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Saida connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Saida connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Saida connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.2.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=192.168.0.2 \
    to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment="" \
    disabled=no

    Desde ja agradeço a ajuda...

    abrass...t+

  2. Não sei se é necessário, mas tente especificar o seguinte:
    src-address=192.168.1.0/24

    na regra do Mangle, apos o
    in-interface=Saida

    Aparentemente está tudo certo. Teria que ver se não tem outras regras no Mangle.

    Se você acompanhar os mangles, aparece pacotes sendo marcados?
    e no Interfaces, aparece trafego nas duas interfaces de entrada?

    Faça um teste, especificando um unico cliente no (src-address) e teste nele como fica.

    Seus links são de quanto cada um? Qual a caracteristica deles? Full, ADSL?



  3. Citação Postado originalmente por liandrocarniel Ver Post
    Não sei se é necessário, mas tente especificar o seguinte:
    src-address=192.168.1.0/24

    na regra do Mangle, apos o
    in-interface=Saida

    Aparentemente está tudo certo. Teria que ver se não tem outras regras no Mangle.

    Se você acompanhar os mangles, aparece pacotes sendo marcados?
    e no Interfaces, aparece trafego nas duas interfaces de entrada?

    Faça um teste, especificando um unico cliente no (src-address) e teste nele como fica.

    Seus links são de quanto cada um? Qual a caracteristica deles? Full, ADSL?
    Amigo ja resolvi aki
    meu erro foi uma inversao de Packets no NAT...achei estranho...mas funcionou...hehe


    vlww...abrass...t+

  4. Citação Postado originalmente por adminegg Ver Post
    Amigo ja resolvi aki
    meu erro foi uma inversao de Packets no NAT...achei estranho...mas funcionou...hehe


    vlww...abrass...t+
    você poderia me apontar exatamente onde estaria o seu erro pq nao entendi o que vc falou nao



  5. Citação Postado originalmente por adminegg Ver Post
    Amigo ja resolvi aki
    meu erro foi uma inversao de Packets no NAT...achei estranho...mas funcionou...hehe


    vlww...abrass...t+
    Seria bom que voce mostrasse onde errou, pois sempre que os procura tentamosajudar, entao quando solucionado o problema é bom que lebre-se também de nos dizer onde acertou...






Tópicos Similares

  1. Respostas: 3
    Último Post: 19-01-2003, 10:32
  2. erro apos compilar o kernel
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 09-12-2002, 09:54
  3. APÓS AS REGRAS IPTABLES
    Por NoiseMaster no fórum Servidores de Rede
    Respostas: 4
    Último Post: 19-11-2002, 16:25
  4. Linuxconf e man ficam estranhos apos rodar o kde
    Por clmr no fórum Servidores de Rede
    Respostas: 0
    Último Post: 04-10-2002, 13:45
  5. balanceamento de carga
    Por wolvie no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-04-2002, 23:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L