+ Responder ao Tópico



  1. #1
    vagampert
    Visitante

    Padrão problema no som no Kalango

    e ai pessoal beleza... gurizada to com um problema no som do kalango..
    qdo executo o live cd ele funciona sem problema porem qdo instalo no hd não carrega o módulo... ja tentei de tudo mas não funciona...
    haha minha placa de som é ISA Yamaha OPL3SA2, se executar o alsaconf beleza funfa de primeira mas se eu reiniciar, volta tudo de novo... ou seja o modulo não levanta, ja tentei salvar a configuraçao com o alsactl store mas não adianta... queria uma ajuda para que funcionasse de primeira...
    não quero cada vez que reinicio usar modprobe ou alsaconf... bhhhaa é chato né... ja tive este problema com o mandriva 10 que nem reconhecia a placa no sndconf...

    ja detectei minha placa com o comando isapnp ta tudo OK...

    se alguem me ajudar agradeço desde ja....
    valew

  2. #2

    Arrow

    Cara, pra vc não te que ficar carregando o módulo toda vez, basta colocar ele pra ser carregado junto com os outros. Deve ser em /etc/rc.d... algumacoisa.modules

    dentro do arquivo terá um mooonte de módulos sendo carregados e dai basta inserir o seu lá.

    Durante a execusão do alsaconf, ele no final, te pergunta se vc quer gravar as modificações em um arquivo... e te mostra qual o arquivo. Esse é o arquivo dito anteriormente. Se o alsaconf perguntar se vc quer gravar vc deve responder que sim.

    no mais é só isso.
    Ab



  3. #3

    Padrão

    O nome do arquivo que o amigo mencionou é /etc/modules.

  4. #4
    vagampert
    Visitante

    Padrão

    cara ja tentei adicionar o comando modprobe mais o nome do modulo mais não adiantou...não sei o que fço pois qdo reinicio some as configurações....
    o arquivo esta no /etc/modprobe.d/ este é o arquivo que o alsaconf modifica né...

    mas valew pela dica,,;;;



  5. #5

    Padrão

    Faz o seguinte então... reinicia a máquina, dá um lsmod pra ver quais módulos estão carregados e guarda uma cópia disso (lsmod > copia_lsmod), depois vc roda o alsaconf, ele carrea os outros módulos e novamente vc da um lsmod pra comparar com o primeiro.

    Feito isso vc saberá o que foi carregado pra poder editar o arquivo e mandar carregar na inicialização.

    talvez vc deva estar digitando o nome errado do módulo, e pra saber se isso tá acontecendo, acha ai mais ou menos o nome do módulo e faz uma busca no google por modprobe nomedomodulo

    Testa ai...
    Ab