Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão Redirecionar clientes em atraso para página local

    HI, pessoal alguem ja fez esse redirecionamento? quero forçar meus clientes em atrazo para uma pagina local de cobrança, desta forma ele fica sem navegação, parcialmente bloqueado, antes de bloqueio total.

  2. #2

    Padrão

    nunca utilizei essa ferramenta mais já li muito sobre isso... tem como fazer isso em adversingment no hotspot.



  3. #3

    Smile

    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no

  4. #4
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no
    Valeu brother, vou testar aqui.



  5. #5

  6. #6

    Wink

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no
    Opa, serve tbm para qualquer tipo de cliente, PPPoE, etc... basta colocar o ip do cliente que quando ele for navegar, solicitando porta 80, vai jogar para um servidor web com a página de bloqueio..
    bem pensado.
    Abraços



  7. #7

    Padrão

    pra quem usa um gerenciador externo ao mt...tipo eu q conecto por telnet e passo os comandos...pode se criar uma regra bloqueando ips de uma determinada lista..

    ae é soh vc adicionar o ip na lista q ele é bloqueado..aos mais experts ae...me digam se isso funga mesmo...


    algo assim...nunca testei mas acho q funga..

    chain=dstnat protocol=tcp dst-port=80 src-address-list=block_parcial action=dst-nat to-addresses=xxx.xxx.xxx.xxx to-ports=80

    flws...t+

  8. #8

    Padrão

    Citação Postado originalmente por Mr_Dom Ver Post
    pra quem usa um gerenciador externo ao mt...tipo eu q conecto por telnet e passo os comandos...pode se criar uma regra bloqueando ips de uma determinada lista..

    ae é soh vc adicionar o ip na lista q ele é bloqueado..aos mais experts ae...me digam se isso funga mesmo...


    algo assim...nunca testei mas acho q funga..

    chain=dstnat protocol=tcp dst-port=80 src-address-list=block_parcial action=dst-nat to-addresses=xxx.xxx.xxx.xxx to-ports=80

    flws...t+
    Um programador esta fazedno isso para mim em java com esse raciocinio.



  9. #9
    Moderador Avatar de xandemartini
    Ingresso
    Nov 2005
    Localização
    Espumoso, Brazil
    Posts
    2.410
    Posts de Blog
    1

    Padrão

    Estas regras só funcionam se o MK estiver fazendo NAT? Se estiver somente como bridge (uso o myauth pra NAT e Controle de Banda) como faria isto?

  10. #10

    Cool Redirecionar para alguma porta no Servidor WEB

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no

    => Aki funcionou legal esta regra porem ela esta direcionando para a porta exemplo...

    alguem sabe como configurar meu servidor web para apontar para uma pagina especifica
    dai ao inves de apontar par porta 80 apontaria para por 8081 exemplo

    e esta apontaria para uma pagina avisodebloqueio q esta no me servidor web...

    abraço para Galera em Geral

    Feliz Natal a Todos... e Prospero Ano novo

    Alexandre
    CaracolNET



  11. #11

    Padrão

    Não sei se é possível, mas já pensei em algo dentro do proprio mikrotik.
    uma requisição através do hotspot, ao invés de aparecer a tela de login, aparecia a tela de aviso ....hehehehehe
    Pode ser, vou estudar mais sobre isso.....
    Prometo que se descobrir algo, posto aqui ...

  12. #12

    Padrão

    bom pessoal é possivel sim ta ai um codigo que eachei no forum original do
    SO

    chain=dstnat src-address=80.x.x.x protocol=tcp dst-port=80 action=dst-nat to-addresses=80.x.x.y to-ports=8001


    esse é o post original do site

    Hello,
    I have problems to redirect non-paying clients to warning web page. I made dst-nat rule, but it wont redirect. Ok, clients do not have Internet enymore, but they don't see the warning. My rule:
    chain=dstnat src-address=80.x.x.x protocol=tcp action=dst-nat
    to-addresses=80.x.x.y to-ports=8001

    Where could be problem?? I also tried to put in the rule dst-port=80, but no changes..


    agora a resposta


    Make that a
    Code:
    chain=dstnat src-address=80.x.x.x protocol=tcp dst-port=80 action=dst-nat to-addresses=80.x.x.y to-ports=8001
    (include the dst-port paramter) or your webserver will see all kinds of TCP traffic redirected to it which it cannot really handle (SMTP, FTP, ...).

    If you made sure you have a webserver running on port 8001 at the address you redirect to, also take care to configure it so every errorpage (especially the 404 one) will show your "we're missing money from you"-page. (As your client will perhaps request http://www.someaddress.com/this/other/page.html - and your webserver won't have that special file...)

    If that doesn't work, try to explain better what acutally happens ("it won't redirect, but they do not have internet"?).


    ta ai o link pra quem quiser ver

    Mikrotik :: View topic - Client redirect to a web page



  13. #13
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Não sei se é possível, mas já pensei em algo dentro do proprio mikrotik.
    uma requisição através do hotspot, ao invés de aparecer a tela de login, aparecia a tela de aviso ....hehehehehe
    Pode ser, vou estudar mais sobre isso.....
    Prometo que se descobrir algo, posto aqui ...
    Ficaria muito massa.

  14. #14

    Thumbs up Funcinou Belezinha

    Galera

    Agradeço de mais por esta dica... funcionou como uma luva!!!

    perfeito

    consegui tb fazer o direcionamento para uma pagina de aviso de bloquio ouvindo a porta 8081 e criando um virtualhost em meu servidor apache...

    Obrigado

    Alexandre
    CaracolNET



  15. #15
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por caracolnet Ver Post
    Galera

    Agradeço de mais por esta dica... funcionou como uma luva!!!

    perfeito

    consegui tb fazer o direcionamento para uma pagina de aviso de bloquio ouvindo a porta 8081 e criando um virtualhost em meu servidor apache...

    Obrigado

    Alexandre
    CaracolNET
    Qual das regras vc usou ?

  16. #16

    Padrão

    Isto funciona mesmo para quem nao usa Hotspot?

    valeu ai.



  17. #17

    Padrão

    MAs .. a final..qual regra foi usada...essa última??? E no meu caso usso PPPoe com Ips válidos e dinamicos...tem como funcionar????
    Última edição por maxtex; 01-01-2007 às 18:24.

  18. #18
    psychopunk
    Visitante

    Padrão Nao estou conseguindo fazer :(

    Opa pessoal..aqui eu uso hotspot e nao funcionou o re-direcionamento..

    eu tenho um bloqueio.html em http://192.168.100.1/bloqueio.html, sendo que esse ip é onde todos os clientes sã redirecionados pra autencicação antes de navegar e o bloqueio.html ta junto com os arquivos de autenticação do hotspot..queria que um determinado ip ex: "192.168.100.14" quando autentica-se fosse re-direcionado pra http://192.168.100.1/bloqueio.html e sem possibilidades de ter acesso externo a não ser a página bloqueio.html



  19. #19

    Padrão

    Caro colega psychopunk,
    se bem entendi, essa idéia sua é a minha intenção, acho que pode funcionar sim. Deixa ver se entendi direito: vc criou uma página http://192.168.100.1/bloqueio.html dentro do diretório hotspot, agora vc quer redirecionar o ip do cliente em atrazo pra essa página, ao invés da default. Isso mesmo ?
    Vamos trocar umas idéias, quem sabe conseguimos fazer funcionar e depois postamos aqui pra galera. [email protected].
    Abraços ......

  20. #20
    psychopunk
    Visitante

    Padrão

    Seguinte...eu quero que o cliente que esta em atraso se logue normal, mais quando efetuar o login que seja re-direcionado pro bloqueio.html que está dentro do diretorio do hotspot