estou tentado rodar o postfix + postgrey do slack 11, quando starto o postgrey dá o seguinte erro

[email protected]:/# /usr/local/postgrey/postgrey
BerkeleyDB needs compatible versions of libdb & db.h
you have db.h version 4.2.52 and libdb version 4.4.20
Compilation failed in require at /usr/local/postgrey/postgrey line 14.
BEGIN failed--compilation aborted at /usr/local/postgrey/postgrey line 14.

linha 14 - use BerkeleyDB;

no cpan
BerkeleyDB is up to date (0.31).

o que pode ser ??