Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde pessoal.
    Estou configurando um servidor apache porém ele está fazendo uma coisa muito estranha.

    Eu configurei dois VirtualHost.

    <VirtualHost sap.dominio.com.br>
    ServerAdmin suporte@dominio.com.br
    DocumentRoot /export/htdocs-sap/html
    ServerName sap.dominio.com.br
    ErrorLog logs/sap-error_log
    CustomLog logs/sap-access_log common

    ProxyPass /sap http://localhost:8084/sap
    ProxyPassReverse /sap http://localhost:8084/sap
    </VirtualHost>

    <VirtualHost auth.dominio.com.br>
    ServerAdmin suporte@dominio.com.br
    DocumentRoot /export/htdocs-auth/html
    ServerName auth.dominio.com.br
    ErrorLog logs/auth-error_log
    CustomLog logs/auth-access_log common

    ProxyPass /auth http://localhost:8085/auth
    ProxyPassReverse /auth http://localhost:8085/auth
    </VirtualHost>

    Quando eu tento acessar http://sap.dominio.com.br ele carrega normalmente essa página, porém quando eu tento acessar http://auth.dominio.com.br ele insiste em carregar o conteúdo do outro domínio.

    Alguém poderia me ajudar a descobrir o que estou fazendo de errado?

  2. Você por acaso já tentou resolver este nome fora da sua rede para saber se ele não é um daqueles domínios malucos?



  3. assim:

    NameVirtualHost *:80

    <VirtualHost *:80>
    ServerAdmin suporte@dominio.com.br
    DocumentRoot /export/htdocs-sap/html
    ServerName sap.dominio.com.br
    ServerAlias www.sap.dominio.com.br
    ErrorLog logs/sap-error_log
    CustomLog logs/sap-access_log common

    ProxyPass /sap http://localhost:8084/sap
    ProxyPassReverse /sap http://localhost:8084/sap
    </VirtualHost>

    <VirtualHost *:80>
    ServerAdmin suporte@dominio.com.br
    DocumentRoot /export/htdocs-auth/html
    ServerName auth.dominio.com.br
    ServerAlias www.auth.dominio.com.br
    ErrorLog logs/auth-error_log
    CustomLog logs/auth-access_log common

    ProxyPass /auth http://localhost:8085/auth
    ProxyPassReverse /auth http://localhost:8085/auth
    </VirtualHost>


    tenta assim.. usando o NameVirtualHost !!

  4. Sinceramente não sei o que aconteceu... sem eu fazer nada a página começou a ser carregada corretamente... estranho...

    Será que foi alguma coisa relacionada a cache???



  5. pode ser... rsrr






Tópicos Similares

  1. VirtualHost
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 09-12-2004, 11:27
  2. Apache com SSL em VirtualHosts
    Por ed_nargo no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-02-2004, 15:33
  3. apache user e group dentro de virtualhost
    Por itamarjp no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-12-2003, 12:50
  4. VirtualHost nao esta 100%
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-02-2003, 16:06
  5. Autenticacao usando VirtualHost com ProxyPass
    Por clever no fórum Servidores de Rede
    Respostas: 0
    Último Post: 19-12-2002, 12:54

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L